aboutsummaryrefslogtreecommitdiff
path: root/mail/sqwebmail/Makefile
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2003-01-09 14:28:40 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2003-01-09 14:28:40 +0000
commit94972d6fdb7e686fcab6262fe92277773532109b (patch)
tree5840024813194bfb4f9777c2b446fe10ffed1ffd /mail/sqwebmail/Makefile
parent7e3ac56c12f700ed5b6dc836500d6d9f8825bd5e (diff)
New user config options for sqwebmail
PR: 44888 Submitted by: Scott Lampert <scott@lampert.org>
Notes
Notes: svn path=/head/; revision=72806
Diffstat (limited to 'mail/sqwebmail/Makefile')
-rw-r--r--mail/sqwebmail/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 1f0633a0f34d..dacaa0f8a33a 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -43,6 +43,11 @@ IMAGEURL?= ${WEBDATASUBDIR}
# set WITH_TIMEOUTSOFT to something other than 1200 seconds (20m)
# set VCHKPW to the home of the vpopmail user, if necessary
#
+# The following settings are in bytes:
+# set WITH_MAXMSGSIZE to max size of messages (including attachments)
+# set WITH_MAXARGSIZE to max size of a text message (excluding attachments)
+# set WITH_MAXFORMARGSIZE to max size of attachments
+
CACHEDIR?= /var/sqwebmail/cache
CACHEOWNER?= bin
@@ -128,6 +133,18 @@ CONFIGURE_ARGS+= --enable-hardtimeout=${WITH_TIMEOUTHARD}
CONFIGURE_ARGS+= --enable-softtimeout=${WITH_TIMEOUTSOFT}
.endif
+.if defined(WITH_MAXMSGSIZE)
+CONFIGURE_ARGS+= --with-maxmsgsize=${WITH_MAXMSGSIZE}
+.endif
+
+.if defined(WITH_MAXARGSIZE)
+CONFIGURE_ARGS+= --with-maxargsize=${WITH_MAXARGSIZE}
+.endif
+
+.if defined(WITH_MAXFORMARGSIZE)
+CONFIGURE_ARGS+= --with-maxformargsize=${WITH_MAXFORMARGSIZE}
+.endif
+
MANPREFIX= ${PREFIX}/share/sqwebmail
MAN1= maildirmake.1
MAN7= authlib.7