aboutsummaryrefslogtreecommitdiff
path: root/mail/sqwebmail/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2006-11-06 17:44:20 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2006-11-06 17:44:20 +0000
commit82edc04e1be91bd4e3bacc0b4561c208e5236e67 (patch)
tree4d952ed67826ab00337908290af735b1eb76cc15 /mail/sqwebmail/Makefile
parent1aeb7b328a21901adef9157af681084005fab2f9 (diff)
Notes
Diffstat (limited to 'mail/sqwebmail/Makefile')
-rw-r--r--mail/sqwebmail/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 675a997b1a74..c2ec2498cb3d 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
OPTIONS= CACHEDIR "Cache logins" on \
+ FAM "Build in fam support for IDLE command" on \
GDBM "Use gdbm db instead of system bdb" off \
GZIP "Compress messages with gzip" on \
HTTPS "Generate https:// URLs for all accesses" off \
@@ -106,6 +107,10 @@ INSTALL_TARGET= install-strip install-configure
.include "${.CURDIR}/../../security/courier-authlib/Makefile.dep"
.endif
+.if defined(WITH_FAM)
+USE_FAM= yes
+.endif
+
.if defined(WITH_RCORDER)
USE_RCORDER= sqwebmail-sqwebmaild
.else
@@ -198,13 +203,20 @@ CONFIGURE_ARGS+=--with-db=db
.endif
post-patch:
+.if !defined(WITH_FAM)
+ @${REINPLACE_CMD} -e 's|$$LIBFAM||g; s|HAVE_FAM|DO_NOT_HAVE_FAM|g' \
+ ${WRKSRC}/maildir/configure
+.endif
@${REINPLACE_CMD} -e 's|LIBPCRE=-lpcre|LIBPCRE="-L${LOCALBASE}/lib -lpcre"|g' \
${WRKSRC}/maildir/configure
+ @${REINPLACE_CMD} -e 's|@echo|echo|g' ${WRKSRC}/maildir/configure
+
@${REINPLACE_CMD} -e 's|-lpcre|-L${LOCALBASE}/lib &|g' \
${WRKSRC}/sqwebmail/Makefile.in
- @${REINPLACE_CMD} -e 's|\$$(testmaildirfilter_LDADD)|& \$$(LIBPCRE)|g' \
+ @${REINPLACE_CMD} -e 's|\$$(testmaildirfilter_LDADD)|& \$$(LIBPCRE)|g; \
+ s|$$(LINK) $$(maildirkw_LDFLAGS)|$$(CXXLINK) $$(maildirkw_LDFLAGS)|' \
${WRKSRC}/maildir/Makefile.in
@${REINPLACE_CMD} -e 's|^case x$$lockmethod in|${TEST} \&\& &|g' \