aboutsummaryrefslogtreecommitdiff
path: root/mail/sqwebmail
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2011-09-27 01:00:09 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2011-09-27 01:00:09 +0000
commit5a4cf9f981b332d9d5982184e028b5636d3a0874 (patch)
treea1c401e7dee538bc7231354b7af62f414c263d75 /mail/sqwebmail
parentf3921da21d385225b019bb31b6cffc48404c90ef (diff)
downloadports-5a4cf9f981b332d9d5982184e028b5636d3a0874.tar.gz
ports-5a4cf9f981b332d9d5982184e028b5636d3a0874.zip
Notes
Diffstat (limited to 'mail/sqwebmail')
-rw-r--r--mail/sqwebmail/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 0a826fdd0fec..497635ac7f3b 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -14,13 +14,13 @@ MASTER_SITES= SF/courier/webmail/${PORTVERSION}
MAINTAINER= oliver@FreeBSD.org
COMMENT= CGI Webmail client for Maildirs
-CFLAGS:= -I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS:S/^[:space:]*//}
-CXXFLAGS:= -I${LOCALBASE}/include ${CXXFLAGS:S/^[:space:]*//}
-
BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+CFLAGS:= -I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS:S/^[:space:]*//}
+CXXFLAGS:= -I${LOCALBASE}/include ${CXXFLAGS:S/^[:space:]*//}
+
OPTIONS= CACHEDIR "Cache logins" on \
FAM "Build in fam support for IDLE command" on \
GDBM "Use gdbm db instead of system bdb" off \
@@ -58,7 +58,6 @@ CACHEOWNER?= bin
# End of user variables
USE_PERL5= YES
-HAS_CONFIGURE= YES
USE_BZIP2= YES
USE_GETTEXT= YES
USE_GMAKE= YES
@@ -161,16 +160,16 @@ CONFIGURE_ARGS+= --enable-unicode
.endif
.if defined(WITH_AUTOPURGE)
-CONFIGURE_ARGS+= --enable-autopurge=${WITH_AUTOPURGE}
+CONFIGURE_ARGS+= --enable-autopurge=${WITH_AUTOPURGE}
.endif
.if defined(WITH_MAXPURGE)
-CONFIGURE_ARGS+= --enable-maxpurge=${WITH_MAXPURGE}
+CONFIGURE_ARGS+= --enable-maxpurge=${WITH_MAXPURGE}
.endif
.if defined(WITH_GDBM)
CONFIGURE_ARGS+=--with-db=gdbm
-LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
.else
CONFIGURE_ARGS+=--with-db=db
.endif