aboutsummaryrefslogtreecommitdiff
path: root/mail/stuphead/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2000-12-18 20:44:08 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2000-12-18 20:44:08 +0000
commitfe005038efeee6df3ffa786961ba0ca3a31fbd36 (patch)
tree0e1ecad7a604af122c76196dce1a47b6ddf1bd73 /mail/stuphead/Makefile
parentad8364e7b431fe415f3ded152f8831187ff61ef5 (diff)
downloadports-fe005038efeee6df3ffa786961ba0ca3a31fbd36.tar.gz
ports-fe005038efeee6df3ffa786961ba0ca3a31fbd36.zip
Notes
Diffstat (limited to 'mail/stuphead/Makefile')
-rw-r--r--mail/stuphead/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/mail/stuphead/Makefile b/mail/stuphead/Makefile
new file mode 100644
index 000000000000..86c1c06d9a40
--- /dev/null
+++ b/mail/stuphead/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: stuphead
+# Date created: 07 December 2000
+# Whom: Sergey Osokin aka oZZ <ozz@FreeBSD.org.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= stuphead
+PORTVERSION= 0.4.9
+CATEGORIES= mail
+MASTER_SITES= http://stuphead.antex.ru/
+
+MAINTAINER= ozz@FreeBSD.org.ru
+
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GTK= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's#DATADIRNAME=lib#DATADIRNAME=share#g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>