aboutsummaryrefslogtreecommitdiff
path: root/mail/stuphead
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-18 17:56:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-18 17:56:06 +0000
commitba4538ccd1ff63da0f6a49f8d05e3f1ecbddc21e (patch)
tree88917b79cfa8909035781a3f01c6af1be10e263f /mail/stuphead
parent3afda598330a16db58d4423a10f2bbeafdc31045 (diff)
downloadports-ba4538ccd1ff63da0f6a49f8d05e3f1ecbddc21e.tar.gz
ports-ba4538ccd1ff63da0f6a49f8d05e3f1ecbddc21e.zip
Notes
Diffstat (limited to 'mail/stuphead')
-rw-r--r--mail/stuphead/Makefile2
-rw-r--r--mail/stuphead/files/patch-src::htmlview.c11
-rw-r--r--mail/stuphead/files/patch-src::messageview.c60
3 files changed, 72 insertions, 1 deletions
diff --git a/mail/stuphead/Makefile b/mail/stuphead/Makefile
index 0aa331e95f03..07618483d490 100644
--- a/mail/stuphead/Makefile
+++ b/mail/stuphead/Makefile
@@ -7,7 +7,7 @@
PORTNAME= stuphead
PORTVERSION= 0.5.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail gnome
MASTER_SITES= http://stuphead.asplinux.ru/stuphead/
diff --git a/mail/stuphead/files/patch-src::htmlview.c b/mail/stuphead/files/patch-src::htmlview.c
new file mode 100644
index 000000000000..8304786e78e0
--- /dev/null
+++ b/mail/stuphead/files/patch-src::htmlview.c
@@ -0,0 +1,11 @@
+--- src/htmlview.c.old Tue Aug 17 23:56:37 2004
++++ src/htmlview.c Tue Aug 17 23:56:57 2004
+@@ -59,7 +59,7 @@
+
+ HtmlView *htmlview_create(void)
+ {
+- HtmlView *htmlview;
++ HtmlView *htmlview = NULL;
+ #ifdef USE_MOZILLA
+ GtkMozEmbed *mozwin;
+ gchar *mozpat;
diff --git a/mail/stuphead/files/patch-src::messageview.c b/mail/stuphead/files/patch-src::messageview.c
new file mode 100644
index 000000000000..0ed8ce08e82e
--- /dev/null
+++ b/mail/stuphead/files/patch-src::messageview.c
@@ -0,0 +1,60 @@
+--- src/messageview.c.orig Wed Aug 18 03:23:29 2004
++++ src/messageview.c Wed Aug 18 03:37:58 2004
+@@ -80,7 +80,9 @@
+ imageview->messageview = messageview;
+
+ htmlview = htmlview_create();
+- htmlview->messageview = messageview;
++ if(htmlview) {
++ htmlview->messageview = messageview;
++ }
+
+ mimeview = mimeview_create();
+ mimeview->textview = textview;
+@@ -91,7 +93,9 @@
+ /* to remove without destroyed */
+ gtk_widget_ref(*(GtkWidget **)textview);
+ gtk_widget_ref(*(GtkWidget **)imageview);
+- gtk_widget_ref(*(GtkWidget **)htmlview);
++ if(htmlview) {
++ gtk_widget_ref(*(GtkWidget **)htmlview);
++ }
+ gtk_widget_ref(*(GtkWidget **)mimeview);
+
+ paned = gtk_vpaned_new();
+@@ -152,7 +156,9 @@
+ gtk_paned_add2(GTK_PANED(messageview->paned), *(GtkWidget **)textview);
+ #endif
+
+- htmlview_init(messageview->htmlview);
++ if(messageview->htmlview) {
++ htmlview_init(messageview->htmlview);
++ }
+ mimeview_init(messageview->mimeview);
+ textview_init(messageview->textview);
+ imageview_init(messageview->imageview);
+@@ -267,17 +273,21 @@
+ GtkWidget *textview = *(GtkWidget **)messageview->textview;
+ GtkWidget *imageview = *(GtkWidget **)messageview->imageview;
+ GtkWidget *mimeview = *(GtkWidget **)messageview->mimeview;
+- GtkWidget *htmlview = *(GtkWidget **)messageview->htmlview;
++
++ if(messageview->htmlview) {
++ GtkWidget *htmlview = *(GtkWidget **)messageview->htmlview;
++ htmlview_destroy(messageview->htmlview);
++ gtk_widget_destroy(htmlview);
++ }
++
+ textview_destroy(messageview->textview);
+ imageview_destroy(messageview->imageview);
+- htmlview_destroy(messageview->htmlview);
+ mimeview_destroy(messageview->mimeview);
+
+ g_free(messageview);
+
+ gtk_widget_unref(textview);
+ gtk_widget_unref(imageview);
+- gtk_widget_unref(htmlview);
+ gtk_widget_unref(mimeview);
+ }
+