aboutsummaryrefslogtreecommitdiff
path: root/mail/stuphead
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-06-11 15:38:08 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-06-11 15:38:08 +0000
commitb8562ae21dad26f50a6ab6aab0d1d18e36afd7df (patch)
treecb9ea7a200c02268280081436f1f83a3c1f75f8d /mail/stuphead
parentb567291a7d872217ce6055ed14970fb4092e9c4d (diff)
downloadports-b8562ae21dad26f50a6ab6aab0d1d18e36afd7df.tar.gz
ports-b8562ae21dad26f50a6ab6aab0d1d18e36afd7df.zip
Notes
Diffstat (limited to 'mail/stuphead')
-rw-r--r--mail/stuphead/Makefile20
-rw-r--r--mail/stuphead/distinfo4
-rw-r--r--mail/stuphead/files/patch-Makefile.in17
-rw-r--r--mail/stuphead/files/patch-src::stuphead11
-rw-r--r--mail/stuphead/pkg-plist2
-rw-r--r--mail/stuphead/pkg-plist.gnome6
-rw-r--r--mail/stuphead/pkg-plist.mozilla5
7 files changed, 31 insertions, 34 deletions
diff --git a/mail/stuphead/Makefile b/mail/stuphead/Makefile
index 0674452ec7dc..7ef870c0bc56 100644
--- a/mail/stuphead/Makefile
+++ b/mail/stuphead/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= stuphead
-PORTVERSION= 0.5.2
+PORTVERSION= 0.5.3
CATEGORIES= mail gnome
MASTER_SITES= http://stuphead.antex.ru/
PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ${PORTNAME}-${PORTVERSION}.patch
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-1.patch
MAINTAINER= ozz@FreeBSD.org.ru
@@ -34,6 +34,7 @@ CONFIGURE_ARGS+= --disable-gdk-pixbuf \
.if defined (WITH_GNOME)
USE_GNOME= yes
+PLIST= ${PKGDIR}/pkg-plist.gnome
CONFIGURE_ARGS+= --enable-gnome
.else
CONFIGURE_ARGS+= --disable-imlib \
@@ -41,6 +42,7 @@ CONFIGURE_ARGS+= --disable-imlib \
.endif
.if defined (WITH_MOZILLA)
+PLIST= ${PKGDIR}/pkg-plist.mozilla
CONFIGURE_ARGS+= --enable-mozilla
BUILD_DEPENDS+= ${PREFIX}/include/mozilla/gtkmozembed.h:${PORTSDIR}/www/mozilla-headers
RUN_DEPENDS+= ${PREFIX}/bin/mozilla:${PORTSDIR}/www/mozilla
@@ -56,4 +58,18 @@ pre-patch:
@${PERL} -pi -e 's#/usr/bin/gnome-config#$(PREFIX)/bin/gnome-config#g' \
${WRKSRC}/configure
+do-install:
+.if defined (WITH_MOZILLA)
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}bin ${PREFIX}/bin
+.else
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}bin ${PREFIX}/bin/${PORTNAME}
+.endif
+ @ ${INSTALL_DATA} ${WRKSRC}/src/pixmaps/${PORTNAME}.xpm ${PREFIX}/share/pixmaps
+ @ ${INSTALL_DATA} ${WRKSRC}/po/fr.gmo ${PREFIX}/share/locale/fr/LC_MESSAGES/${PORTNAME}.mo
+ @ ${INSTALL_DATA} ${WRKSRC}/po/ru.gmo ${PREFIX}/share/locale/ru/LC_MESSAGES/${PORTNAME}.mo
+.if defined (WITH_GNOME)
+ @ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/gnome/apps/Internet
+.endif
+
.include <bsd.port.mk>
diff --git a/mail/stuphead/distinfo b/mail/stuphead/distinfo
index 8fe75b64c304..5ad2812b87a4 100644
--- a/mail/stuphead/distinfo
+++ b/mail/stuphead/distinfo
@@ -1,2 +1,2 @@
-MD5 (stuphead-0.5.2.tar.bz2) = 1e4024b142f10a73a08da0035867c03a
-MD5 (stuphead-0.5.2.patch) = aeb8d2ea39e7c00910ecdcb8fbc622b2
+MD5 (stuphead-0.5.3.tar.bz2) = dcec0ec7a18b2bfa54508638a18c9900
+MD5 (stuphead-0.5.3-1.patch) = a5e1f78175e10aeeed2c0a21ed807834
diff --git a/mail/stuphead/files/patch-Makefile.in b/mail/stuphead/files/patch-Makefile.in
deleted file mode 100644
index 0b0152d55226..000000000000
--- a/mail/stuphead/files/patch-Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.in.orig Fri May 4 19:56:35 2001
-+++ Makefile.in Fri May 4 19:57:01 2001
-@@ -424,11 +424,11 @@
- -rm -rf $(distdir)
-
- install-data-local:
-- @INSTALL@ -d -m755 $(GNOME_DATADIR)/gnome/apps/Internet
-- @INSTALL@ -m644 stuphead.desktop $(GNOME_DATADIR)/gnome/apps/Internet
-+ @INSTALL@ -d -m755 $(GNOME_DATADIR)/apps/Internet
-+ @INSTALL@ -m644 stuphead.desktop $(GNOME_DATADIR)/apps/Internet
-
- uninstall-local:
-- rm -f $(GNOME_DATADIR)/gnome/apps/Internet/stuphead.desktop
-+ rm -f $(GNOME_DATADIR)/apps/Internet/stuphead.desktop
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/mail/stuphead/files/patch-src::stuphead b/mail/stuphead/files/patch-src::stuphead
deleted file mode 100644
index 10edf96179c6..000000000000
--- a/mail/stuphead/files/patch-src::stuphead
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/stuphead.orig Fri May 4 19:12:38 2001
-+++ src/stuphead Fri May 4 19:13:57 2001
-@@ -15,6 +15,8 @@
- MOZILLA_HOME=/usr/local/lib/mozilla
- elif [ -f ~/mozilla/libgtkembedmoz.so ]; then
- MOZILLA_HOME=~/mozilla
-+elif [ -f /usr/X11R6/lib/mozilla/libgtkembedmoz.so ]; then
-+ MOZILLA_HOME=/usr/X11R6/lib/mozilla
- fi
-
- LD_LIBRARY_PATH=$MOZILLA_HOME:$LD_LIBRARY_PATH
diff --git a/mail/stuphead/pkg-plist b/mail/stuphead/pkg-plist
index ffb1269992b5..772efb123add 100644
--- a/mail/stuphead/pkg-plist
+++ b/mail/stuphead/pkg-plist
@@ -1,6 +1,4 @@
bin/stuphead
-bin/stupheadbin
share/locale/fr/LC_MESSAGES/stuphead.mo
share/locale/ru/LC_MESSAGES/stuphead.mo
share/pixmaps/stuphead.xpm
-share/gnome/apps/Internet/stuphead.desktop
diff --git a/mail/stuphead/pkg-plist.gnome b/mail/stuphead/pkg-plist.gnome
new file mode 100644
index 000000000000..ffb1269992b5
--- /dev/null
+++ b/mail/stuphead/pkg-plist.gnome
@@ -0,0 +1,6 @@
+bin/stuphead
+bin/stupheadbin
+share/locale/fr/LC_MESSAGES/stuphead.mo
+share/locale/ru/LC_MESSAGES/stuphead.mo
+share/pixmaps/stuphead.xpm
+share/gnome/apps/Internet/stuphead.desktop
diff --git a/mail/stuphead/pkg-plist.mozilla b/mail/stuphead/pkg-plist.mozilla
new file mode 100644
index 000000000000..49a8474aed34
--- /dev/null
+++ b/mail/stuphead/pkg-plist.mozilla
@@ -0,0 +1,5 @@
+bin/stuphead
+bin/stupheadbin
+share/locale/fr/LC_MESSAGES/stuphead.mo
+share/locale/ru/LC_MESSAGES/stuphead.mo
+share/pixmaps/stuphead.xpm