aboutsummaryrefslogtreecommitdiff
path: root/mail/swaks
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-10-12 14:23:31 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-10-12 14:23:31 +0000
commit7a869bd74cfbb0f0965f927bd8b90811cf210d0b (patch)
treef4c7046c9f698d2e635e95bc36eb318654a52e83 /mail/swaks
parent368fea4182003512bb3bf1705fecd5979bf5dcdb (diff)
downloadports-7a869bd74cfbb0f0965f927bd8b90811cf210d0b.tar.gz
ports-7a869bd74cfbb0f0965f927bd8b90811cf210d0b.zip
Notes
Diffstat (limited to 'mail/swaks')
-rw-r--r--mail/swaks/Makefile36
-rw-r--r--mail/swaks/distinfo2
-rw-r--r--mail/swaks/pkg-descr3
-rw-r--r--mail/swaks/pkg-message7
4 files changed, 48 insertions, 0 deletions
diff --git a/mail/swaks/Makefile b/mail/swaks/Makefile
new file mode 100644
index 000000000000..d59fc2182e33
--- /dev/null
+++ b/mail/swaks/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: swaks
+# Date created: 29 Sep 2004
+# Whom: Oliver Eikemeier
+#
+# $FreeBSD$
+#
+
+PORTNAME= swaks
+PORTVERSION= 20040404.1
+CATEGORIES= mail
+MASTER_SITES= http://jetmore.org/john/code/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+EXTRACT_SUFX=
+
+MAINTAINER= eik@FreeBSD.org
+COMMENT= Swiss Army Knife SMTP transaction tester
+
+PLIST_FILES= bin/${PORTNAME}
+
+USE_PERL5_RUN= yes
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}
+
+do-build:
+ @${SED} -e '1s|/usr/bin/perl|${PERL}|' \
+ ${WRKSRC}/${DISTNAME} > ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${DESTDIR}${PREFIX}/bin/${PORTNAME}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/swaks/distinfo b/mail/swaks/distinfo
new file mode 100644
index 000000000000..eea1e142dc56
--- /dev/null
+++ b/mail/swaks/distinfo
@@ -0,0 +1,2 @@
+MD5 (swaks.20040404.1) = 747b5ace5648a4dc6ff2faef139539a1
+SIZE (swaks.20040404.1) = 46264
diff --git a/mail/swaks/pkg-descr b/mail/swaks/pkg-descr
new file mode 100644
index 000000000000..3f021d5d556a
--- /dev/null
+++ b/mail/swaks/pkg-descr
@@ -0,0 +1,3 @@
+Program to test MTA configurations.
+
+WWW: http://jetmore.org/john/code/#swaks
diff --git a/mail/swaks/pkg-message b/mail/swaks/pkg-message
new file mode 100644
index 000000000000..4682c8ad8c22
--- /dev/null
+++ b/mail/swaks/pkg-message
@@ -0,0 +1,7 @@
+swaks has been successfully installed.
+
+Try
+ `swaks --help'
+to list the available options and
+ `swaks --support'
+for a list of capabilities.