aboutsummaryrefslogtreecommitdiff
path: root/mail/sylpheed-claws/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-01-03 07:58:03 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-01-03 07:58:03 +0000
commitb97052ed340eff6f8ce8a61f3e6960229a2e6edf (patch)
tree7a27029740c94a5498b3b45a6e99bc41a79a3be9 /mail/sylpheed-claws/Makefile
parent5a9d758e8face552312c571b014ee5c1783fbb77 (diff)
downloadports-b97052ed340eff6f8ce8a61f3e6960229a2e6edf.tar.gz
ports-b97052ed340eff6f8ce8a61f3e6960229a2e6edf.zip
Notes
Diffstat (limited to 'mail/sylpheed-claws/Makefile')
-rw-r--r--mail/sylpheed-claws/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 5dc76dcc025e..ef7de03c445b 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sylpheed-claws
-PORTVERSION= 0.8.6
+PORTVERSION= 0.8.8
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -19,8 +19,8 @@ MAINTAINER= corecode@corecode.ath.cx
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-THEMEVERSION= 0.8.3
-THEMEFILE= sylpheed-iconset-${THEMEVERSION}claws.tar.gz
+THEMEVERSION= 0.8.7
+THEMEFILE= sylpheed-${THEMEVERSION}claws-iconset.tar.gz
USE_BZIP2= yes
USE_GMAKE= yes
@@ -74,7 +74,7 @@ CONFIGURE_ENV+= PTHREAD_LIBS=${PTHREAD_LIBS:S/"//g}
.endif
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
-CONFIGURE_ARGS+= --enable-ssl
+CONFIGURE_ARGS+= --enable-openssl
.endif
.if defined(WITHOUT_THEMES)
PLIST_SUB+= THEMES="@comment "
@@ -110,6 +110,8 @@ post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
@${REINPLACE_CMD} -e "s|po intl src|po src|" ${WRKSRC}/Makefile.in
+ @for f in ${WRKSRC}/tools/*; do \
+ ${REINPLACE_CMD} -e "s|/usr/bin/perl|${PERL}|" $$f; done
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|src manual faq tools|src tools|' ${WRKSRC}/Makefile.in
.endif
@@ -127,9 +129,10 @@ post-install:
@${MKDIR} ${DATADIR}
@cd ${WRKSRC}/tools && \
${INSTALL_SCRIPT} OOo2sylpheed.pl calypso_convert.pl \
- eud2gc.py filter_conv.pl gif2xface.pl gpg-sign-syl \
- kmail2sylpheed.pl kmail2sylpheed_v2.pl newscache_clean.pl \
- outlook2sylpheed.pl tb2sylpheed update-po uudec ${DATADIR}
+ eud2gc.py filter_conv.pl gif2xface.pl google_msgid.pl \
+ gpg-sign-syl kmail2sylpheed.pl kmail2sylpheed_v2.pl \
+ newscache_clean.pl outlook2sylpheed.pl tb2sylpheed \
+ update-po uudec ${DATADIR}
.if !defined(WITHOUT_THEMES)
@${MKDIR} ${DATADIR}/themes
@cd ${WRKDIR}/${THEMEFILE:C/.tar.gz//} && for d in `find .`; do \