aboutsummaryrefslogtreecommitdiff
path: root/mail/sylpheed-claws
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-07-30 11:00:00 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-07-30 11:00:00 +0000
commit79483b93f0c086332693146fb9144d5465f5883c (patch)
treecec35fcf89eba9b5e777d451c5ffd7315b2d5be8 /mail/sylpheed-claws
parent49ecf70f2bb18df7b256c137f968ad0a9a2840cd (diff)
downloadports-79483b93f0c086332693146fb9144d5465f5883c.tar.gz
ports-79483b93f0c086332693146fb9144d5465f5883c.zip
Notes
Diffstat (limited to 'mail/sylpheed-claws')
-rw-r--r--mail/sylpheed-claws/Makefile83
-rw-r--r--mail/sylpheed-claws/distinfo4
-rw-r--r--mail/sylpheed-claws/files/patch-configure66
-rw-r--r--mail/sylpheed-claws/files/patch-configure.ac34
-rw-r--r--mail/sylpheed-claws/files/patch-sylpheed-claws.desktop11
-rw-r--r--mail/sylpheed-claws/files/patch-sylpheed.desktop20
-rw-r--r--mail/sylpheed-claws/pkg-plist26
7 files changed, 110 insertions, 134 deletions
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index f117c80ddf43..afad6ef3ec17 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sylpheed-claws
-PORTVERSION= 1.9.12
+PORTVERSION= 1.9.13
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -14,11 +14,12 @@ DISTFILES= ${EXTRACT_ONLY} \
${THEMEFILE}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
-
MAINTAINER= netchild@FreeBSD.org
COMMENT= A lightweight and very featureful GTK+ based e-mail and news client
+LIB_DEPENDS= etpan:${PORTSDIR}/mail/libetpan
+RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
+
THEMEVERSION= 20040929
THEMEFILE= sylpheed-iconset-${THEMEVERSION}.tar.gz
@@ -27,9 +28,9 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
USE_GNOME= gnomehack pkgconfig gtk20
USE_REINPLACE= yes
+USE_AUTOTOOLS= autoconf:259 libtool:15
WANT_GNOME= yes
MAN1= sylpheed-claws.1
@@ -44,38 +45,52 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+OPTIONS= ALL "Enable all options." off \
+ ASPELL "Enable spell checking support." on \
+ CLAMAV "Enable virus-checking support." off \
+ COMPFACE "Enable X-Face support." on \
+ GNOMEPRINT "Enable extended print support (GNOME)." off \
+ GPGME "Enable PGP/GnuPG support using GPGME." off \
+ JPILOT "Enable JPilot support." off \
+ LDAP "Enable LDAP support." off \
+ SA_PLUG "Enable SpamAssassin support." off \
+ SSL "Enable OpenSSL support." on \
+ THEMES "Install additional themes." on
+
+
.if defined(NOPORTDOCS)
EXTRA_PATCHES= ${FILESDIR}/extra-doc:Makefile.in
.endif
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
--with-openssl-libs=${OPENSSLLIB}
.else
CONFIGURE_ARGS+= --disable-openssl
.endif
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_SSL)
-.if defined(OPENSSLVER)
-MYSSLVER=${OPENSSLVER}
+.if ${HAVE_GNOME:Mgnomehier} != "" || defined(WITH_GNOMEPRINT)
+USE_GNOME+= gnomehier
+PLIST_SUB+= GNOME=""
+USE_GNOME+= gnomehier
.else
-MYSSLVER!=openssl version | cut -d ' ' -f 2
-.endif
-SSLTEST!=test ${MYSSLVER} \< 0.9.7 && ${ECHO_CMD} bad || ${TRUE}
-. if ${SSLTEST} == "bad"
-IGNORE=You need at least OpenSSL v0.9.7
-. endif
+PLIST_SUB+= GNOME="@comment "
.endif
-.if ${HAVE_GNOME:Mgnomehier} != ""
-PLIST_SUB+= GNOME=""
+.if ${HAVE_GNOME:Mgnomeprint} != "" || defined(WITH_GNOMEPRINT)
+PLIST_SUB+= GNOMEPRINT=""
+USE_GNOME+= libgnomeprint libgnomeprintui
+CONFIGURE_ARGS+= --enable-gnomeprint
.else
-PLIST_SUB+= GNOME="@comment "
+PLIST_SUB+= GNOMEPRINT="@comment "
+CONFIGURE_ARGS+= --disable-gnomeprint
.endif
+
.if exists(${LOCALBASE}/include/clamav.h)
WITH_CLAMAV= yes
.endif
@@ -123,12 +138,14 @@ PLIST_SUB+= SA_PLUG="@comment "
.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
PLIST_SUB+= GPGME=""
-CONFIGURE_ARGS+= --enable-pgpmime-plugin
-LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
+CONFIGURE_ARGS+= --enable-pgpmime-plugin --enable-pgpcore-plugin \
+ --enable-pgpinline-plugin
+LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
.else
PLIST_SUB+= GPGME="@comment "
-CONFIGURE_ARGS+= --disable-pgpmime-plugin
+CONFIGURE_ARGS+= --disable-pgpmime-plugin --disable-pgpcore-plugin \
+ --disable-pgpinline-plugin
.endif
.if defined(WITHOUT_THEMES)
PLIST_SUB+= THEMES="@comment "
@@ -136,24 +153,6 @@ PLIST_SUB+= THEMES="@comment "
PLIST_SUB+= THEMES=""
.endif
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may define the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_ALL Enable all options below"
- @${ECHO} ""
- @${ECHO} " WITH_COMPFACE Enable compface (X-Face) support"
- @${ECHO} " WITH_GPGME Build the pgpmime plugin"
- @${ECHO} " WITH_ASPELL Enable spell-checking support"
- @${ECHO} " WITH_JPILOT Enable JPilot support"
- @${ECHO} " WITH_LDAP Enable LDAP access support"
- @${ECHO} " WITH_SA_PLUG Build Spamassassin plugin"
- @${ECHO} " WITH_CLAMAV Build Clamav antivirus plugin"
- @${ECHO} ""
- @${ECHO} " WITHOUT_SSL Disable OpenSSL support"
- @${ECHO} " WITHOUT_THEMES Don't install additional themes"
- @${ECHO} ""
-
post-extract:
.if !defined(WITHOUT_THEMES)
@${MKDIR} ${WRKSRC}/themes
@@ -194,7 +193,7 @@ post-install:
.if ${HAVE_GNOME:Mgnomehier} != ""
@${MKDIR} ${PREFIX}/share/gnome/applications
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${PREFIX}/share/gnome/applications/sylpheed-claws.desktop
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed-claws.desktop ${PREFIX}/share/gnome/applications/
.endif
.if !defined(WITHOUT_THEMES)
@@ -209,6 +208,6 @@ post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/tools/sylprint.pl ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/tools/sylprint.rc ${PREFIX}/etc/sylprint.rc.example
@${MKDIR} ${PREFIX}/share/pixmaps
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${PREFIX}/share/pixmaps/sylpheed-claws.png
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed-claws*.png ${PREFIX}/share/pixmaps/
.include <bsd.port.post.mk>
diff --git a/mail/sylpheed-claws/distinfo b/mail/sylpheed-claws/distinfo
index bbf633a50a5f..5bc1b28dfcbb 100644
--- a/mail/sylpheed-claws/distinfo
+++ b/mail/sylpheed-claws/distinfo
@@ -1,4 +1,4 @@
-MD5 (sylpheed-claws-1.9.12.tar.bz2) = c7cdfe6ac9afacd680cb8fe58eb9da79
-SIZE (sylpheed-claws-1.9.12.tar.bz2) = 3297470
+MD5 (sylpheed-claws-1.9.13.tar.bz2) = afd3b82ca210520f0ad241b77c5e673a
+SIZE (sylpheed-claws-1.9.13.tar.bz2) = 3432284
MD5 (sylpheed-iconset-20040929.tar.gz) = d72cf03bf3d13cf9e2785eaca3807707
SIZE (sylpheed-iconset-20040929.tar.gz) = 1298891
diff --git a/mail/sylpheed-claws/files/patch-configure b/mail/sylpheed-claws/files/patch-configure
deleted file mode 100644
index 6739b8497e24..000000000000
--- a/mail/sylpheed-claws/files/patch-configure
+++ /dev/null
@@ -1,66 +0,0 @@
---- configure.orig Sun May 15 12:40:22 2005
-+++ configure Sun May 15 12:48:42 2005
-@@ -24058,9 +24058,9 @@
- localedir='${datadir}/locale'
-
-
--manualdir='${prefix}/${DATADIRNAME}/${PACKAGE}/manual'
-+manualdir='${prefix}/${DATADIRNAME}/doc/${PACKAGE}/manual'
-
--faqdir='${prefix}/${DATADIRNAME}/${PACKAGE}/faq'
-+faqdir='${prefix}/${DATADIRNAME}/doc/${PACKAGE}/faq'
-
-
- if test "x${datadir}" = 'x${prefix}/share'; then
-@@ -27756,15 +27756,16 @@
- if test "x$ac_cv_env_OPENSSL_CFLAGS_set" = "xset"; then
- pkg_cv_OPENSSL_CFLAGS=$ac_cv_env_OPENSSL_CFLAGS_value
- elif test -n "$PKG_CONFIG"; then
-- if { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists \"openssl >= 0.9.7\" >/dev/null 2>&1") >&5
-- ($PKG_CONFIG --exists "openssl >= 0.9.7" >/dev/null 2>&1) 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; then
-- pkg_cv_OPENSSL_CFLAGS=`$PKG_CONFIG --cflags "openssl >= 0.9.7" 2>/dev/null`
-- else
-- pkg_failed=yes
-- fi
-+# if { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists \"openssl >= 0.9.7\" >/dev/null 2>&1") >&5
-+# ($PKG_CONFIG --exists "openssl >= 0.9.7" >/dev/null 2>&1) 2>&5
-+# ac_status=$?
-+# echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+# (exit $ac_status); }; then
-+# pkg_cv_OPENSSL_CFLAGS=`$PKG_CONFIG --cflags "openssl >= 0.9.7" 2>/dev/null`
-+pkg_cv_OPENSSL_CFLAGS=
-+# else
-+# pkg_failed=yes
-+# fi
- else
- pkg_failed=untried
- fi
-@@ -27779,15 +27780,16 @@
- if test "x$ac_cv_env_OPENSSL_LIBS_set" = "xset"; then
- pkg_cv_OPENSSL_LIBS=$ac_cv_env_OPENSSL_LIBS_value
- elif test -n "$PKG_CONFIG"; then
-- if { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists \"openssl >= 0.9.7\" >/dev/null 2>&1") >&5
-- ($PKG_CONFIG --exists "openssl >= 0.9.7" >/dev/null 2>&1) 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; then
-- pkg_cv_OPENSSL_LIBS=`$PKG_CONFIG --libs "openssl >= 0.9.7" 2>/dev/null`
-- else
-- pkg_failed=yes
-- fi
-+# if { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists \"openssl >= 0.9.7\" >/dev/null 2>&1") >&5
-+# ($PKG_CONFIG --exists "openssl >= 0.9.7" >/dev/null 2>&1) 2>&5
-+# ac_status=$?
-+# echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+# (exit $ac_status); }; then
-+# pkg_cv_OPENSSL_LIBS=`$PKG_CONFIG --libs "openssl >= 0.9.7" 2>/dev/null`
-+pkg_cv_OPENSSL_LIBS=%%OPENSSL_LIBS%%
-+# else
-+# pkg_failed=yes
-+# fi
- else
- pkg_failed=untried
- fi
diff --git a/mail/sylpheed-claws/files/patch-configure.ac b/mail/sylpheed-claws/files/patch-configure.ac
new file mode 100644
index 000000000000..c5aa15b3d2ba
--- /dev/null
+++ b/mail/sylpheed-claws/files/patch-configure.ac
@@ -0,0 +1,34 @@
+--- configure.ac.orig Sat Jul 30 10:54:42 2005
++++ configure.ac Sat Jul 30 11:10:47 2005
+@@ -153,9 +153,9 @@
+ localedir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(localedir)
+
+-manualdir='${prefix}/${DATADIRNAME}/${PACKAGE}/manual'
++manualdir='${prefix}/${DATADIRNAME}/doc/${PACKAGE}/manual'
+ AC_SUBST(manualdir)
+-faqdir='${prefix}/${DATADIRNAME}/${PACKAGE}/faq'
++faqdir='${prefix}/${DATADIRNAME}/doc/${PACKAGE}/faq'
+ AC_SUBST(faqdir)
+
+ dnl Set PACKAGE_DATA_DIR in config.h.
+@@ -303,7 +303,18 @@
+ AC_MSG_CHECKING([whether to use OpenSSL])
+ if test x"$ac_cv_enable_openssl" = xyes; then
+ AC_MSG_RESULT(yes)
+- PKG_CHECK_MODULES(OPENSSL, openssl >= 0.9.7, :, ac_cv_enable_openssl=no)
++ case $host_os in
++ *freebsd*)
++ if [ $(openssl version | cut -d ' ' -f 2) \< 0.9.7 ]; then
++ ac_cv_enable_openssl=no
++ else
++ OPENSSL_LIBS=${OPENSSL_LIBS-"-lcrypto -lssl"}
++ fi
++ ;;
++ *)
++ PKG_CHECK_MODULES(OPENSSL, openssl >= 0.9.7, :, ac_cv_enable_openssl=no)
++ ;;
++ esac
+ if test x$ac_cv_enable_openssl = xyes; then
+ AC_DEFINE(USE_OPENSSL, 1, Define if you want OpenSSL support)
+ else
diff --git a/mail/sylpheed-claws/files/patch-sylpheed-claws.desktop b/mail/sylpheed-claws/files/patch-sylpheed-claws.desktop
new file mode 100644
index 000000000000..1eea74683a46
--- /dev/null
+++ b/mail/sylpheed-claws/files/patch-sylpheed-claws.desktop
@@ -0,0 +1,11 @@
+--- sylpheed-claws.desktop.orig Sat Jul 30 11:17:58 2005
++++ sylpheed-claws.desktop Sat Jul 30 11:18:16 2005
+@@ -1,7 +1,7 @@
+ [Desktop Entry]
+ Encoding=UTF-8
+ Name=Sylpheed-Claws
+-Exec=sylpheed
++Exec=sylpheed-claws
+ Icon=sylpheed-claws.png
+ Info="Sylpheed-Claws"
+ Categories=Application;Network;
diff --git a/mail/sylpheed-claws/files/patch-sylpheed.desktop b/mail/sylpheed-claws/files/patch-sylpheed.desktop
deleted file mode 100644
index 163b639afe9d..000000000000
--- a/mail/sylpheed-claws/files/patch-sylpheed.desktop
+++ /dev/null
@@ -1,20 +0,0 @@
---- sylpheed.desktop.orig Mon Dec 13 13:41:28 2004
-+++ sylpheed.desktop Mon Dec 13 13:44:45 2004
-@@ -1,10 +1,13 @@
- [Desktop Entry]
--Name=Sylpheed
--Name[ja]=Sylpheed
-+Version=1.0
-+Encoding=UTF-8
-+Name=Sylpheed Claws
-+Name[ja]=Sylpheed Claws
- Comment=E-Mail client
- Comment[ja]=電子メールクライアント
--Exec=sylpheed
--Icon=sylpheed.png
-+Comment[pl]=Klient poczty elektronicznej
-+Exec=sylpheed-claws
-+Icon=sylpheed-claws.png
- Terminal=0
- Type=Application
- Categories=Application;Network;
diff --git a/mail/sylpheed-claws/pkg-plist b/mail/sylpheed-claws/pkg-plist
index 0803351c3224..d9aaeda627a1 100644
--- a/mail/sylpheed-claws/pkg-plist
+++ b/mail/sylpheed-claws/pkg-plist
@@ -62,6 +62,11 @@ include/sylpheed-claws/editldap.h
include/sylpheed-claws/editldap_basedn.h
include/sylpheed-claws/editvcard.h
include/sylpheed-claws/enriched.h
+include/sylpheed-claws/etpan/etpan-thread-manager-types.h
+include/sylpheed-claws/etpan/etpan-thread-manager.h
+include/sylpheed-claws/etpan/etpan-errors.h
+include/sylpheed-claws/etpan/etpan-log.h
+include/sylpheed-claws/etpan/imap-thread.h
include/sylpheed-claws/exphtmldlg.h
include/sylpheed-claws/expldifdlg.h
include/sylpheed-claws/export.h
@@ -73,6 +78,7 @@ include/sylpheed-claws/folder_item_prefs.h
include/sylpheed-claws/foldersel.h
include/sylpheed-claws/folderutils.h
include/sylpheed-claws/folderview.h
+include/sylpheed-claws/gedit-print.h
include/sylpheed-claws/grouplistdialog.h
include/sylpheed-claws/gtk/about.h
include/sylpheed-claws/gtk/colorlabel.h
@@ -83,6 +89,7 @@ include/sylpheed-claws/gtk/foldersort.h
include/sylpheed-claws/gtk/gtkaspell.h
include/sylpheed-claws/gtk/gtksctree.h
include/sylpheed-claws/gtk/gtkshruler.h
+include/sylpheed-claws/gtk/gtksourceprintjob.h
include/sylpheed-claws/gtk/gtkutils.h
include/sylpheed-claws/gtk/gtkvscrollbutton.h
include/sylpheed-claws/gtk/inputdialog.h
@@ -133,11 +140,12 @@ include/sylpheed-claws/news_gtk.h
include/sylpheed-claws/noticeview.h
include/sylpheed-claws/partial_download.h
include/sylpheed-claws/pine.h
-%%GPGME%%include/sylpheed-claws/plugins/pgpmime/passphrase.h
+%%GPGME%%include/sylpheed-claws/plugins/pgpcore/passphrase.h
+%%GPGME%%include/sylpheed-claws/plugins/pgpcore/prefs_gpg.h
+%%GPGME%%include/sylpheed-claws/plugins/pgpcore/select-keys.h
+%%GPGME%%include/sylpheed-claws/plugins/pgpcore/sgpgme.h
+%%GPGME%%include/sylpheed-claws/plugins/pgpinline/pgpinline.h
%%GPGME%%include/sylpheed-claws/plugins/pgpmime/pgpmime.h
-%%GPGME%%include/sylpheed-claws/plugins/pgpmime/prefs_gpg.h
-%%GPGME%%include/sylpheed-claws/plugins/pgpmime/select-keys.h
-%%GPGME%%include/sylpheed-claws/plugins/pgpmime/sgpgme.h
include/sylpheed-claws/pop.h
include/sylpheed-claws/prefs_account.h
include/sylpheed-claws/prefs_actions.h
@@ -193,13 +201,20 @@ lib/sylpheed-claws/plugins/dillo_viewer.so
lib/sylpheed-claws/plugins/trayicon.so
libdata/pkgconfig/sylpheed-claws.pc
@dirrm include/sylpheed-claws/common
+@dirrm include/sylpheed-claws/etpan
@dirrm include/sylpheed-claws/gtk
+%%GPGME%%@dirrm include/sylpheed-claws/plugins/pgpcore
+%%GPGME%%@dirrm include/sylpheed-claws/plugins/pgpinline
%%GPGME%%@dirrm include/sylpheed-claws/plugins/pgpmime
@unexec rmdir %D/include/sylpheed-claws/plugins 2>/dev/null >/dev/null || true
@dirrm include/sylpheed-claws
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.so
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin_gtk.so
+%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.so
+%%GPGME%%lib/sylpheed-claws/plugins/pgpmime.deps
%%GPGME%%lib/sylpheed-claws/plugins/pgpmime.so
+%%GPGME%%lib/sylpheed-claws/plugins/pgpinline.deps
+%%GPGME%%lib/sylpheed-claws/plugins/pgpinline.so
%%SA_PLUG%%lib/sylpheed-claws/plugins/spamassassin.so
%%SA_PLUG%%lib/sylpheed-claws/plugins/spamassassin_gtk.so
%%PORTDOCS%%%%DOCSDIR%%/NEWS
@@ -353,6 +368,7 @@ share/locale/hu/LC_MESSAGES/sylpheed-claws.mo
share/locale/it/LC_MESSAGES/sylpheed-claws.mo
share/locale/ja/LC_MESSAGES/sylpheed-claws.mo
share/locale/ko/LC_MESSAGES/sylpheed-claws.mo
+share/locale/nb/LC_MESSAGES/sylpheed-claws.mo
share/locale/nl/LC_MESSAGES/sylpheed-claws.mo
share/locale/pl/LC_MESSAGES/sylpheed-claws.mo
share/locale/pt_BR/LC_MESSAGES/sylpheed-claws.mo
@@ -362,6 +378,8 @@ share/locale/sr/LC_MESSAGES/sylpheed-claws.mo
share/locale/sv/LC_MESSAGES/sylpheed-claws.mo
share/locale/zh_CN/LC_MESSAGES/sylpheed-claws.mo
share/locale/zh_TW.Big5/LC_MESSAGES/sylpheed-claws.mo
+share/pixmaps/sylpheed-claws-128x128.png
+share/pixmaps/sylpheed-claws-64x64.png
share/pixmaps/sylpheed-claws.png
%%GNOME%%share/gnome/applications/sylpheed-claws.desktop
%%DATADIR%%/OOo2sylpheed.pl