aboutsummaryrefslogtreecommitdiff
path: root/mail/sylpheed2/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-04-02 14:20:40 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-04-02 14:20:40 +0000
commit473b41c9b4be4d7b60df2d31b8bc16b07182ac93 (patch)
tree1b36524e2fd07393f3742cfb247b14e9e5e3e3c6 /mail/sylpheed2/Makefile
parentf0f831b87fb523fa44de7ee96d00324136fa5cc2 (diff)
downloadports-473b41c9b4be4d7b60df2d31b8bc16b07182ac93.tar.gz
ports-473b41c9b4be4d7b60df2d31b8bc16b07182ac93.zip
Notes
Diffstat (limited to 'mail/sylpheed2/Makefile')
-rw-r--r--mail/sylpheed2/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 7ce2eb8ec4f0..c8dd08e69523 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -9,18 +9,17 @@ PORTNAME= sylpheed
PORTVERSION= 1.9.7
PORTREVISION= 0
CATEGORIES= mail ipv6
-MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
- http://sylpheed.good-day.net/sylpheed/v1.9/:source \
- ${MASTER_SITE_SOURCEFORGE:S/$/:source/}
-MASTER_SITE_SUBDIR= sylpheed-claws/:source oliver/:mime
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r.1/rc/}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:source mime.types:mime
+MASTER_SITES= http://sylpheed.good-day.net/sylpheed/v1.9/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sylpheed-claws/
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= oliver@FreeBSD.org
COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
+RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
+
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -94,7 +93,7 @@ MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
s|-lresolv||g; s|-lpisock\"|-liconv &|g; ' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
+ @${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}&|g' \
${WRKSRC}/src/procmime.c
.if defined(NOPORTDOCS)
@@ -118,7 +117,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/${i}.ja ${DOCSDIR}
.endfor
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/mime.types ${PREFIX}/etc/sylpheed-mime.types
.endif
.include <bsd.port.post.mk>