aboutsummaryrefslogtreecommitdiff
path: root/mail/sympa
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2004-02-16 07:15:01 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2004-02-16 07:15:01 +0000
commit25a972f6f2199abafb58f0cbdb337439e18e44b1 (patch)
tree3bd6a096056f952e76f36cfaf92cb90d745c8e2d /mail/sympa
parent46689973af8570355235c9a40e178da1afc91430 (diff)
downloadports-25a972f6f2199abafb58f0cbdb337439e18e44b1.tar.gz
ports-25a972f6f2199abafb58f0cbdb337439e18e44b1.zip
Notes
Diffstat (limited to 'mail/sympa')
-rw-r--r--mail/sympa/Makefile2
-rw-r--r--mail/sympa/distinfo2
-rw-r--r--mail/sympa/files/patch-soap-sympa_soap_server.fcgi12
-rw-r--r--mail/sympa/files/patch-src-etc-script-orphan_killer.pl12
-rw-r--r--mail/sympa/files/patch-wwsympa-wwsympa.fcgi42
5 files changed, 68 insertions, 2 deletions
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index a70c2171bb51..0b7c321f0159 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sympa
-PORTVERSION?= 4.0.a8
+PORTVERSION?= 4.0.b2
CATEGORIES= mail
MASTER_SITES?= http://www.sympa.org/distribution/
diff --git a/mail/sympa/distinfo b/mail/sympa/distinfo
index be06b20fa151..ecc3ec30fbfd 100644
--- a/mail/sympa/distinfo
+++ b/mail/sympa/distinfo
@@ -1 +1 @@
-MD5 (sympa-4.0.a8.tar.gz) = 1d30040e1774d10372c30cd94abba579
+MD5 (sympa-4.0.b2.tar.gz) = 428c1d3f0750296eb161fb28cb9675f1
diff --git a/mail/sympa/files/patch-soap-sympa_soap_server.fcgi b/mail/sympa/files/patch-soap-sympa_soap_server.fcgi
new file mode 100644
index 000000000000..53d72703c11e
--- /dev/null
+++ b/mail/sympa/files/patch-soap-sympa_soap_server.fcgi
@@ -0,0 +1,12 @@
+--- soap/sympa_soap_server.fcgi 2003/11/28 18:16:39
++++ soap/sympa_soap_server.fcgi 2003/12/28 18:16:39
+@@ -78,7 +78,7 @@
+ my $server = SOAP::Transport::HTTP::FCGI::Sympa->new();
+
+ #$server->dispatch_with({'urn:Sympa' => 'sympasoap'});
+-$server->dispatch_to('/home/sympa/bin','sympasoap');
++$server->dispatch_to('--LIBDIR--','sympasoap');
+
+ $server->handle($birthday);
+
+
diff --git a/mail/sympa/files/patch-src-etc-script-orphan_killer.pl b/mail/sympa/files/patch-src-etc-script-orphan_killer.pl
new file mode 100644
index 000000000000..0ba62614fa2e
--- /dev/null
+++ b/mail/sympa/files/patch-src-etc-script-orphan_killer.pl
@@ -0,0 +1,12 @@
+--- src/etc/script/orphan_killer.pl 2003/11/28 18:16:39
++++ src/etc/script/orphan_killer.pl 2003/12/02 16:32:40
+@@ -24,7 +24,7 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-use lib '/home/sympa/bin';
++use lib '--LIBDIR--';
+
+ use Conf;
+ ## Change to your wwsympa.conf location
+
diff --git a/mail/sympa/files/patch-wwsympa-wwsympa.fcgi b/mail/sympa/files/patch-wwsympa-wwsympa.fcgi
new file mode 100644
index 000000000000..402cd50160cd
--- /dev/null
+++ b/mail/sympa/files/patch-wwsympa-wwsympa.fcgi
@@ -0,0 +1,42 @@
+--- wwsympa/wwsympa.fcgi 2003/11/28 18:16:39
++++ wwsympa/wwsympa.fcgi 2003/12/28 18:16:39
+@@ -3523,10 +3523,10 @@
+ close MSG;
+
+ $param->{'spool'}{$id}{'size'} = int( (-s "$Conf{'queuemod'}/$msg") / 1024 + 0.5);
+- $param->{'spool'}{$id}{'subject'} = &MIME::Words::decode_mimewords($mail->head->get('Subject'));
++ $param->{'spool'}{$id}{'subject'} = &tools::decode_mimewords($mail->head->get('Subject'));
+ $param->{'spool'}{$id}{'subject'} ||= 'no_subject';
+ $param->{'spool'}{$id}{'date'} = $mail->head->get('Date');
+- $param->{'spool'}{$id}{'from'} = &MIME::Words::decode_mimewords($mail->head->get('From'));
++ $param->{'spool'}{$id}{'from'} = &tools::decode_mimewords($mail->head->get('From'));
+ foreach my $field ('subject','date','from') {
+ $param->{'spool'}{$id}{$field} =~ s/</&lt;/;
+ $param->{'spool'}{$id}{$field} =~ s/>/&gt;/;
+@@ -3595,7 +3595,7 @@
+ unless ($#sender_hdr == -1) {
+ my $rejected_sender = $sender_hdr[0]->address;
+ my %context;
+- $context{'subject'} = &MIME::Words::decode_mimewords($msg->head->get('subject'));
++ $context{'subject'} = &tools::decode_mimewords($msg->head->get('subject'));
+ $context{'rejected_by'} = $param->{'user'}{'email'};
+ $list->send_file('reject', $rejected_sender, $robot, \%context);
+ }
+@@ -4352,7 +4352,7 @@
+
+ ## Decode subject header fields
+ foreach my $m (@{$param->{'res'}}) {
+- $m->{'subj'} = &MIME::Words::decode_mimewords($m->{'subj'});
++ $m->{'subj'} = &tools::decode_mimewords($m->{'subj'});
+ }
+
+ return 1;
+@@ -9020,7 +9020,7 @@
+ ($param->{'local_to'},$param->{'domain_to'}) = split ('@',$param->{'to'});
+
+ $param->{'mailto'}= &mailto($list,$param->{'to'});
+- $param->{'subject'}= &MIME::Words::encode_mimewords($in{'subject'});
++ $param->{'subject'}= $in{'subject'}; # &tools::encode_mimewords($in{'subject'});
+ $param->{'in_reply_to'}= $in{'in_reply_to'};
+ $param->{'message_id'} = &tools::get_message_id($robot);
+ return 1;