aboutsummaryrefslogtreecommitdiff
path: root/mail/sympa
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-02-16 13:21:22 +0000
committerChris Rees <crees@FreeBSD.org>2013-02-16 13:21:22 +0000
commit9f56d0b8bc189406e02ab0deb569baff95e01bce (patch)
tree4e736da1f1a0fae3b551bb8aaa420f5420da271a /mail/sympa
parentfb97fcf84e0228e6356fa5c60232996438d99c39 (diff)
downloadports-9f56d0b8bc189406e02ab0deb569baff95e01bce.tar.gz
ports-9f56d0b8bc189406e02ab0deb569baff95e01bce.zip
Notes
Diffstat (limited to 'mail/sympa')
-rw-r--r--mail/sympa/Makefile47
-rw-r--r--mail/sympa/distinfo4
-rw-r--r--mail/sympa/pkg-plist4
3 files changed, 28 insertions, 27 deletions
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index 8539f24457ae..442d22ae497a 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -1,12 +1,8 @@
-# Ports collection Makefile for: sympa
-# Date created: 29 November 2003
-# Whom: Autrijus Tang <autrijus@autrijus.org>
-#
+# Created by: Autrijus Tang <autrijus@autrijus.org>
# $FreeBSD$
-#
PORTNAME= sympa
-PORTVERSION= 6.1.16
+PORTVERSION= 6.1.17
CATEGORIES= mail
MASTER_SITES= http://www.sympa.org/distribution/ \
http://www.sympa.org/distribution/old/
@@ -79,41 +75,42 @@ MAN8= alias_manager.8 archived.8 bounced.8 sympa.8
CONFLICTS= sympa-5*
-DB_TYPE:= ${DB_TYPE:L}
+OPTIONS_DEFINE= FASTCGI APACHE
+OPTIONS_DEFAULT=APACHE
+OPTIONS_RADIO= DATABASE
+OPTIONS_RADIO_DATABASE= ORACLE PGSQL SYBASE MYSQL
-.if ${DB_TYPE:Mmysql}
-USE_MYSQL= yes
+SYBASE_DESC= Sybase database
+
+.ifdef DB_TYPE
+DB_TYPE:= ${DB_TYPE:U}
+. for option in ${OPTIONS_RADIO_DATABASE}
+. if ${DB_TYPE} == ${option:S,PGSQL,PG,}
+OPTIONS_SET+= ${option}
+. endif
+. endfor
.endif
.include <bsd.port.options.mk>
-.if defined(WITH_FASTCGI)
+.if ${PORT_OPTIONS:MFASTCGI}
RUN_DEPENDS+= p5-FCGI>=0:${PORTSDIR}/www/p5-FCGI
-. if !defined(WITHOUT_APACHE)
+. if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22+
-RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
+RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
. endif
.endif
-.if ${DB_TYPE:Moracle}
+.if ${PORT_OPTIONS:MORACLE}
RUN_DEPENDS+= p5-DBD-Oracle>=0:${PORTSDIR}/databases/p5-DBD-Oracle
-.elif ${DB_TYPE:Mpg}
+.elif ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
-.elif ${DB_TYPE:Msybase}
+.elif ${PORT_OPTIONS:MSYBASE}
RUN_DEPENDS+= p5-DBD-Sybase>=0:${PORTSDIR}/databases/p5-DBD-Sybase
-.elif ${DB_TYPE:Mmysql}
+.elif ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
-pre-fetch:
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " DB_TYPE=type Optional: mysql, Oracle, Pg or Sybase"
- @${ECHO_MSG} " WITH_FASTCGI Use FastCGI instead of plain CGI"
- @${ECHO_MSG} " WITHOUT_APACHE Use FastCGI without apache (spawn-fcgi or ?)"
- @${ECHO_MSG} ""
-
pre-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
diff --git a/mail/sympa/distinfo b/mail/sympa/distinfo
index d164896ab260..1125bf1d2327 100644
--- a/mail/sympa/distinfo
+++ b/mail/sympa/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sympa-6.1.16.tar.gz) = ba74a532ab36df3e79132a69e53e544c5680517a71745039bdd32da960b04219
-SIZE (sympa-6.1.16.tar.gz) = 7856093
+SHA256 (sympa-6.1.17.tar.gz) = a506ea6e9c88c4a91d22bf146acb06fae5c277e98312b957bdae974739145b79
+SIZE (sympa-6.1.17.tar.gz) = 7881215
diff --git a/mail/sympa/pkg-plist b/mail/sympa/pkg-plist
index 9dffa8947b12..c6bc0d82abe0 100644
--- a/mail/sympa/pkg-plist
+++ b/mail/sympa/pkg-plist
@@ -84,6 +84,8 @@ libexec/sympa/wwsympa.fcgi
%%EXAMPLESDIR%%/charset.conf
%%EXAMPLESDIR%%/crawlers_detection.conf
%%EXAMPLESDIR%%/create_list.conf
+%%EXAMPLESDIR%%/create_list_templates/confidential/comment.tt2
+%%EXAMPLESDIR%%/create_list_templates/confidential/config.tt2
%%EXAMPLESDIR%%/create_list_templates/discussion_list/comment.tt2
%%EXAMPLESDIR%%/create_list_templates/discussion_list/config.tt2
%%EXAMPLESDIR%%/create_list_templates/hotline/comment.tt2
@@ -219,6 +221,7 @@ libexec/sympa/wwsympa.fcgi
%%EXAMPLESDIR%%/scenari/review.private
%%EXAMPLESDIR%%/scenari/review.public
%%EXAMPLESDIR%%/scenari/send.closed
+%%EXAMPLESDIR%%/scenari/send.confidential
%%EXAMPLESDIR%%/scenari/send.default
%%EXAMPLESDIR%%/scenari/send.editorkey
%%EXAMPLESDIR%%/scenari/send.editorkeyonly
@@ -574,6 +577,7 @@ libexec/sympa/wwsympa.fcgi
@dirrm %%EXAMPLESDIR%%/create_list_templates/html-news-letter
@dirrm %%EXAMPLESDIR%%/create_list_templates/hotline
@dirrm %%EXAMPLESDIR%%/create_list_templates/discussion_list
+@dirrm %%EXAMPLESDIR%%/create_list_templates/confidential
@dirrm %%EXAMPLESDIR%%/create_list_templates
@dirrm %%EXAMPLESDIR%%
@dirrm libexec/sympa/Sympa/Template