aboutsummaryrefslogtreecommitdiff
path: root/mail/textmail/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-07 20:17:55 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-07 20:17:55 +0000
commitc6b4f42a5ea82977d1f769085baf30e1d47f0e38 (patch)
tree128be31546860915831e6a63cca141c666c7b622 /mail/textmail/Makefile
parentbca6524f5f7d3b6de3eb3c3d9df28d7c103409c5 (diff)
downloadports-c6b4f42a5ea82977d1f769085baf30e1d47f0e38.tar.gz
ports-c6b4f42a5ea82977d1f769085baf30e1d47f0e38.zip
Notes
Diffstat (limited to 'mail/textmail/Makefile')
-rw-r--r--mail/textmail/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/mail/textmail/Makefile b/mail/textmail/Makefile
new file mode 100644
index 000000000000..faa8c541e032
--- /dev/null
+++ b/mail/textmail/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: textmail
+# Date created: 8 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= textmail
+PORTVERSION= 20070803
+CATEGORIES= graphics
+MASTER_SITES= http://raf.org/textmail/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Converts e-mail attachments to plain-text
+
+RUN_DEPENDS= antiword:${PORTSDIR}/textproc/antiword \
+ catdoc:${PORTSDIR}/textproc/catdoc \
+ xls2csv:${PORTSDIR}/textproc/catdoc \
+ lynx:${PORTSDIR}/www/lynx \
+ pdftotext:${PORTSDIR}/graphics/xpdf
+
+USE_PERL5= yes
+PLIST_FILES= bin/${PORTNAME}
+NO_WRKSUBDIR= yes
+MAN1= ${PORTNAME}.1
+
+do-build:
+ @cd ${WRKSRC}/&&pod2man ${PORTNAME}>${PORTNAME}.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>