aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird-devel
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-11-29 21:12:28 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-11-29 21:12:28 +0000
commit36353c589f868095c2c4e18fcdee86c8345cc2fc (patch)
treecd5afec946f2d0e169655af460f2c7135a2153f5 /mail/thunderbird-devel
parente8f2893f6ebc0fe7c58269e09b77b3e89bee2198 (diff)
Notes
Diffstat (limited to 'mail/thunderbird-devel')
-rw-r--r--mail/thunderbird-devel/Makefile204
-rw-r--r--mail/thunderbird-devel/files/mozconfig.in76
-rw-r--r--mail/thunderbird-devel/files/patch-build_unix_run-mozilla.sh2
-rw-r--r--mail/thunderbird-devel/files/patch-config_autoconf.mk.in18
-rw-r--r--mail/thunderbird-devel/files/patch-configure38
-rw-r--r--mail/thunderbird-devel/files/patch-libm25
-rw-r--r--mail/thunderbird-devel/files/patch-nopangoxft20
-rw-r--r--mail/thunderbird-devel/files/patch-nspr-unix.c21
-rw-r--r--mail/thunderbird-devel/files/patch-sysnss178
-rw-r--r--mail/thunderbird-devel/pkg-deinstall.in5
-rw-r--r--mail/thunderbird-devel/pkg-install.in2
11 files changed, 278 insertions, 311 deletions
diff --git a/mail/thunderbird-devel/Makefile b/mail/thunderbird-devel/Makefile
index f7347c599657..00a44fbdff49 100644
--- a/mail/thunderbird-devel/Makefile
+++ b/mail/thunderbird-devel/Makefile
@@ -3,7 +3,7 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/mail/thunderbird-devel/Makefile,v 1.11 2005/10/11 03:28:04 marcus Exp $
+# $MCom: ports/mail/thunderbird-devel/Makefile,v 1.15 2005/11/23 04:54:58 ahze Exp $
#
PORTNAME= thunderbird
@@ -17,54 +17,31 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-source
MAINTAINER= gnome@FreeBSD.org
COMMENT= Mozilla Thunderbird is standalone mail and news that stands above
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- Xft.2:${PORTSDIR}/x11-fonts/libXft
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-
-USE_X_PREFIX= yes
-
-USE_GCC= 3.4+
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_ICONV= yes
-USE_PERL5= yes
-USE_REINPLACE= yes
-HAS_CONFIGURE= yes
-NO_MTREE= yes
-PLIST= ${WRKDIR}/plist
+WANT_GNOME= yes
ALL_TARGET= default
-USE_GNOME= gtk20 libidl
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
-PKGINSTALL= ${WRKDIR}/pkg-install
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-FAKEDIR= ${WRKDIR}/fake
+HAS_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
- --exclude */macbuild/*\
- --exclude */package/* \
- --exclude .cvsignore \
- --exclude makefile.win \
- --exclude MANIFEST
+MOZ_EXTENSIONS= wallet,spellcheck,xmlextras,webservices
+MOZ_PROTOCOLS= http,file,jar,viewsource,res,data
+MOZ_GRAPHICS= default,-xbm
+MOZ_OPTIONS= --enable-single-profile --disable-profilesharing \
+ --enable-application=mail -enable-official-branding
+MOZ_MK_OPTIONS= MOZ_MOZ_THUNDERBIRD=1
+MOZ_EXPORT= MOZ_THUNDERBIRD=1
-NO_MTREE= yes
-WRKSRC= ${WRKDIR}/mozilla
-LOCAL_SUBDIR= lib/${PORTNAME}
-LOCAL_PREFIX= ${PREFIX}/${LOCAL_SUBDIR}
+PORTNAME_ICON= ${PREFIX}/lib/${PORTNAME}/chrome/icons/default/default.xpm
-THUNDERBIRD= ${PORTNAME}
-THUNDERBIRD_VER= 1.5
-THUNDERBIRD_ICON_SRC= ${LOCAL_PREFIX}/lib/${THUNDERBIRD}-${THUNDERBIRD_VER}/icons/default.xpm
-THUNDERBIRD_ICON= ${PORTNAME}.xpm
-MOZ_PIS_SCRIPTS= S50cleanhome
-SCRIPTS_DIR= ${FAKEDIR}/${LOCAL_SUBDIR}/lib/${PORTNAME}-${THUNDERBIRD_VER}
-MOZ_PIS_DIR= ${SCRIPTS_DIR}/init.d
+SYSTEM_PREFS= ${FAKEDIR}/lib/${PORTNAME}-${PORTVERSION}/defaults/pref/${PORTNAME}.js
+MOZ_PIS_SCRIPTS=moz_pis_S50cleanhome
-OPTIONS= DEBUG "Build a debugging image" off \
- LOGGING "Enable additional log messages" off \
- OPTIMIZED_CFLAGS "Enable some additional optimizations" off
+CONFLICTS= thunderbird-1.0*
.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/mozilla/Makefile.common"
.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
IGNORE= core dumps at runtime
@@ -74,147 +51,30 @@ IGNORE= core dumps at runtime
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif # ${PERL_LEVEL} < 500600
-.if defined(WITH_DEBUG)
-WITH_LOGGING= yes
-CONFIGURE_ENV+= WITH_DEBUG=yes
-.endif # defined(WITH_DEBUG)
-
-.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS:= -O2 -fno-strict-aliasing ${CFLAGS:N-O*}
-.else
-CFLAGS:= -O ${CFLAGS:N-O*:N-m*}
-CONFIGURE_ENV+= WITH_OPTIMIZE=-O
-.endif # defined(WITH_OPTIMIZED_CFLAGS)
-
-.if defined(WITH_LOGGING)
-CONFIGURE_ENV+= WITH_LOGGING=yes
-.endif # defined(WITH_LOGGING)
-
-CPPFLAGS+= -I${X11BASE}/include
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${X11BASE}/lib
-LIBS+= ${PTHREAD_LIBS}
-
-pre-extract::
- @${ECHO_MSG}
- @${ECHO_MSG} "Extracting source (this takes a while) ..."
- @${ECHO_MSG}
-
post-extract::
-# FAKEDIR is here so that nsinstall will install under FAKEDIR, not
-# under PREFIX. See pre-install and do-install for details.
- @${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
- -e 's|@CFLAGS@|${CFLAGS}|' \
- -e 's|@LDFLAGS@|${LDFLAGS}|' \
- -e 's|@LIBS@|${LIBS}|' \
- -e 's|@X11BASE@|${X11BASE}|' \
- -e 's|@LOCALBASE@|${LOCALBASE}|' \
- -e 's|@PREFIX@|${FAKEDIR}/lib/thunderbird|' \
- -e 's|@PERL@|${PERL5}|' \
- <${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
+ @${SED} -e 's|@PORTNAME_ICON@|${PORTNAME_ICON}|' \
+ <${FILESDIR}/${PORTNAME}.desktop.in >${WRKDIR}/${PORTNAME}.desktop
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/build/unix/run-mozilla.sh
- @${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure \
- ${WRKSRC}/nsprpub/configure
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/nsprpub/configure \
- ${WRKSRC}/security/coreconf/FreeBSD.mk \
- ${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
- ${WRKSRC}/js/src/Makefile.in
- @${REINPLACE_CMD} -E -e 's|libesd\.so\.[0-9]+|libesd.so|g' \
- ${WRKSRC}/widget/src/gtk2/nsSound.cpp
- @${REINPLACE_CMD} -E -e 's|libcups\.so\.[0-9]+|libcups.no|g' \
- ${WRKSRC}/gfx/src/gtk/nsDeviceContextSpecG.cpp
- @${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/ ; \
- /dom.disable_window_open_feature.toolbar/s/false/true/' \
- ${WRKSRC}/modules/libpref/src/init/all.js \
- ${WRKSRC}/extensions/sroaming/resources/content/prefs/all.js \
- ${WRKSRC}/modules/libpref/src/init/all.js
+ @${REINPLACE_CMD} -e 's|/usr/local/netscape|${LOCALBASE}|g' \
+ -e 's|/usr/local/lib/netscape|${LOCALBASE}/lib|g' \
+ ${WRKSRC}/xpcom/*/SpecialSystemDirectory.cpp
+ @${FIND} ${WRKSRC} -name all.js | ${XARGS} ${REINPLACE_CMD} -e \
+ '/accessibility.typeaheadfind.enablesound/s/true/false/ ; \
+ /dom.disable_window_open_feature.toolbar/s/false/true/'
@${REINPLACE_CMD} -e 's|<iconv.h>|\"${LOCALBASE}/include/iconv.h\"|g' \
${WRKSRC}/configure \
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
- @${SED} -e 's|@THUNDERBIRD_ICON@|${THUNDERBIRD_ICON}|' \
- < ${FILESDIR}/thunderbird.desktop.in > ${WRKDIR}/thunderbird.desktop
-.for ii in ${MOZ_PIS_SCRIPTS}
- @${SED} -e 's|%%MOZILLA%%|${THUNDERBIRD}|g ; \
- s|%%PREFIX%%|${PREFIX}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' \
- < ${FILESDIR}/moz_pis_${ii} > ${WRKDIR}/moz_pis_${ii}
-.endfor
-
-pre-configure:
- @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
- ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
- ${FALSE}; \
- fi
pre-install:
- @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${THUNDERBIRD_VER}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' \
- < ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
- @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${THUNDERBIRD_VER}|g' \
- < ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
-# Overview: the program installs itself in FAKEDIR, then a list is made of the
-# files and directories in there. This is the PLIST (packing list) for the
-# package, replacing the traditional pkg-plist file.
- @${RM} -rf ${FAKEDIR} ${PLIST}
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- Makefile ${MAKE_ARGS} ${INSTALL_TARGET}
- @${MKDIR} ${SCRIPTS_DIR}
- @${MKDIR} ${MOZ_PIS_DIR}
- ${RM} -rf ${FAKEDIR}/lib/${THUNDERBIRD}/lib/${THUNDERBIRD}-${THUNDERBIRD_VER}/extensions
-.for ii in mac win
-.for jj in / .jar
- @${RM} -rf ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/chrome/en-${ii}${jj}
-.endfor
-.endfor
- @${RM} -fr ${FAKEDIR}/share/idl ${FAKEDIR}/include
-.for ii in thunderbird thunderbird-config
- @${ECHO_CMD} bin/${ii} >> ${PLIST}
-.endfor
-.for ii in ${MOZ_PIS_SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKDIR}/moz_pis_${ii} ${MOZ_PIS_DIR}/${ii}
-.endfor
- @${MKDIR} ${FAKEDIR}/${LOCAL_SUBDIR}/lib/${PORTNAME}-${PORTVERSION}/defaults
- @${CP} -RL ${WRKSRC}/dist/bin/defaults/isp \
- ${FAKEDIR}/${LOCAL_SUBDIR}/lib/${PORTNAME}-${PORTVERSION}/defaults
- @cd ${FAKEDIR} && ${FIND} * ! -type d | ${SORT} >> ${PLIST}; \
- ${FIND} * -type d -empty | ${SORT} | ${SED} -e \
- "s:^:@exec ${MKDIR} %D/:" -e "s:$$: || true:" >> ${PLIST}; \
- ${FIND} * -type d -empty | ${SORT} -r | ${SED} -e \
- "s:^:@unexec ${RMDIR} %D/:" -e "s:$$: || true:" >> ${PLIST}; \
- ${FIND} * -type d ! -empty | ${SORT} -r | ${SED} -e "s:^:@dirrm :" | \
- ${GREP} / >> ${PLIST}
- ${ECHO_CMD} 'share/applications/thunderbird.desktop' >> ${PLIST}
- ${ECHO_CMD} 'share/pixmaps/${THUNDERBIRD_ICON}' >> ${PLIST}
- ${ECHO_CMD} '@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}' >> ${PLIST}
-
-do-install:
-# This is the actual installation. First, the contents of FAKEDIR are
-# just copied to PREFIX.
- cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
+ ${ECHO_CMD} 'share/applications/${PORTNAME}.desktop' >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${PLIST}
post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- ${MKDIR} ${PREFIX}/bin
- ${RM} -f ${PREFIX}/bin/thunderbird
- ${LN} -s ${LOCAL_PREFIX}/bin/thunderbird \
- ${PREFIX}/bin/thunderbird
- ${RM} -f ${PREFIX}/bin/thunderbird-config
- ${LN} -s ${LOCAL_PREFIX}/bin/thunderbird-config \
- ${PREFIX}/bin/thunderbird-config
- ${PERL} -pi -e 's|${FAKEDIR}|${PREFIX}|g' \
- ${LOCAL_PREFIX}/bin/thunderbird \
- ${LOCAL_PREFIX}/bin/thunderbird-config
- ${FIND} ${LOCAL_PREFIX}/lib/pkgconfig -type f | ${XARGS} \
- ${PERL} -pi -e 's|${FAKEDIR}|${PREFIX}|g'
- ${MKDIR} ${PREFIX}/share/applications ${PREFIX}/share/pixmaps
- ${INSTALL_DATA} ${WRKDIR}/thunderbird.desktop ${PREFIX}/share/applications
- ${LN} -sf ${THUNDERBIRD_ICON_SRC} ${PREFIX}/share/pixmaps/${THUNDERBIRD_ICON}
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/other-licenses/branding/${PORTNAME}/default.xpm \
+ ${PREFIX}/lib/${PORTNAME}/chrome/icons/default/default.xpm
.include <bsd.port.post.mk>
diff --git a/mail/thunderbird-devel/files/mozconfig.in b/mail/thunderbird-devel/files/mozconfig.in
deleted file mode 100644
index 08c357be6731..000000000000
--- a/mail/thunderbird-devel/files/mozconfig.in
+++ /dev/null
@@ -1,76 +0,0 @@
-# .mozconfig.in -*-shell-script-*-
-# $FreeBSD$
-# $MCom: ports/mail/thunderbird-devel/files/mozconfig.in,v 1.5 2005/06/28 05:40:07 adamw Exp $
-######################################################################
-# standard opts from README
-export MOZ_THUNDERBIRD=1
-mk_add_options MOZ_MOZ_THUNDERBIRD=1
-ac_add_options --enable-application=mail
-ac_add_options --enable-crypto
-ac_add_options --disable-mathml
-ac_add_options --disable-activex
-ac_add_options --disable-activex-scripting
-ac_add_options --disable-oji
-ac_add_options --disable-necko-disk-cache
-ac_add_options --disable-tests
-ac_add_options --disable-profilesharing
-ac_add_options --enable-single-profile
-ac_add_options --disable-freetype2
-ac_add_options --enable-extensions=wallet,spellcheck,xmlextras,webservices
-ac_add_options --enable-necko-protocols=http,file,jar,viewsource,res,data
-ac_add_options --enable-image-decoders=default,-xbm
-ac_add_options --enable-default-toolkit=gtk2
-# See the following URL for approval email for using official branding
-# http://people.freebsd.org/~ahze/firefox_thunderbird-approved.txt
-ac_add_options --enable-official-branding
-######################################################################
-# FBSD specific
-export CPPFLAGS="@CPPFLAGS@"
-export CFLAGS="@CFLAGS@"
-export LIBS="@LIBS@"
-export LDFLAGS="@LDFLAGS@"
-export CONFIG_SH=/bin/sh
-export XP_UNIX=1
-mk_add_options XP_UNIX=1
-export PERL="@PERL@"
-mk_add_options PERL=$PERL
-# Configure options for installation
-ac_add_options --prefix=@PREFIX@
-######################################################################
-# Use ports for these libraries
-ac_add_options --with-system-jpeg=@LOCALBASE@
-ac_add_options --with-system-zlib
-ac_add_options --with-system-png=@LOCALBASE@
-######################################################################
-# set compile/link features
-ac_add_options --with-pthreads
-######################################################################
-# conditional from port Makefile
-#if test -n "$WITH_REORDER"; then
-# ac_add_options --enable-reorder
-#else
-# ac_add_options --disable-reorder
-#fi # test -n "$WITH_REORDER"
-if test -n "$WITH_DEBUG"; then
- ac_add_options --enable-debug
- ac_add_options --disable-strip
-else
- ac_add_options --disable-debug
- ac_add_options --enable-optimize=${WITH_OPTIMIZE}
- ac_add_options --enable-strip
- export BUILD_OFFICIAL=1
- export MOZILLA_OFFICIAL=1
- mk_add_options BUILD_OFFICIAL=1
- mk_add_options MOZILLA_OFFICIAL=1
-fi # test -n "$WITH_DEBUG"
-if test -n "$WITH_LOGGING"; then
- ac_add_options --enable-logging
-else
- ac_add_options --disable-logging
-fi # test -n "$WITH_LOGGING"
-if test -z "$WITHOUT_XFT"; then
- ac_add_options --enable-xft
-else
- ac_add_options --disable-xft
-fi # test -z "$WITHOUT_XFT"
-######################################################################
diff --git a/mail/thunderbird-devel/files/patch-build_unix_run-mozilla.sh b/mail/thunderbird-devel/files/patch-build_unix_run-mozilla.sh
index 28bbd1a1154e..7e038a39d310 100644
--- a/mail/thunderbird-devel/files/patch-build_unix_run-mozilla.sh
+++ b/mail/thunderbird-devel/files/patch-build_unix_run-mozilla.sh
@@ -5,7 +5,7 @@
##
## Set LD_LIBRARY_PATH
-LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
-+LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:%%PREFIX%%/lib/browser_plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
++LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:%%PREFIX%%/lib/browser_plugins:%%PREFIX%%/lib/browser_linux_plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
if [ -n "$LD_LIBRARYN32_PATH" ]
then
LD_LIBRARYN32_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARYN32_PATH+":$LD_LIBRARYN32_PATH"}
diff --git a/mail/thunderbird-devel/files/patch-config_autoconf.mk.in b/mail/thunderbird-devel/files/patch-config_autoconf.mk.in
new file mode 100644
index 000000000000..29fe7f8fbde0
--- /dev/null
+++ b/mail/thunderbird-devel/files/patch-config_autoconf.mk.in
@@ -0,0 +1,18 @@
+--- config/autoconf.mk.in.orig Thu Jul 14 00:50:06 2005
++++ config/autoconf.mk.in Thu Jul 14 00:50:40 2005
+@@ -50,13 +50,13 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+-includedir = @includedir@/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++includedir = @includedir@/%%MOZILLA%%
+ libdir = @libdir@
+ datadir = @datadir@
+ mandir = @mandir@
+ idldir = @datadir@/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+
+-mozappdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++mozappdir = $(libdir)/%%MOZILLA%%
+ mredir = $(libdir)/mre/mre-$(MOZ_APP_VERSION)
+ mrelibdir = $(mredir)/lib
+
diff --git a/mail/thunderbird-devel/files/patch-configure b/mail/thunderbird-devel/files/patch-configure
deleted file mode 100644
index 9e60372adb33..000000000000
--- a/mail/thunderbird-devel/files/patch-configure
+++ /dev/null
@@ -1,38 +0,0 @@
---- configure.orig Fri Feb 13 01:06:29 2004
-+++ configure Fri Feb 13 01:07:17 2004
-@@ -9181,7 +9181,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-liconv $LIBS"
-+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 9187 "configure"
- #include "confdefs.h"
-@@ -9212,7 +9212,7 @@
- fi
- if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- _ICONV_LIBS="$_ICONV_LIBS -liconv"
-+ _ICONV_LIBS="$_ICONV_LIBS -L$LOCALBASE/lib -liconv"
- else
- echo "$ac_t""no" 1>&6
- echo $ac_n "checking for libiconv in -liconv""... $ac_c" 1>&6
-@@ -9222,7 +9222,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-liconv $LIBS"
-+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 9228 "configure"
- #include "confdefs.h"
-@@ -9253,7 +9253,7 @@
- fi
- if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- _ICONV_LIBS="$_ICONV_LIBS -liconv"
-+ _ICONV_LIBS="$_ICONV_LIBS -L$LOCALBASE/lib -liconv"
- else
- echo "$ac_t""no" 1>&6
- fi
diff --git a/mail/thunderbird-devel/files/patch-libm b/mail/thunderbird-devel/files/patch-libm
new file mode 100644
index 000000000000..7de64b2a5068
--- /dev/null
+++ b/mail/thunderbird-devel/files/patch-libm
@@ -0,0 +1,25 @@
+--- js/src/Makefile.in Thu Aug 4 22:26:52 2005
++++ js/src/Makefile.in Thu Aug 4 23:02:32 2005
+@@ -148,5 +148,4 @@
+ endif
+
+-FDLIBM_LIBRARY = fdlibm/$(LIB_PREFIX)fdm.$(LIB_SUFFIX)
+ JSMATH_PRELINK = jsmathtemp.o
+ JS_SAFE_ARENA = 1
+@@ -320,7 +319,4 @@
+ endif
+ @$(RM) -f $(JSMATH_PRELINK)
+-else
+-# Create dependency so we build fdlibm
+-jsmath.o: $(FDLIBM_LIBRARY) Makefile.in
+ endif
+
+--- js/Makefile.in Sun Mar 23 14:36:00 2003
++++ js/Makefile.in Thu Aug 4 23:08:06 2005
+@@ -46,5 +46,5 @@
+ #
+
+-DIRS = src/fdlibm src
++DIRS = src
+
+ include $(topsrcdir)/config/rules.mk
diff --git a/mail/thunderbird-devel/files/patch-nopangoxft b/mail/thunderbird-devel/files/patch-nopangoxft
new file mode 100644
index 000000000000..5a11c8c4864e
--- /dev/null
+++ b/mail/thunderbird-devel/files/patch-nopangoxft
@@ -0,0 +1,20 @@
+--- gfx/src/gtk/mozilla-decoder.cpp.orig 2005-08-18 22:41:26.000000000 -0400
++++ gfx/src/gtk/mozilla-decoder.cpp 2005-08-18 22:38:01.000000000 -0400
+@@ -40,7 +40,7 @@
+ #define PANGO_ENABLE_ENGINE
+
+ #include "mozilla-decoder.h"
+-#include <pango/pangoxft.h>
++#include <pango/pangocairo.h>
+ #include <pango/pangofc-fontmap.h>
+ #include <pango/pangofc-font.h>
+ #include <gdk/gdkx.h>
+@@ -208,7 +208,7 @@
+ }
+ }
+
+- pango_fc_font_map_add_decoder_find_func(PANGO_FC_FONT_MAP(pango_xft_get_font_map(GDK_DISPLAY(),gdk_x11_get_default_screen())),
++ pango_fc_font_map_add_decoder_find_func(PANGO_FC_FONT_MAP(pango_cairo_font_map_get_default()),
+ mozilla_find_decoder,
+ NULL,
+ NULL);
diff --git a/mail/thunderbird-devel/files/patch-nspr-unix.c b/mail/thunderbird-devel/files/patch-nspr-unix.c
deleted file mode 100644
index 6bb4ed08fb40..000000000000
--- a/mail/thunderbird-devel/files/patch-nspr-unix.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- nsprpub/pr/src/md/unix/unix.c.orig Sat May 31 18:06:04 2003
-+++ nsprpub/pr/src/md/unix/unix.c Sat May 31 18:04:43 2003
-@@ -65,7 +65,8 @@
- * PRInt32* pointer to a _PRSockLen_t* pointer.
- */
- #if defined(HAVE_SOCKLEN_T) \
-- || (defined(LINUX) && defined(__GLIBC__) && __GLIBC__ >= 2)
-+ || (defined(LINUX) && defined(__GLIBC__) && __GLIBC__ >= 2) \
-+ || defined(FREEBSD)
- #define _PRSockLen_t socklen_t
- #elif defined(IRIX) || defined(HPUX) || defined(OSF1) || defined(SOLARIS) \
- || defined(AIX4_1) || defined(LINUX) || defined(SONY) \
-@@ -73,7 +74,7 @@
- || defined(SUNOS4) || defined(NCR) || defined(DARWIN) \
- || defined(NEXTSTEP) || defined(QNX)
- #define _PRSockLen_t int
--#elif (defined(AIX) && !defined(AIX4_1)) || defined(FREEBSD) \
-+#elif (defined(AIX) && !defined(AIX4_1)) \
- || defined(NETBSD) || defined(OPENBSD) || defined(UNIXWARE) \
- || defined(DGUX) || defined(VMS) || defined(NTO)
- #define _PRSockLen_t size_t
diff --git a/mail/thunderbird-devel/files/patch-sysnss b/mail/thunderbird-devel/files/patch-sysnss
new file mode 100644
index 000000000000..d854cabc053a
--- /dev/null
+++ b/mail/thunderbird-devel/files/patch-sysnss
@@ -0,0 +1,178 @@
+--- Makefile.in Tue Sep 14 16:59:40 2004
++++ Makefile.in Tue Aug 2 08:26:55 2005
+@@ -102,6 +102,4 @@
+ # tier 1 - 3rd party individual libraries
+ #
+-tier_1_dirs += dbm
+-
+ ifndef MOZ_NATIVE_JPEG
+ tier_1_dirs += jpeg
+--- security/manager/Makefile.in Mon Mar 28 19:56:36 2005
++++ security/manager/Makefile.in Tue Aug 2 09:02:50 2005
+@@ -37,16 +37,7 @@
+ SOFTOKEN3_LIB \
+ SOFTOKEN3_CHK \
+- LOADABLE_ROOT_MODULE \
+ HAVE_FREEBL_MODULES \
+ $(NULL)
+
+-LOADABLE_ROOT_MODULE = $(DLL_PREFIX)nssckbi$(DLL_SUFFIX)
+-
+-NSS3_LIB = $(DLL_PREFIX)nss3$(DLL_SUFFIX)
+-SMIME3_LIB = $(DLL_PREFIX)smime3$(DLL_SUFFIX)
+-SSL3_LIB = $(DLL_PREFIX)ssl3$(DLL_SUFFIX)
+-SOFTOKEN3_LIB = $(DLL_PREFIX)softokn3$(DLL_SUFFIX)
+-SOFTOKEN3_CHK = $(DLL_PREFIX)softokn3.chk
+-
+ ifneq (,$(filter SunOS HP-UX,$(OS_ARCH)))
+ ifeq (,$(filter i86pc ia64,$(OS_TEST)))
+@@ -132,9 +123,4 @@
+ .nss.cleaned: .nss.checkout
+ $(MAKE) -C $(topsrcdir)/security/coreconf $(DEFAULT_GMAKE_FLAGS) clean
+- $(MAKE) -C $(topsrcdir)/security/nss/lib $(DEFAULT_GMAKE_FLAGS) clean
+-ifndef SKIP_CHK
+- $(MAKE) -C $(topsrcdir)/security/nss/cmd/lib $(DEFAULT_GMAKE_FLAGS) clean
+- $(MAKE) -C $(topsrcdir)/security/nss/cmd/shlibsign $(DEFAULT_GMAKE_FLAGS) clean
+-endif
+ touch $@
+
+@@ -153,43 +139,4 @@
+ ifeq ($(OS_ARCH),WINNT)
+ cd $(DIST)/lib; cp -f $(LIB_PREFIX)dbm$(MOZ_BITS).$(LIB_SUFFIX) $(LIB_PREFIX)dbm.$(LIB_SUFFIX)
+-else
+- cd $(DIST)/lib; cp -f $(LIB_PREFIX)mozdbm_s.$(LIB_SUFFIX) $(LIB_PREFIX)dbm.$(LIB_SUFFIX); $(RANLIB) $(LIB_PREFIX)dbm.$(LIB_SUFFIX)
+-endif
+- $(MAKE) -C $(topsrcdir)/security/nss/lib $(DEFAULT_GMAKE_FLAGS)
+-ifndef SKIP_CHK
+- $(MAKE) -C $(topsrcdir)/security/nss/cmd/lib $(DEFAULT_GMAKE_FLAGS)
+- $(MAKE) -C $(topsrcdir)/security/nss/cmd/shlibsign $(DEFAULT_GMAKE_FLAGS)
+-endif
+-ifndef DISABLE_DIST_GRE
+- $(INSTALL) -m 755 $(DIST)/lib/$(LOADABLE_ROOT_MODULE) $(GRE_DIST)
+-ifndef SKIP_CHK
+- $(INSTALL) -m 644 $(DIST)/lib/$(SOFTOKEN3_CHK) $(GRE_DIST)
+-endif
+- $(INSTALL) -m 755 $(DIST)/lib/$(SOFTOKEN3_LIB) $(GRE_DIST)
+- $(INSTALL) -m 755 $(DIST)/lib/$(NSS3_LIB) $(GRE_DIST)
+- $(INSTALL) -m 755 $(DIST)/lib/$(SSL3_LIB) $(GRE_DIST)
+- $(INSTALL) -m 755 $(DIST)/lib/$(SMIME3_LIB) $(GRE_DIST)
+-ifdef HAVE_FREEBL_MODULES
+- $(INSTALL) -m 644 $(DIST)/lib/$(FREEBL_PURE32_CHK) $(GRE_DIST)
+- $(INSTALL) -m 755 $(DIST)/lib/$(FREEBL_PURE32_MODULE) $(GRE_DIST)
+- $(INSTALL) -m 644 $(DIST)/lib/$(FREEBL_HYBRID_CHK) $(GRE_DIST)
+- $(INSTALL) -m 755 $(DIST)/lib/$(FREEBL_HYBRID_MODULE) $(GRE_DIST)
+-endif
+-endif
+-ifndef _SKIP_OLD_GRE_INSTALL
+- $(INSTALL) -m 755 $(DIST)/lib/$(LOADABLE_ROOT_MODULE) $(DIST)/bin
+-ifndef SKIP_CHK
+- $(INSTALL) -m 644 $(DIST)/lib/$(SOFTOKEN3_CHK) $(DIST)/bin
+-endif
+- $(INSTALL) -m 755 $(DIST)/lib/$(SOFTOKEN3_LIB) $(DIST)/bin
+- $(INSTALL) -m 755 $(DIST)/lib/$(NSS3_LIB) $(DIST)/bin
+- $(INSTALL) -m 755 $(DIST)/lib/$(SSL3_LIB) $(DIST)/bin
+- $(INSTALL) -m 755 $(DIST)/lib/$(SMIME3_LIB) $(DIST)/bin
+-ifdef HAVE_FREEBL_MODULES
+- $(INSTALL) -m 644 $(DIST)/lib/$(FREEBL_PURE32_CHK) $(DIST)/bin
+- $(INSTALL) -m 755 $(DIST)/lib/$(FREEBL_PURE32_MODULE) $(DIST)/bin
+- $(INSTALL) -m 644 $(DIST)/lib/$(FREEBL_HYBRID_CHK) $(DIST)/bin
+- $(INSTALL) -m 755 $(DIST)/lib/$(FREEBL_HYBRID_MODULE) $(DIST)/bin
+-endif
+ endif
+ $(MAKE) -C boot $@
+@@ -200,18 +147,4 @@
+
+ install::
+- $(SYSINSTALL) -m 755 $(DIST)/lib/$(LOADABLE_ROOT_MODULE) $(DESTDIR)$(mozappdir)
+-ifndef SKIP_CHK
+- $(SYSINSTALL) -m 644 $(DIST)/lib/$(SOFTOKEN3_CHK) $(DESTDIR)$(mozappdir)
+-endif
+- $(SYSINSTALL) -m 755 $(DIST)/lib/$(SOFTOKEN3_LIB) $(DESTDIR)$(mozappdir)
+- $(SYSINSTALL) -m 755 $(DIST)/lib/$(NSS3_LIB) $(DESTDIR)$(mozappdir)
+- $(SYSINSTALL) -m 755 $(DIST)/lib/$(SSL3_LIB) $(DESTDIR)$(mozappdir)
+- $(SYSINSTALL) -m 755 $(DIST)/lib/$(SMIME3_LIB) $(DESTDIR)$(mozappdir)
+-ifdef HAVE_FREEBL_MODULES
+- $(SYSINSTALL) -m 644 $(DIST)/lib/$(FREEBL_PURE32_CHK) $(DESTDIR)$(mozappdir)
+- $(SYSINSTALL) -m 755 $(DIST)/lib/$(FREEBL_PURE32_MODULE) $(DESTDIR)$(mozappdir)
+- $(SYSINSTALL) -m 644 $(DIST)/lib/$(FREEBL_HYBRID_CHK) $(DESTDIR)$(mozappdir)
+- $(SYSINSTALL) -m 755 $(DIST)/lib/$(FREEBL_HYBRID_MODULE) $(DESTDIR)$(mozappdir)
+-endif
+ $(MAKE) -C boot $@
+ $(MAKE) -C ssl $@
+@@ -227,9 +160,4 @@
+ endif
+ $(MAKE) -C $(topsrcdir)/security/coreconf $(DEFAULT_GMAKE_FLAGS) clean
+- $(MAKE) -C $(topsrcdir)/security/nss/lib $(DEFAULT_GMAKE_FLAGS) clean
+-ifndef SKIP_CHK
+- $(MAKE) -C $(topsrcdir)/security/nss/cmd/lib $(DEFAULT_GMAKE_FLAGS) clean
+- $(MAKE) -C $(topsrcdir)/security/nss/cmd/shlibsign $(DEFAULT_GMAKE_FLAGS) clean
+-endif
+
+ echo-requires-recursive::
+--- security/manager/ssl/src/Makefile.in Wed Jan 7 08:36:51 2004
++++ security/manager/ssl/src/Makefile.in Tue Aug 2 09:13:07 2005
+@@ -117,5 +117,5 @@
+ # Use local includes because they are inserted before INCLUDES
+ # so that Mozilla's nss.h is used, not glibc's
+-LOCAL_INCLUDES += -I$(DIST)/public/nss \
++LOCAL_INCLUDES += -I$(LOCALBASE)/include/nss/nss \
+ $(NULL)
+
+--- config/config.mk Tue Oct 12 00:11:11 2004
++++ config/config.mk Tue Aug 2 09:19:18 2005
+@@ -170,5 +170,4 @@
+ NSS_LIBS = \
+ $(LIBS_DIR) \
+- $(DIST)/lib/$(LIB_PREFIX)crmf.$(LIB_SUFFIX) \
+ -lsmime3 \
+ -lssl3 \
+@@ -189,11 +188,5 @@
+ endif
+
+-NSS_DEP_LIBS = \
+- $(DIST)/lib/$(LIB_PREFIX)crmf.$(LIB_SUFFIX) \
+- $(DIST)/lib/$(DLL_PREFIX)smime3$(DLL_SUFFIX) \
+- $(DIST)/lib/$(DLL_PREFIX)ssl3$(DLL_SUFFIX) \
+- $(DIST)/lib/$(DLL_PREFIX)nss3$(DLL_SUFFIX) \
+- $(DIST)/lib/$(DLL_PREFIX)softokn3$(DLL_SUFFIX) \
+- $(NULL)
++NSS_DEP_LIBS =
+
+ MOZ_UNICHARUTIL_LIBS = $(DIST)/lib/$(LIB_PREFIX)unicharutil_s.$(LIB_SUFFIX)
+--- security/manager/ssl/src/nsNSSComponent.cpp Thu Apr 22 15:48:30 2004
++++ security/manager/ssl/src/nsNSSComponent.cpp Thu Aug 4 16:44:27 2005
+@@ -88,4 +88,8 @@
+ }
+
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <errno.h>
++
+ #ifdef PR_LOGGING
+ PRLogModuleInfo* gPIPNSSLog = nsnull;
+@@ -406,4 +410,5 @@
+ const char *possible_ckbi_locations[] = {
+ NS_GRE_DIR,
++ NS_UNIX_LIB_DIR,
+ NS_XPCOM_CURRENT_PROCESS_DIR
+ };
+@@ -419,5 +424,5 @@
+ }
+
+- char *fullModuleName = nsnull;
++ char *fullModuleName;
+ #ifdef XP_MAC
+ nsCAutoString nativePath;
+@@ -431,4 +436,12 @@
+ fullModuleName = PR_GetLibraryName(processDir.get(), "nssckbi");
+ #endif
++ if (fullModuleName == nsnull)
++ continue;
++ struct stat sb;
++ if (stat(fullModuleName, &sb)) {
++ if (errno != ENOENT)
++ perror(fullModuleName);
++ continue;
++ }
+ /* If a module exists with the same name, delete it. */
+ NS_ConvertUCS2toUTF8 modNameUTF8(modName);
diff --git a/mail/thunderbird-devel/pkg-deinstall.in b/mail/thunderbird-devel/pkg-deinstall.in
index 8d4995f057fa..c921e64d63d8 100644
--- a/mail/thunderbird-devel/pkg-deinstall.in
+++ b/mail/thunderbird-devel/pkg-deinstall.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/mail/thunderbird-devel/pkg-deinstall.in,v 1.6 2005/09/12 21:01:45 marcus Exp $
+# $MCom: ports/mail/thunderbird-devel/pkg-deinstall.in,v 1.9 2005/11/22 21:29:14 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
@@ -16,12 +16,13 @@ PATH=/bin:/usr/bin
MOZDIR=%%MOZDIR%%
rm -rf ${MOZDIR}/chrome/overlayinfo
+rm -rf ${MOZDIR}/chrome/icons/default/default.xpm
rm -f ${MOZDIR}/chrome/*.rdf ${MOZDIR}/chrome/app-chrome.manifest
rm -f ${MOZDIR}/component.reg
rm -f ${MOZDIR}/components.ini
rm -f ${MOZDIR}/defaults.ini
rm -f ${MOZDIR}/components/*.dat
-rm -rf ${MOZDIR}/extensions
+#rm -rf ${MOZDIR}/extensions
rm -rf ${MOZDIR}/updates
exit 0
diff --git a/mail/thunderbird-devel/pkg-install.in b/mail/thunderbird-devel/pkg-install.in
index b70c93e4b394..39e08dad1695 100644
--- a/mail/thunderbird-devel/pkg-install.in
+++ b/mail/thunderbird-devel/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/mail/thunderbird-devel/pkg-install.in,v 1.5 2005/06/28 05:40:07 adamw Exp $
+# $MCom: ports/mail/thunderbird-devel/pkg-install.in,v 1.7 2005/11/18 10:05:25 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)