aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird-esr/Makefile
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-07-26 21:49:58 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-07-26 21:49:58 +0000
commit30c1a0a7927d6992cbf7baf9e8e1f637b2e4f6d4 (patch)
tree89c0045d73cc71a8a86842d8aa10f24e71cb5f26 /mail/thunderbird-esr/Makefile
parentd7df099ed9e71aeb1cf30ae4e058f52c668df365 (diff)
- update firefox/thunderbird ESR versions to 10.0.6
- update firefox 14.0.1 - update thunderbird to 14.0 - update seamonkey to 2.11 - switch to new options framework - add experimental rendering via cairo-qt (QT4 option) - add audio backend options (ALSA and PulseAudio) - rename SMB option to GNOMEVFS2 - turn on LOGGING by default (like upstream linux builds) - improve about:memory output - unbreak PGO - use system libs [1] - switch to libevent2 [2] - fix conflict with devel/libunwind and base gcc [3] - unbreak clang/libc++ build [4] - unbreak build with base gcc on >= 9.x [5] - use common IPC code with other BSDs[6] - and *miscellaneous improvements* PR: ports/146231 [1], ports/161421 [2] ports/150631, ports/168369, ports/168637, ports/168793, ports/168978 [3] ports/163454, ports/164905, ports/169231 [4] ports/169389, ports/169479 [5] Obtained from: pkgsrc via bugzilla #753046 [6] In collaboration with: Jan Beich (who did the major part of this work and deserves a special thank you!)
Notes
Notes: svn path=/head/; revision=301582
Diffstat (limited to 'mail/thunderbird-esr/Makefile')
-rw-r--r--mail/thunderbird-esr/Makefile76
1 files changed, 25 insertions, 51 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 8829354123ce..44618e494fc9 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= thunderbird
-DISTVERSION= 10.0.5
+DISTVERSION= 10.0.6
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}esr/source
@@ -15,39 +15,34 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}esr.source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Mozilla Thunderbird is standalone mail and news that stands above
-BUILD_DEPENDS= nspr>=4.8.7:${PORTSDIR}/devel/nspr \
+BUILD_DEPENDS= nspr>=4.8.8:${PORTSDIR}/devel/nspr \
+ nss>=3.13.1:${PORTSDIR}/security/nss \
+ sqlite3>=3.7.7.1:${PORTSDIR}/databases/sqlite3 \
cairo>=1.10.2_1,1:${PORTSDIR}/graphics/cairo \
unzip:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
- event-1.4:${PORTSDIR}/devel/libevent
CONFLICTS_BUILD= spidermonkey-*
-USE_AUTOTOOLS= autoconf213
+USE_AUTOTOOLS= autoconf213:env
LATEST_LINK= thunderbird-esr
USE_GECKO= gecko
CONFLICTS= thunderbird-1[1-9].*
-USE_MOZILLA= -png -nss -dbm -jpeg -xft
-MOZ_TOOLKIT= cairo-gtk2
+USE_MOZILLA= # empty
MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
+USE_QT4= # empty
+QT_NONSTANDARD= yes
ALL_TARGET= default
-CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
-MAKE_ENV= PTHREAD_LDFLAGS="${PTHREAD_LIBS}"
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GL= gl
MOZ_PROTOCOLS= http,ftp,file,viewsource,res,data,wyciwyg,websocket
-MOZ_GRAPHICS= default,-xbm
MOZ_OPTIONS= --program-transform-name='s/thunderbird/${MOZILLA}/' \
- --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
--enable-single-profile --disable-profilesharing \
- --enable-application=mail --enable-official-branding \
- --disable-updater --disable-necko-wifi \
- --with-system-libevent=${LOCALBASE}
+ --enable-application=mail --enable-official-branding
MOZ_MK_OPTIONS= MOZ_MOZ_THUNDERBIRD=1 MAIL_PKG_SHARED=1
MOZ_EXPORT= MOZ_THUNDERBIRD=1 MAIL_PKG_SHARED=1
MOZ_PKGCONFIG_FILES=
@@ -58,45 +53,38 @@ PORTNAME_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/chrome/icons/default/default48.png
SYSTEM_PREFS= ${FAKEDIR}/lib/${PORTNAME}/defaults/pref/${PORTNAME}.js
MOZ_PIS_SCRIPTS=moz_pis_S50cleanhome
-OPTIONS= LIGHTNING "Enable calendar extension" off
+OPTIONS_DEFINE= LIGHTNING
+.include "${.CURDIR}/../../www/firefox/Makefile.options"
.include <bsd.port.pre.mk>
WRKSRC= ${WRKDIR}/comm-esr10
MOZSRC:= ${WRKSRC}/mozilla
-.if ${ARCH} == powerpc64
+.if ${ARCH} == amd64
+CONFIGURE_TARGET=x86_64-portbld-freebsd${OSREL}
+.elif ${ARCH} == powerpc64
.if ${OSVERSION} < 900033
BROKEN= Needs binutils 2.17.50 to build
.else
-CONFIGURE_ENV+= UNAME_m="powerpc64"
+MOZ_EXPORT+= UNAME_m="powerpc64"
CFLAGS+= -mminimal-toc
.endif
.endif
-.if ${HAVE_GNOME:Mlibgnomeui}!=""
-USE_GNOME+= libgnomeui
-MOZ_OPTIONS+= --enable-gnomeui
-.else
-MOZ_OPTIONS+= --disable-gnomeui
-.endif
-
-.if defined(WITHOUT_DBUS)
-MOZ_OPTIONS+= --disable-dbus --disable-libnotify
-.else
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.4:${PORTSDIR}/devel/libnotify
-.endif
-
.if ${ARCH} == amd64 || ${ARCH} == i386
BUILD_DEPENDS+= yasm:${PORTSDIR}/devel/yasm
.endif
-.if defined(WITH_LIGHTNING)
+.if !empty(CXX:M*clang++*)
+CFLAGS+= -Wno-return-type-c-linkage
+.endif
+
+.if ${PORT_OPTIONS:MLIGHTNING}
MOZ_OPTIONS+= --enable-calendar
MOZ_MK_OPTIONS+= MOZ_CO_PROJECT=calendar
LIGHTNING_DIR= share/lightning
-XPI_FILE= ${MOZSRC}/dist/xpi-stage/lightning.xpi
+XPI_FILE= ${MOZ_OBJDIR}/mozilla/dist/xpi-stage/lightning.xpi
XPI_LIBDIR= ${PREFIX}/lib/xpi
XPI_ORIG_ID= {e2fda1a4-762b-4020-b5ad-a41df1933103}
XPI_ID= lightning@thunderbird.mozilla.org
@@ -109,22 +97,8 @@ post-extract:
<${FILESDIR}/thunderbird.desktop.in >${WRKDIR}/${MOZILLA_EXEC_NAME}.desktop
post-patch:
- @${GREP} -Flr \"/proc ${MOZSRC}/ipc/chromium/src/base | ${XARGS} ${REINPLACE_CMD} \
- -e 's|/proc/self/fd|/dev/fd|' \
- -e 's|/proc["/]|/compat/linux&|'
- @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
- ${MOZSRC}/storage/build/Makefile.in \
- ${MOZSRC}/toolkit/library/Makefile.in \
- ${MOZSRC}/db/sqlite3/src/Makefile.in
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${MOZSRC}/security/manager/ssl/src/Makefile.in \
- ${MOZSRC}/js/src/config/mkdepend/Makefile.in \
- ${MOZSRC}/js/src/config/config.mk
- @${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g ; \
- s|echo aout|echo elf|g ; \
- s|/usr/X11R6|${LOCALBASE}|g' \
- ${MOZSRC}/js/src/configure
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/mail/app/nsMailApp.cpp
pre-configure:
(cd ${WRKSRC} && ${AUTOCONF})
@@ -143,7 +117,7 @@ post-install:
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKDIR}/${MOZILLA_EXEC_NAME}.desktop ${PREFIX}/share/applications
${LN} -sf ${PORTNAME_ICON_SRC} ${PREFIX}/share/pixmaps/${PORTNAME_ICON}
-.if defined(WITH_LIGHTNING)
+.if ${PORT_OPTIONS:MLIGHTNING}
@${MKDIR} ${XPI_LIBDIR}/${XPI_ID} ${XPI_LIBDIR}/symlinks/thunderbird
@(cd ${XPI_LIBDIR}/${XPI_ID}; ${TAR} -xf ${XPI_FILE})
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${XPI_LIBDIR}/${XPI_ID}