aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-18 23:52:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-18 23:52:13 +0000
commitd652322c83f4bb93469ab3822c0e59ba68b52d13 (patch)
treea9f754f7e98d95a6a0cf44b543d1ea51aced3a45 /mail/thunderbird
parente6b0ae894fd4fb3f42e5459c3e498a44ce271248 (diff)
Notes
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile3
-rw-r--r--mail/thunderbird/distinfo6
-rw-r--r--mail/thunderbird/files/patch-bug144071740
3 files changed, 4 insertions, 45 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index e13cef0443b9..d306ab7fffe7 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= thunderbird
-DISTVERSION= 52.7.0
-PORTREVISION= 3
+DISTVERSION= 52.8.0
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index 35bccce62e9b..d232b92ce433 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1521833256
-SHA256 (thunderbird-52.7.0.source.tar.xz) = 82462890d393ed78c03226924a6166596b7b6d1562b5071e713a7558cd292ea3
-SIZE (thunderbird-52.7.0.source.tar.xz) = 230410444
+TIMESTAMP = 1526507977
+SHA256 (thunderbird-52.8.0.source.tar.xz) = 35b9a687997d92f36107090c1217941e5d637760b0efa7d13819cde36894eb59
+SIZE (thunderbird-52.8.0.source.tar.xz) = 230380780
diff --git a/mail/thunderbird/files/patch-bug1440717 b/mail/thunderbird/files/patch-bug1440717
deleted file mode 100644
index 0bc2424c394a..000000000000
--- a/mail/thunderbird/files/patch-bug1440717
+++ /dev/null
@@ -1,40 +0,0 @@
-commit ae9da5994b51
-Author: Nicolas Silva <nsilva@mozilla.com>
-Date: Mon Mar 12 13:36:00 2018 +0100
-
- Bug 1440717 - Use RefPtr for CompositingRenderTargetOGL::mGL. r=Bas, a=ritu
-
- --HG--
- extra : source : b6d2d55223d2aa5cb85bbdf33075d1d38f2a9a30
- extra : intermediate-source : 0ec90964e0bc479412a4da8a61d48b665211736e
----
- gfx/layers/opengl/CompositingRenderTargetOGL.cpp | 2 +-
- gfx/layers/opengl/CompositingRenderTargetOGL.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
-index c05b8edfd346..a1521c56da87 100644
---- mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
-+++ mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
-@@ -60,7 +60,7 @@ CompositingRenderTargetOGL::BindRenderTarget()
- msg.AppendPrintf("Framebuffer not complete -- CheckFramebufferStatus returned 0x%x, "
- "GLContext=%p, IsOffscreen()=%d, mFBO=%d, aFBOTextureTarget=0x%x, "
- "aRect.width=%d, aRect.height=%d",
-- result, mGL, mGL->IsOffscreen(), mFBO, mInitParams.mFBOTextureTarget,
-+ result, mGL.get(), mGL->IsOffscreen(), mFBO, mInitParams.mFBOTextureTarget,
- mInitParams.mSize.width, mInitParams.mSize.height);
- NS_WARNING(msg.get());
- }
-diff --git mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
-index 501701d6f1a3..071dc5cac1c2 100644
---- mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
-+++ mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
-@@ -184,7 +184,7 @@ private:
- * the target is always cleared at the end of a frame.
- */
- RefPtr<CompositorOGL> mCompositor;
-- GLContext* mGL;
-+ RefPtr<GLContext> mGL;
- GLuint mTextureHandle;
- GLuint mFBO;
- };