aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-06-13 19:55:24 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-06-13 19:55:24 +0000
commitd7a356db13b9efca7aa45371d5f4c2c39bfa2dbf (patch)
treef8342fa27f4a8858fb8d2d8ea7e4d5bc7213d341 /mail/thunderbird
parenta38b8c46780c36f033e470ffc283c27c7125e2eb (diff)
Notes
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile5
-rw-r--r--mail/thunderbird/distinfo6
-rw-r--r--mail/thunderbird/files/patch-bug135905131
-rw-r--r--mail/thunderbird/files/patch-bug135914257
4 files changed, 5 insertions, 94 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index e0e0fbbd04da..b6c82c9db4f1 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= thunderbird
-DISTVERSION= 52.1.1
-PORTREVISION= 1
+DISTVERSION= 52.2.0
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build4/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
DISTFILES= ${PORTNAME}-${DISTVERSION}.source${EXTRACT_SUFX}
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}.source${EXTRACT_SUFX}
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index d39abb0cd97c..c3e32c7ed9e0 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495277987
-SHA256 (thunderbird-52.1.1.source.tar.xz) = 88211d0d57dfdae9232617244f9c5406520a538e9e7be6ceec79fdfed175ba84
-SIZE (thunderbird-52.1.1.source.tar.xz) = 228534928
+TIMESTAMP = 1497298367
+SHA256 (thunderbird-52.2.0.source.tar.xz) = c65c66244ac113996002bcfa9e387f14291163cfb7009a9126e3a8d4a970e72d
+SIZE (thunderbird-52.2.0.source.tar.xz) = 228453944
diff --git a/mail/thunderbird/files/patch-bug1359051 b/mail/thunderbird/files/patch-bug1359051
deleted file mode 100644
index b3dcbb415540..000000000000
--- a/mail/thunderbird/files/patch-bug1359051
+++ /dev/null
@@ -1,31 +0,0 @@
-commit fe7592e16fcc
-Author: Sean Stangl <sstangl@mozilla.com>
-Date: Mon Apr 24 07:10:58 2017 -0700
-
- Bug 1359051 - Define cacheFlush for non-Simulator ARM64 builds. r=tcampbell
----
- js/src/jit/ExecutableAllocator.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git js/src/jit/ExecutableAllocator.h js/src/jit/ExecutableAllocator.h
-index 3a42918142ef..570a25ff0dc3 100644
---- mozilla/js/src/jit/ExecutableAllocator.h
-+++ mozilla/js/src/jit/ExecutableAllocator.h
-@@ -259,7 +259,7 @@ class ExecutableAllocator
- {
- __clear_cache(code, reinterpret_cast<char*>(code) + size);
- }
--#elif defined(JS_CODEGEN_ARM) && defined(XP_IOS)
-+#elif (defined(JS_CODEGEN_ARM) || defined(JS_CODEGEN_ARM64)) && defined(XP_IOS)
- static void cacheFlush(void* code, size_t size)
- {
- sys_icache_invalidate(code, size);
-@@ -297,7 +297,7 @@ class ExecutableAllocator
- : "r0", "r1", "r2");
- }
- }
--#elif defined(JS_CODEGEN_ARM64) && (defined(__linux__) || defined(ANDROID)) && defined(__GNUC__)
-+#elif defined(JS_CODEGEN_ARM64)
- static void cacheFlush(void* code, size_t size)
- {
- __clear_cache(code, (void *)((size_t)code + size));
diff --git a/mail/thunderbird/files/patch-bug1359142 b/mail/thunderbird/files/patch-bug1359142
deleted file mode 100644
index d6f5563da5bf..000000000000
--- a/mail/thunderbird/files/patch-bug1359142
+++ /dev/null
@@ -1,57 +0,0 @@
-Define EPC_sig and RFP_sig for JS_CODEGEN_(ARM64|MIPS) on BSDs
-
-diff --git js/src/wasm/WasmSignalHandlers.cpp js/src/wasm/WasmSignalHandlers.cpp
-index 1ab76eeb4bd9..bcdff0487837 100644
---- mozilla/js/src/wasm/WasmSignalHandlers.cpp
-+++ mozilla/js/src/wasm/WasmSignalHandlers.cpp
-@@ -108,7 +108,19 @@ class AutoSetHandlingSegFault
- # define R12_sig(p) ((p)->sc_r12)
- # define R13_sig(p) ((p)->sc_r13)
- # define R14_sig(p) ((p)->sc_r14)
--# define R15_sig(p) ((p)->sc_r15)
-+# if defined(__arm__)
-+# define R15_sig(p) ((p)->sc_pc)
-+# else
-+# define R15_sig(p) ((p)->sc_r15)
-+# endif
-+# if defined(__aarch64__)
-+# define EPC_sig(p) ((p)->sc_elr)
-+# define RFP_sig(p) ((p)->sc_x[29])
-+# endif
-+# if defined(__mips__)
-+# define EPC_sig(p) ((p)->sc_pc)
-+# define RFP_sig(p) ((p)->sc_regs[30])
-+# endif
- #elif defined(__linux__) || defined(SOLARIS)
- # if defined(__linux__)
- # define XMM_sig(p,i) ((p)->uc_mcontext.fpregs->_xmm[i])
-@@ -171,6 +183,14 @@ class AutoSetHandlingSegFault
- # define R13_sig(p) ((p)->uc_mcontext.__gregs[_REG_R13])
- # define R14_sig(p) ((p)->uc_mcontext.__gregs[_REG_R14])
- # define R15_sig(p) ((p)->uc_mcontext.__gregs[_REG_R15])
-+# if defined(__aarch64__)
-+# define EPC_sig(p) ((p)->uc_mcontext.__gregs[_REG_PC])
-+# define RFP_sig(p) ((p)->uc_mcontext.__gregs[_REG_X29])
-+# endif
-+# if defined(__mips__)
-+# define EPC_sig(p) ((p)->uc_mcontext.__gregs[_REG_EPC])
-+# define RFP_sig(p) ((p)->uc_mcontext.__gregs[_REG_S8])
-+# endif
- #elif defined(__DragonFly__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
- # if defined(__DragonFly__)
- # define XMM_sig(p,i) (((union savefpu*)(p)->uc_mcontext.mc_fpregs)->sv_xmm.sv_xmm[i])
-@@ -200,6 +220,14 @@ class AutoSetHandlingSegFault
- # else
- # define R15_sig(p) ((p)->uc_mcontext.mc_r15)
- # endif
-+# if defined(__FreeBSD__) && defined(__aarch64__)
-+# define EPC_sig(p) ((p)->uc_mcontext.mc_gpregs.gp_elr)
-+# define RFP_sig(p) ((p)->uc_mcontext.mc_gpregs.gp_x[29])
-+# endif
-+# if defined(__FreeBSD__) && defined(__mips__)
-+# define EPC_sig(p) ((p)->uc_mcontext.mc_pc)
-+# define RFP_sig(p) ((p)->uc_mcontext.mc_regs[30])
-+# endif
- #elif defined(XP_DARWIN)
- # define EIP_sig(p) ((p)->uc_mcontext->__ss.__eip)
- # define EBP_sig(p) ((p)->uc_mcontext->__ss.__ebp)