aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2017-05-01 20:13:35 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2017-05-01 20:13:35 +0000
commitcde338157e92ead6aa07e57bf6616378924a87af (patch)
tree6e7df7c5cbd9277c690df2cb69933cb3d43fd52f /mail/thunderbird
parent77ca3effa0a6a9a8101bf70c7fa3a84b692aa6b6 (diff)
downloadports-cde338157e92ead6aa07e57bf6616378924a87af.tar.gz
ports-cde338157e92ead6aa07e57bf6616378924a87af.zip
Notes
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile3
-rw-r--r--mail/thunderbird/distinfo6
-rw-r--r--mail/thunderbird/files/patch-bug132266080
3 files changed, 4 insertions, 85 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index f574fba15f4c..52acedb7333b 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= thunderbird
-DISTVERSION= 52.0.1
-PORTREVISION= 1
+DISTVERSION= 52.1.0
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build4/source
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index f936b11dae74..49b67357378a 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1492181434
-SHA256 (thunderbird-52.0.1.source.tar.xz) = a1cede97e836c728d3157b9e043f3724f7aff83f92ba1f3796e9cc7299402cab
-SIZE (thunderbird-52.0.1.source.tar.xz) = 228422924
+TIMESTAMP = 1493583865
+SHA256 (thunderbird-52.1.0.source.tar.xz) = c33ca35b6acd1a0dc0d0f4b1df16745a33144c5d3d3715fe05454a5e9eefd48b
+SIZE (thunderbird-52.1.0.source.tar.xz) = 228493044
diff --git a/mail/thunderbird/files/patch-bug1322660 b/mail/thunderbird/files/patch-bug1322660
deleted file mode 100644
index 9944ae4109ce..000000000000
--- a/mail/thunderbird/files/patch-bug1322660
+++ /dev/null
@@ -1,80 +0,0 @@
---- mozilla/modules/woff2/src/store_bytes.h
-+++ mozilla/modules/woff2/src/store_bytes.h
-@@ -29,41 +29,44 @@ inline size_t StoreU32(uint8_t* dst, size_t offset, uint32_t x) {
- dst[offset + 1] = x >> 16;
- dst[offset + 2] = x >> 8;
- dst[offset + 3] = x;
- return offset + 4;
- }
-
- inline size_t Store16(uint8_t* dst, size_t offset, int x) {
- #if (defined(__BYTE_ORDER__) && (__BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__))
-- *reinterpret_cast<uint16_t*>(dst + offset) =
-- ((x & 0xFF) << 8) | ((x & 0xFF00) >> 8);
-+ uint16_t v = ((x & 0xFF) << 8) | ((x & 0xFF00) >> 8);
-+ memcpy(dst + offset, &v, 2);
- #elif (defined(__BYTE_ORDER__) && (__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__))
-- *reinterpret_cast<uint16_t*>(dst + offset) = static_cast<uint16_t>(x);
-+ uint16_t v = static_cast<uint16_t>(x);
-+ memcpy(dst + offset, &v, 2);
- #else
- dst[offset] = x >> 8;
- dst[offset + 1] = x;
- #endif
- return offset + 2;
- }
-
- inline void StoreU32(uint32_t val, size_t* offset, uint8_t* dst) {
- dst[(*offset)++] = val >> 24;
- dst[(*offset)++] = val >> 16;
- dst[(*offset)++] = val >> 8;
- dst[(*offset)++] = val;
- }
-
- inline void Store16(int val, size_t* offset, uint8_t* dst) {
- #if (defined(__BYTE_ORDER__) && (__BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__))
-- *reinterpret_cast<uint16_t*>(dst + *offset) =
-+ uint16_t v = ((val & 0xFF) << 8) | ((val & 0xFF00) >> 8);
-+ memcpy(dst + *offset, &v, 2);
- ((val & 0xFF) << 8) | ((val & 0xFF00) >> 8);
- *offset += 2;
- #elif (defined(__BYTE_ORDER__) && (__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__))
-- *reinterpret_cast<uint16_t*>(dst + *offset) = static_cast<uint16_t>(val);
-+ uint16_t v = static_cast<uint16_t>(val);
-+ memcpy(dst + *offset, &v, 2);
- *offset += 2;
- #else
- dst[(*offset)++] = val >> 8;
- dst[(*offset)++] = val;
- #endif
- }
-
- inline void StoreBytes(const uint8_t* data, size_t len,
---- mozilla/modules/woff2/src/woff2_common.cc
-+++ mozilla/modules/woff2/src/woff2_common.cc
-@@ -20,22 +20,23 @@
-
- namespace woff2 {
-
-
- uint32_t ComputeULongSum(const uint8_t* buf, size_t size) {
- uint32_t checksum = 0;
- size_t aligned_size = size & ~3;
- for (size_t i = 0; i < aligned_size; i += 4) {
-+ uint32_t v;
-+ memcpy(&v, buf + i, 4);
- #if (defined(__BYTE_ORDER__) && (__BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__))
-- uint32_t v = *reinterpret_cast<const uint32_t*>(buf + i);
- checksum += (((v & 0xFF) << 24) | ((v & 0xFF00) << 8) |
- ((v & 0xFF0000) >> 8) | ((v & 0xFF000000) >> 24));
- #elif (defined(__BYTE_ORDER__) && (__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__))
-- checksum += *reinterpret_cast<const uint32_t*>(buf + i);
-+ checksum += v;
- #else
- checksum += (buf[i] << 24) | (buf[i + 1] << 16) |
- (buf[i + 2] << 8) | buf[i + 3];
- #endif
- }
-
- // treat size not aligned on 4 as if it were padded to 4 with 0's
- if (size != aligned_size) {