aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-10-29 13:54:54 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-10-29 13:54:54 +0000
commit4953b13eac463d0ccaed68c84ce992cc4b4fc863 (patch)
treee4f49966ea534b8e09c9a78c60dafc399f322cea /mail/thunderbird
parent962f8427b637bd4d5f33dd51463a9011250e8f67 (diff)
downloadports-4953b13eac463d0ccaed68c84ce992cc4b4fc863.tar.gz
ports-4953b13eac463d0ccaed68c84ce992cc4b4fc863.zip
Notes
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile7
-rw-r--r--mail/thunderbird/distinfo4
-rw-r--r--mail/thunderbird/files/patch-bug799441116
-rw-r--r--mail/thunderbird/files/patch-z-bug76244570
4 files changed, 189 insertions, 8 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 18fb82ae6651..3493b540ef27 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= thunderbird
-DISTVERSION= 16.0.1
-PORTREVISION= 1
+DISTVERSION= 16.0.2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
@@ -78,10 +77,6 @@ CFLAGS+= -mminimal-toc
.endif
.endif
-.if ${ARCH} == amd64 || ${ARCH} == i386
-BUILD_DEPENDS+= yasm:${PORTSDIR}/devel/yasm
-.endif
-
.if ${PORT_OPTIONS:MENIGMAIL}
MASTER_SITES+= http://www.enigmail.net/download/source/:enigmail
DISTFILES+= ${EM_DISTFILE}:enigmail
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index 0e80f6947aff..de5ac59baf8e 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,4 +1,4 @@
-SHA256 (thunderbird-16.0.1.source.tar.bz2) = 2b2ca8c78a2f4e40f93d2f50d9cd7d5b0283245d97d2477510e638d2cde279cb
-SIZE (thunderbird-16.0.1.source.tar.bz2) = 111401489
+SHA256 (thunderbird-16.0.2.source.tar.bz2) = 32d27524faf3409e26bafd32ed0523d5ef93c4fd7b3ed3c4705584a30accd329
+SIZE (thunderbird-16.0.2.source.tar.bz2) = 111401765
SHA256 (enigmail-1.4.5.tar.gz) = fa59491fba21de9414a003933349074a8ec1833a1d64cac9f0a9f7020ed6c020
SIZE (enigmail-1.4.5.tar.gz) = 1269207
diff --git a/mail/thunderbird/files/patch-bug799441 b/mail/thunderbird/files/patch-bug799441
new file mode 100644
index 000000000000..acfe8d9302c6
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug799441
@@ -0,0 +1,116 @@
+commit b9accdd
+Author: Mike Hommey <mh+mozilla@glandium.org>
+Date: Thu Oct 18 14:47:10 2012 +0200
+
+ Bug 799441 - Build GIO module in libxul. r=ted
+---
+ configure.in | 6 ++++++
+ extensions/gio/Makefile.in | 14 +++-----------
+ toolkit/library/Makefile.in | 5 +++++
+ toolkit/library/nsStaticXULComponents.cpp | 7 +++++++
+ toolkit/toolkit-tiers.mk | 4 ++++
+ 5 files changed, 25 insertions(+), 11 deletions(-)
+
+diff --git configure.in configure.in
+index a9fb5f1..37e6db8 100644
+--- mozilla/configure.in
++++ mozilla/configure.in
+@@ -6086,6 +6086,12 @@ if test -n "$LIBXUL_SDK_DIR" -a `echo "$MOZ_EXTENSIONS" | grep -c gio` -ne 0; th
+ MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|gio||'`
+ fi
+
++if test `echo "$MOZ_EXTENSIONS" | grep -c gio` -ne 0; then
++ MOZ_GIO_COMPONENT=1
++ MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|gio||'`
++fi
++AC_SUBST(MOZ_GIO_COMPONENT)
++
+ if test -z "$MOZ_JSDEBUGGER" -a `echo "$MOZ_EXTENSIONS" | grep -c venkman` -ne 0; then
+ AC_MSG_WARN([Cannot build venkman without JavaScript debug library. Removing venkman from MOZ_EXTENSIONS.])
+ MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|venkman||'`
+diff --git extensions/gio/Makefile.in extensions/gio/Makefile.in
+index ccf2846..79112a8 100644
+--- mozilla/extensions/gio/Makefile.in
++++ mozilla/extensions/gio/Makefile.in
+@@ -14,6 +14,9 @@ MODULE = nkgio
+ LIBRARY_NAME = nkgio
+ SHORT_LIBNAME = nkgio
+ IS_COMPONENT = 1
++EXPORT_LIBRARY = 1
++MODULE_NAME = nsGIOModule
++LIBXUL_LIBRARY = 1
+
+ CPPSRCS = \
+ nsGIOProtocolHandler.cpp \
+@@ -21,15 +24,4 @@ CPPSRCS = \
+
+ LOCAL_INCLUDES = $(MOZ_GIO_CFLAGS)
+
+-EXTRA_DSO_LDOPTS = \
+- $(XPCOM_GLUE_LDOPTS) \
+- $(NSPR_LIBS) \
+- $(MOZ_GIO_LIBS) \
+- $(NULL)
+-
+-# make sure this component is never statically linked into the main
+-# application. this is necessary since we don't want to force users
+-# to install gio in order to use the rest of mozilla ;-)
+-FORCE_SHARED_LIB= 1
+-
+ include $(topsrcdir)/config/rules.mk
+diff --git toolkit/library/Makefile.in toolkit/library/Makefile.in
+index 7f9046e..6499758 100644
+--- mozilla/toolkit/library/Makefile.in
++++ mozilla/toolkit/library/Makefile.in
+@@ -333,6 +333,11 @@ COMPONENT_LIBS += gkdebug
+ endif
+ endif
+
++ifdef MOZ_GIO_COMPONENT
++DEFINES += -DMOZ_GIO_COMPONENT
++COMPONENT_LIBS += nkgio
++endif
++
+ ifdef MOZ_APP_COMPONENT_LIBS
+ COMPONENT_LIBS += $(MOZ_APP_COMPONENT_LIBS)
+ endif
+diff --git toolkit/library/nsStaticXULComponents.cpp toolkit/library/nsStaticXULComponents.cpp
+index e1d90f2..85b21a2 100644
+--- mozilla/toolkit/library/nsStaticXULComponents.cpp
++++ mozilla/toolkit/library/nsStaticXULComponents.cpp
+@@ -164,6 +164,12 @@
+ #define PROFILER_MODULE
+ #endif
+
++#if defined(MOZ_GIO_COMPONENT)
++#define GIO_MODULE MODULE(nsGIOModule)
++#else
++#define GIO_MODULE
++#endif
++
+ #define XUL_MODULES \
+ MODULE(nsUConvModule) \
+ MODULE(nsI18nModule) \
+@@ -220,6 +226,7 @@
+ MODULE(nsTelemetryModule) \
+ MODULE(jsinspector) \
+ MODULE(jsdebugger) \
++ GIO_MODULE \
+ /* end of list */
+
+ #define MODULE(_name) \
+diff --git toolkit/toolkit-tiers.mk toolkit/toolkit-tiers.mk
+index e87d7af..4b16d23 100644
+--- mozilla/toolkit/toolkit-tiers.mk
++++ mozilla/toolkit/toolkit-tiers.mk
+@@ -252,6 +252,10 @@ tier_platform_dirs += js/ductwork/debugger
+
+ tier_platform_dirs += other-licenses/snappy
+
++ifdef MOZ_GIO_COMPONENT
++tier_platform_dirs += extensions/gio
++endif
++
+ ifdef APP_LIBXUL_STATICDIRS
+ # Applications can cheat and ask for code to be
+ # built before libxul so libxul can be linked against it.
diff --git a/mail/thunderbird/files/patch-z-bug762445 b/mail/thunderbird/files/patch-z-bug762445
new file mode 100644
index 000000000000..648492dfa700
--- /dev/null
+++ b/mail/thunderbird/files/patch-z-bug762445
@@ -0,0 +1,70 @@
+commit b44dc8e
+Author: Jan Beich <jbeich@tormail.org>
+Date: Fri Oct 12 18:49:59 2012 +0000
+
+ Bug 762445 - Add jemalloc3 glue for heap-committed, heap-dirty in about:memory.
+---
+ memory/build/mozjemalloc_compat.c | 34 ++++++++++++++++++++++++++++------
+ 1 file changed, 28 insertions(+), 6 deletions(-)
+
+diff --git memory/build/mozjemalloc_compat.c memory/build/mozjemalloc_compat.c
+index 94ad96e..7adfef5 100644
+--- mozilla/memory/build/mozjemalloc_compat.c
++++ mozilla/memory/build/mozjemalloc_compat.c
+@@ -11,15 +11,50 @@
+ #define wrap(a) je_ ## a
+ #endif
+
+-extern MOZ_IMPORT_API(int)
++/*
++ * CTL_* macros are from memory/jemalloc/src/src/stats.c with changes:
++ * - drop `t' argument to avoid redundancy in calculating type size
++ * - require `i' argument for arena number explicitly
++ */
++
++#define CTL_GET(n, v) do { \
++ size_t sz = sizeof(v); \
++ wrap(mallctl)(n, &v, &sz, NULL, 0); \
++} while (0)
++
++#define CTL_I_GET(n, v, i) do { \
++ size_t mib[6]; \
++ size_t miblen = sizeof(mib) / sizeof(mib[0]); \
++ size_t sz = sizeof(v); \
++ wrap(mallctlnametomib)(n, mib, &miblen); \
++ mib[2] = i; \
++ wrap(mallctlbymib)(mib, miblen, &v, &sz, NULL, 0); \
++} while (0)
++
++MOZ_IMPORT_API(int)
+ wrap(mallctl)(const char*, void*, size_t*, void*, size_t);
++MOZ_IMPORT_API(int)
++wrap(mallctlnametomib)(const char *name, size_t *mibp, size_t *miblenp);
++MOZ_IMPORT_API(int)
++wrap(mallctlbymib)(const size_t *mib, size_t miblen, void *oldp, size_t *oldlenp, void *newp, size_t newlen);
+
+ MOZ_EXPORT_API(void)
+ jemalloc_stats(jemalloc_stats_t *stats)
+ {
+- size_t size = sizeof(stats->mapped);
+- wrap(mallctl)("stats.mapped", &stats->mapped, &size, NULL, 0);
+- wrap(mallctl)("stats.allocated", &stats->allocated, &size, NULL, 0);
+- stats->committed = -1;
+- stats->dirty = -1;
++ unsigned narenas;
++ size_t active, allocated, mapped, page, pdirty;
++
++ CTL_GET("arenas.narenas", narenas);
++ CTL_GET("arenas.page", page);
++ CTL_GET("stats.active", active);
++ CTL_GET("stats.allocated", allocated);
++ CTL_GET("stats.mapped", mapped);
++
++ /* get the summation for all arenas, i == narenas */
++ CTL_I_GET("stats.arenas.0.pdirty", pdirty, narenas);
++
++ stats->allocated = allocated;
++ stats->mapped = mapped;
++ stats->dirty = pdirty * page;
++ stats->committed = active + stats->dirty;
+ }