aboutsummaryrefslogtreecommitdiff
path: root/mail/tpop3d/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-12 15:02:53 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-12 15:02:53 +0000
commit52ff2674db4e42cba8dcbc47cb1328d503d3632c (patch)
treec65b2f3adf0dd420bd40b6e55ea1d267f742623e /mail/tpop3d/Makefile
parentd60890de971e7927bc4a52e64cf79a242dc3d6f8 (diff)
downloadports-52ff2674db4e42cba8dcbc47cb1328d503d3632c.tar.gz
ports-52ff2674db4e42cba8dcbc47cb1328d503d3632c.zip
Notes
Diffstat (limited to 'mail/tpop3d/Makefile')
-rw-r--r--mail/tpop3d/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index 7bb18235e4ba..1924d4132511 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -33,8 +33,8 @@ OPTIONS= MYSQL "Use MySQL authentication" off \
.include <bsd.port.pre.mk>
# MySQL authentication
-.if defined(WITH_MYSQL) && !defined(WITHOUT_MYSQL)
-.if defined(WITH_PGSQL) && !defined(WITHOUT_PGSQL)
+.if defined(WITH_MYSQL)
+.if defined(WITH_PGSQL)
BROKEN= MySQL and PgSQL authentication can not be build together
.endif
USE_MYSQL= yes
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+= --enable-auth-mysql \
--with-mysql-include-dir=${LOCALBASE}/include/mysql
.endif
-.if defined(WITH_PGSQL) && !defined(WITHOUT_PGSQL)
+.if defined(WITH_PGSQL)
USE_PGSQL= yes
DEFAULT_PGSQL_VER= 80
CONFIGURE_ARGS+= --enable-auth-pgsql \
@@ -51,26 +51,26 @@ CONFIGURE_ARGS+= --enable-auth-pgsql \
--with-pgsql-include-dir=${LOCALBASE}/include
.endif
-.if defined(WITH_LDAP) && !defined(WITHOUT_LDAP)
+.if defined(WITH_LDAP)
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --enable-auth-ldap --with-openldap-root=${LOCALBASE}
.endif
# Perl authentication
-.if defined(WITH_PERLAUTH) && !defined(WITHOUT_PERLAUTH)
+.if defined(WITH_PERLAUTH)
USE_PERL5= yes
CONFIGURE_ARGS+= --enable-auth-perl
.endif
-.if defined(WITH_FLATAUTH) && !defined(WITHOUT_FLATAUTH)
+.if defined(WITH_FLATAUTH)
CONFIGURE_ARGS+= --enable-auth-flatfile
.endif
-.if defined(WITH_MAILDIR) && !defined(WITHOUT_MAILDIR)
+.if !defined(WITHOUT_MAILDIR)
CONFIGURE_ARGS+= --enable-mbox-maildir
.endif
-.if defined(WITH_DRAC) && !defined(WITHOUT_DRAC)
+.if defined(WITH_DRAC)
CONFIGURE_ARGS+= --enable-drac
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
LDFLAGS+= -L${LOCALBASE}/lib