aboutsummaryrefslogtreecommitdiff
path: root/mail/tpop3d/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-04 13:16:47 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-04 13:16:47 +0000
commit2c96136918b6730a4728008f579efbaad02ec8cd (patch)
treed166f80aaf837f06c88918cbb40548d38bd16d75 /mail/tpop3d/Makefile
parent9700d47dfa94e00de0868c512ea7867da871cd4f (diff)
downloadports-2c96136918b6730a4728008f579efbaad02ec8cd.tar.gz
ports-2c96136918b6730a4728008f579efbaad02ec8cd.zip
Notes
Diffstat (limited to 'mail/tpop3d/Makefile')
-rw-r--r--mail/tpop3d/Makefile38
1 files changed, 20 insertions, 18 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index fedb0cdc9c4f..5794de753e03 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -6,16 +6,22 @@
#
PORTNAME= tpop3d
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
CATEGORIES= mail
MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
MAINTAINER= chris@shagged.org
COMMENT= Virtual-domain capable POP3 server supporting MySQL auth
-USE_REINPLACE= yes
+USE_OPENSSL= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-auth-other \
+ --enable-tcp-wrappers \
+ --with-mailspool-directory=/var/mail
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-# mysql authentication
+# MySQL authentication
.if !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --enable-auth-mysql \
@@ -24,25 +30,16 @@ CONFIGURE_ARGS+= --enable-auth-mysql \
.endif
.if defined(WITH_LDAP)
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
-.endif
-
-# perl authentication
-.if defined(WITH_PERLAUTH)
-USE_PERL5= yes
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
+CONFIGURE_ARGS+= --enable-auth-ldap --with-openldap-root=${LOCALBASE}
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-auth-other \
- --enable-tcp-wrappers \
- --with-mailspool-directory=/var/mail
-
+# Perl authentication
.if defined(WITH_PERLAUTH)
+USE_PERL5= yes
CONFIGURE_ARGS+= --enable-auth-perl
.endif
-.if defined(WITH_LDAP)
-CONFIGURE_ARGS+= --enable-auth-ldap --with-openldap-root=${LOCALBASE}
-.endif
+
.if !defined(WITHOUT_MAILDIR)
CONFIGURE_ARGS+= --enable-mbox-maildir
.endif
@@ -50,10 +47,11 @@ CONFIGURE_ARGS+= --enable-mbox-maildir
SAMPLE_RCD= tpop3d.sh.sample
STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${SAMPLE_RCD}
DEFAULT_CONFIG= ${PREFIX}/etc/tpop3d.conf.dist
-USE_OPENSSL= yes
MAN5= tpop3d.conf.5
MAN8= tpop3d.8
+DOCS= CHANGES CREDITS FAQ HACKING INSTALL PORTABILITY \
+ README README.POP-before-SMTP README.auth_mysql TODO
post-patch:
@${REINPLACE_CMD} 's,^CFLAGS =, CFLAGS = \@CFLAGS\@,' \
@@ -71,5 +69,9 @@ post-install:
${INSTALL_SCRIPT} ${FILESDIR}/tpop3d.conf.dist \
${PREFIX}/etc/tpop3d.conf ; \
fi
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
.include <bsd.port.mk>