aboutsummaryrefslogtreecommitdiff
path: root/mail/tpop3d/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-03 01:24:54 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-03 01:24:54 +0000
commit6a500058e9c62347b8290fe62f2d33394fe6d36f (patch)
tree861fc0a349644297aa5841a9714dd0e8c0f53115 /mail/tpop3d/Makefile
parent1c12fa0d50b86bca3a5dd8a1e355b731361ec152 (diff)
downloadports-6a500058e9c62347b8290fe62f2d33394fe6d36f.tar.gz
ports-6a500058e9c62347b8290fe62f2d33394fe6d36f.zip
Notes
Diffstat (limited to 'mail/tpop3d/Makefile')
-rw-r--r--mail/tpop3d/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index c5be070aa588..74b4e632a82f 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= tpop3d
-PORTVERSION= 1.5.3
-PORTREVISION= 6
+PORTVERSION= 1.5.4
CATEGORIES= mail
-MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= tpop3d
MAINTAINER= boris@tagnet.ru
COMMENT= Virtual-domain capable POP3 server supporting MySQL, PgSQL etc auth
@@ -28,6 +28,7 @@ OPTIONS= MYSQL "Use MySQL authentication" off \
PERLAUTH "Use Perl authentication" off \
PASSWDAUTH "Use /etc/passwd authentication" off \
FLATAUTH "Use /etc/passwd-style flat file authentication" off \
+ GDBMAUTH "Use authentication against GNU dbm files" off \
MAILDIR "Compile Maildir support" on \
MBOXINDICES "Save Mbox indices" off \
DRAC "Enable DRAC RFC for POP-before-SMTP relaying" off \
@@ -69,6 +70,11 @@ CONFIGURE_ARGS+= --enable-auth-perl
CONFIGURE_ARGS+= --enable-auth-flatfile
.endif
+.if defined(WITH_GDBMAUTH)
+LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm
+CONFIGURE_ARGS+= --enable-auth-gdbm
+.endif
+
.if defined(WITH_PASSWDAUTH)
CONFIGURE_ARGS+= --enable-auth-passwd
.endif