aboutsummaryrefslogtreecommitdiff
path: root/mail/tpop3d/Makefile
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2006-12-05 18:40:12 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2006-12-05 18:40:12 +0000
commitdf3589e28c809a071c408286a759962250e774df (patch)
tree7fa08bee80b9e2f88bf85d0fe887f9de20b755b1 /mail/tpop3d/Makefile
parentcfd7ec46dc55c6a384340328af903c15d0b290a3 (diff)
Notes
Diffstat (limited to 'mail/tpop3d/Makefile')
-rw-r--r--mail/tpop3d/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index 1924d4132511..79f2ae344cbb 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -28,7 +28,8 @@ OPTIONS= MYSQL "Use MySQL authentication" off \
PERLAUTH "Use Perl authentication" off \
FLATAUTH "Enable /etc/passwd-style authentication" off \
MAILDIR "Compile Maildir support" on \
- DRAC "Enable DRAC RFC for POP-before-SMTP relaying" off
+ DRAC "Enable DRAC RFC for POP-before-SMTP relaying" off \
+ FIX_PERLAUTH "Only try it if perl-auth coredumps" off
.include <bsd.port.pre.mk>
@@ -76,6 +77,10 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
LDFLAGS+= -L${LOCALBASE}/lib
.endif
+.if defined(WITH_FIX_PERLAUTH)
+EXTRA_PATCHES+=${PATCHDIR}/extra-patch-auth_perl.c
+.endif
+
USE_RC_SUBR= tpop3d.sh
DEFAULT_CONFIG= ${PREFIX}/etc/tpop3d.conf.dist