aboutsummaryrefslogtreecommitdiff
path: root/mail/tpop3d/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-31 05:43:57 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-31 05:43:57 +0000
commit3b958fc914e24661941243a8d0ff1d550e4d2616 (patch)
tree6853deaef837a39c48ccde154ea10e8fdfc550b9 /mail/tpop3d/Makefile
parentc5114301454ab2997551bc1b14f2d13bd99359b9 (diff)
downloadports-3b958fc914e24661941243a8d0ff1d550e4d2616.tar.gz
ports-3b958fc914e24661941243a8d0ff1d550e4d2616.zip
Notes
Diffstat (limited to 'mail/tpop3d/Makefile')
-rw-r--r--mail/tpop3d/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
new file mode 100644
index 000000000000..d3872219c0c8
--- /dev/null
+++ b/mail/tpop3d/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: tpop3d
+# Date created: 27 July 2001
+# Whom: chris@shagged.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tpop3d
+PORTVERSION= 1.3.4
+CATEGORIES= mail
+MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
+
+MAINTAINER= chris@shagged.org
+
+# mysql authentication
+.if !defined(WITHOUT_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+.endif
+
+# perl authentication
+.if defined(WITH_PERLAUTH)
+USE_PERL5= yes
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-auth-other \
+ --with-mailspool-directory=/var/mail
+
+.if !defined(WITHOUT_MYSQL)
+CONFIGURE_ARGS+= --enable-auth-mysql --with-mysql-root=${LOCALBASE}
+.endif
+.if defined(WITH_PERLAUTH)
+CONFIGURE_ARGS+= --enable-auth-perl
+.endif
+.if !defined(WITHOUT_MAILDIR)
+CONFIGURE_ARGS+= --enable-mbox-maildir
+.endif
+
+SAMPLE_RCD= tpop3d.sh.sample
+STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${SAMPLE_RCD}
+DEFAULT_CONFIG= ${PREFIX}/etc/tpop3d.conf.dist
+
+MAN5= tpop3d.conf.5
+MAN8= tpop3d.8
+
+post-patch:
+ @${PERL} -pi -e 's,^CFLAGS =, CFLAGS = \@CFLAGS\@,' \
+ ${WRKSRC}/Makefile.in
+ @${PERL} -pi -e 's,/etc/tpop3d,${PREFIX}/etc/tpop3d,g' \
+ ${WRKSRC}/tpop3d.conf.5 ${WRKSRC}/tpop3d.8
+
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/tpop3d.conf.dist ${DEFAULT_CONFIG}
+ @if [ ! -f ${STARTUP_SCRIPT} ]; then \
+ ${INSTALL_SCRIPT} ${FILESDIR}/${SAMPLE_RCD} \
+ ${STARTUP_SCRIPT} ; \
+ fi
+ @if [ ! -f ${PREFIX}/etc/tpop3d.conf ]; then \
+ ${INSTALL_SCRIPT} ${FILESDIR}/tpop3d.conf.dist \
+ ${PREFIX}/etc/tpop3d.conf ; \
+ fi
+
+.include <bsd.port.mk>