aboutsummaryrefslogtreecommitdiff
path: root/mail/tpop3d/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-11 22:08:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-11 22:08:12 +0000
commitf7d3313e01fc8ce49cdbca26b442dd8fae381854 (patch)
tree77e6d42f703fe841258e24466c88dc08b7a09256 /mail/tpop3d/Makefile
parent193131fbb6c0c88e3edcfdd55550534018f24745 (diff)
downloadports-f7d3313e01fc8ce49cdbca26b442dd8fae381854.tar.gz
ports-f7d3313e01fc8ce49cdbca26b442dd8fae381854.zip
Notes
Diffstat (limited to 'mail/tpop3d/Makefile')
-rw-r--r--mail/tpop3d/Makefile41
1 files changed, 29 insertions, 12 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index 35a09e12972b..9427970fb872 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= mail
MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
MAINTAINER= chris@shagged.org
-COMMENT= Virtual-domain capable POP3 server supporting MySQL auth
+COMMENT= Virtual-domain capable POP3 server supporting MySQL,PgSQL etc auth
USE_OPENSSL= yes
USE_REINPLACE= yes
@@ -23,37 +23,58 @@ CONFIGURE_ARGS= --enable-auth-other \
--with-mailspool-directory=/var/mail
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+OPTIONS= MYSQL "Use MySQL authentication" off \
+ PGSQL "Use PgSQL authentication" off \
+ LDAP "Use LDAP authentication" off \
+ PERLAUTH "Use Perl authentication" off \
+ FLATAUTH "Enable /etc/passwd-style authentication" off \
+ MAILDIR "Compile Maildir support" on
+
# MySQL authentication
-.if !defined(WITHOUT_MYSQL)
+.if defined(WITH_MYSQL) && !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
+DEFAULT_MYSQL_VER= 41
CONFIGURE_ARGS+= --enable-auth-mysql \
--with-mysql-lib-dir=${LOCALBASE}/lib/mysql \
--with-mysql-include-dir=${LOCALBASE}/include/mysql
.endif
-.if defined(WITH_LDAP)
+.if defined(WITH_PGSQL) && !defined(WITHOUT_PGSQL)
+USE_PGSQL= yes
+DEFAULT_PGSQL_VER= 80
+CONFIGURE_ARGS+= --enable-auth-pgsql \
+ --with-pgsql-lib-dir=${LOCALBASE}/lib \
+ --with-pgsql-include-dir=${LOCALBASE}/include
+.endif
+
+.if defined(WITH_LDAP) && !defined(WITHOUT_LDAP)
LIB_DEPENDS+= ldap-2.2:${PORTSDIR}/net/openldap22-client
CONFIGURE_ARGS+= --enable-auth-ldap --with-openldap-root=${LOCALBASE}
.endif
# Perl authentication
-.if defined(WITH_PERLAUTH)
+.if defined(WITH_PERLAUTH) && !defined(WITHOUT_PERLAUTH)
USE_PERL5= yes
CONFIGURE_ARGS+= --enable-auth-perl
.endif
+.if defined(WITH_FLATAUTH) && !defined(WITHOUT_FLATAUTH)
+CONFIGURE_ARGS+= --enable-auth-flatfile
+.endif
+
.if !defined(WITHOUT_MAILDIR)
CONFIGURE_ARGS+= --enable-mbox-maildir
.endif
-SAMPLE_RCD= tpop3d.sh.sample
-STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${SAMPLE_RCD}
+USE_RC_SUBR= tpop3d.sh
DEFAULT_CONFIG= ${PREFIX}/etc/tpop3d.conf.dist
MAN5= tpop3d.conf.5
MAN8= tpop3d.8
-DOCS= CHANGES CREDITS FAQ HACKING INSTALL PORTABILITY \
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGES CREDITS FAQ HACKING INSTALL PORTABILITY \
README README.POP-before-SMTP README.auth_mysql TODO
+.endif
post-patch:
@${REINPLACE_CMD} 's,^CFLAGS =, CFLAGS = \@CFLAGS\@,' \
@@ -63,17 +84,13 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/tpop3d.conf.dist ${DEFAULT_CONFIG}
- @if [ ! -f ${STARTUP_SCRIPT} ]; then \
- ${INSTALL_SCRIPT} ${FILESDIR}/${SAMPLE_RCD} \
- ${STARTUP_SCRIPT} ; \
- fi
@if [ ! -f ${PREFIX}/etc/tpop3d.conf ]; then \
${INSTALL_SCRIPT} ${FILESDIR}/tpop3d.conf.dist \
${PREFIX}/etc/tpop3d.conf ; \
fi
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>