aboutsummaryrefslogtreecommitdiff
path: root/mail/up-imapproxy
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-06 00:56:42 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-06 00:56:42 +0000
commit5bf24e10aac08e8278c3ef893a94e8eea21ec2dd (patch)
tree0f6f67e47f7984f312ce735fc8308936c0633ed6 /mail/up-imapproxy
parentaf42c5091df0006d76693ade32aab7f849e56828 (diff)
downloadports-5bf24e10aac08e8278c3ef893a94e8eea21ec2dd.tar.gz
ports-5bf24e10aac08e8278c3ef893a94e8eea21ec2dd.zip
Notes
Diffstat (limited to 'mail/up-imapproxy')
-rw-r--r--mail/up-imapproxy/Makefile13
-rw-r--r--mail/up-imapproxy/files/imapproxyd.sh.in2
2 files changed, 13 insertions, 2 deletions
diff --git a/mail/up-imapproxy/Makefile b/mail/up-imapproxy/Makefile
index a4ff313df1b3..9703a7522626 100644
--- a/mail/up-imapproxy/Makefile
+++ b/mail/up-imapproxy/Makefile
@@ -27,6 +27,17 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+OPTIONS= DOVECOT "Use with dovecot2" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DOVECOT)
+SUB_LIST+= DOVECOT="dovecot"
+RUN_DEPENDS+= dovecot>=1.0:${PORTSDIR}/mail/dovecot2
+.else
+SUB_LIST+= DOVECOT=""
+.endif
+
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -36,4 +47,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/scripts/imapproxy.conf ${PREFIX}/etc/imapproxyd.conf.sample
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/up-imapproxy/files/imapproxyd.sh.in b/mail/up-imapproxy/files/imapproxyd.sh.in
index ac9576496e1c..c9bebba1ced5 100644
--- a/mail/up-imapproxy/files/imapproxyd.sh.in
+++ b/mail/up-imapproxy/files/imapproxyd.sh.in
@@ -3,7 +3,7 @@
# $FreeBSD$
#
# PROVIDE: imapproxyd
-# REQUIRE: DAEMON courier_imap_imapd courier_imap_imapd_ssl cyrus_imapd inetd
+# REQUIRE: DAEMON courier_imap_imapd courier_imap_imapd_ssl cyrus_imapd inetd %%DOVECOT%%
# KEYWORD: shutdown
#