aboutsummaryrefslogtreecommitdiff
path: root/mail/up-imapproxy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-11-23 17:24:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-11-23 17:24:44 +0000
commit9fd453f7ed9c5ef906ec4337711e61c4095f000e (patch)
tree3fafdd38c5d1a5bda69bae72bbea35a759c2bb30 /mail/up-imapproxy
parent9fed815c9bd34c4deda915eab1033e4a1a3d2254 (diff)
downloadports-9fd453f7ed9c5ef906ec4337711e61c4095f000e.tar.gz
ports-9fd453f7ed9c5ef906ec4337711e61c4095f000e.zip
Notes
Diffstat (limited to 'mail/up-imapproxy')
-rw-r--r--mail/up-imapproxy/Makefile8
-rw-r--r--mail/up-imapproxy/files/patch-src_imapcommon.c13
2 files changed, 14 insertions, 7 deletions
diff --git a/mail/up-imapproxy/Makefile b/mail/up-imapproxy/Makefile
index 29e895b2f27d..b99a1b8cf80a 100644
--- a/mail/up-imapproxy/Makefile
+++ b/mail/up-imapproxy/Makefile
@@ -19,12 +19,6 @@ COMMENT= A caching IMAP proxy server
GNU_CONFIGURE= YES
USE_RC_SUBR= imapproxyd.sh
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700019
-BROKEN= Does not compile on FreeBSD >= 7.0
-.endif
-
post-patch:
${REINPLACE_CMD} -e "s|-lc_r|${PTHREAD_LIBS}|g" \
-e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
@@ -36,4 +30,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/up-imapproxy/files/patch-src_imapcommon.c b/mail/up-imapproxy/files/patch-src_imapcommon.c
new file mode 100644
index 000000000000..0dab2e8332d6
--- /dev/null
+++ b/mail/up-imapproxy/files/patch-src_imapcommon.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/imapcommon.c.orig
++++ src/imapcommon.c
+@@ -136,6 +136,7 @@
+
+ #include <openssl/evp.h>
+ #include <openssl/err.h>
++#include <openssl/md5.h>
+
+ #include <pthread.h>
+ #include <sys/types.h>