aboutsummaryrefslogtreecommitdiff
path: root/mail/usendmail
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-02-29 22:55:38 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-02-29 22:55:38 +0000
commit6520b351f20e59bf94782a669b3544503c718230 (patch)
tree448359d78d34224bec65e55d27e635bb1dd90bd1 /mail/usendmail
parent207323cc3c3d6057392b11cd466d736effc4f44c (diff)
downloadports-6520b351f20e59bf94782a669b3544503c718230.tar.gz
ports-6520b351f20e59bf94782a669b3544503c718230.zip
Notes
Diffstat (limited to 'mail/usendmail')
-rw-r--r--mail/usendmail/Makefile49
-rw-r--r--mail/usendmail/distinfo2
-rw-r--r--mail/usendmail/pkg-descr7
-rw-r--r--mail/usendmail/pkg-message20
4 files changed, 78 insertions, 0 deletions
diff --git a/mail/usendmail/Makefile b/mail/usendmail/Makefile
new file mode 100644
index 000000000000..b08ea6084a7f
--- /dev/null
+++ b/mail/usendmail/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: usendmail
+# Date created: 2004-02-19
+# Whom: Thomas Seck <tmseck@netcologne.de>
+#
+# $FreeBSD$
+#
+# Tunables: QMAIL_DIR: Where qmail resides (default: /var/qmail)
+
+PORTNAME= usendmail
+PORTVERSION= 0.1.6
+CATEGORIES= mail
+MASTER_SITES= http://www.ohse.de/uwe/usendmail/
+
+MAINTAINER= tmseck@netcologne.de
+COMMENT= A replacement for qmail's sendmail drop-in
+
+BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
+RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
+
+QMAIL_DIR?= /var/qmail
+
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/mail/${DISTNAME}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PLIST_FILES= sbin/usendmail
+PORTDOCS= NEWS README
+
+do-patch:
+ @${REINPLACE_CMD} -e 's,/var/qmail,${QMAIL_DIR},' \
+ ${WRKSRC}/src/usendmail.c
+
+do-build:
+ cd ${WRKSRC} && ./package/build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/command/usendmail ${PREFIX}/sbin/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/src && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ @${SED} -e 's:%%PREFIX%%:${PREFIX}:g' \
+ -e's:%%QMAIL_DIR%%:${QMAIL_DIR}:g' <pkg-message \
+ >${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/usendmail/distinfo b/mail/usendmail/distinfo
new file mode 100644
index 000000000000..bf9f49107fb5
--- /dev/null
+++ b/mail/usendmail/distinfo
@@ -0,0 +1,2 @@
+MD5 (usendmail-0.1.6.tar.gz) = de4b8f1ad8eb9b24b3b8d887aa94fddc
+SIZE (usendmail-0.1.6.tar.gz) = 51071
diff --git a/mail/usendmail/pkg-descr b/mail/usendmail/pkg-descr
new file mode 100644
index 000000000000..2076584727cc
--- /dev/null
+++ b/mail/usendmail/pkg-descr
@@ -0,0 +1,7 @@
+usendmail is a replacement for the sendmail clone of the qmail package.
+
+It accepts more of the original sendmail's commandline options and does
+not depend on environment variables to set the envelope sender.
+
+Author: Uwe Ohse <uwe@ohse.de>
+WWW: http://www.ohse.de/uwe/usendmail.html
diff --git a/mail/usendmail/pkg-message b/mail/usendmail/pkg-message
new file mode 100644
index 000000000000..f6f1d3fc8366
--- /dev/null
+++ b/mail/usendmail/pkg-message
@@ -0,0 +1,20 @@
+
+usendmail has been successfully installed!
+
+Now you have to change your sendmail(8) wrapping:
+
+If you are using mailwrapper(8), do the following:
+
+in /etc/mail/mailer.conf replace the lines
+
+sendmail %%QMAIL_DIR%%/bin/sendmail
+send-mail %%QMAIL_DIR%%/bin/sendmail
+
+with
+
+sendmail %%PREFIX%%/sbin/usendmail
+send-mail %%PREFIX%%/sbin/usendmail
+
+Otherwise replace the link from /usr/sbin/sendmail to
+%%QMAIL_DIR%%/bin/sendmail with one to %%PREFIX%%/sbin/usendmail.
+