aboutsummaryrefslogtreecommitdiff
path: root/mail/vmailmgr
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-02-02 14:17:24 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-02-02 14:17:24 +0000
commit83d745472982a48daff75befd9b437c9de07d34c (patch)
tree260cefc07fc5f2e209cb9e27cc1784c2f2f6a06e /mail/vmailmgr
parent5da5196c0a2c82c9a3cf80481c84839d324fe2c5 (diff)
downloadports-83d745472982a48daff75befd9b437c9de07d34c.tar.gz
ports-83d745472982a48daff75befd9b437c9de07d34c.zip
Notes
Diffstat (limited to 'mail/vmailmgr')
-rw-r--r--mail/vmailmgr/files/patch-authenticate:Makefile.in11
-rw-r--r--mail/vmailmgr/files/patch-authenticate:authvmailmgr.cc10
-rw-r--r--mail/vmailmgr/files/patch-authenticate:checkvpw.cc10
-rw-r--r--mail/vmailmgr/files/patch-authenticate:vauthenticate.cc10
-rw-r--r--mail/vmailmgr/files/patch-cgi:Makefile.in11
-rw-r--r--mail/vmailmgr/files/patch-commands:Makefile.in11
-rw-r--r--mail/vmailmgr/files/patch-commands:vcheckquota.cc17
-rw-r--r--mail/vmailmgr/files/patch-commands:vchforwards.cc12
-rw-r--r--mail/vmailmgr/files/patch-commands:vpasswd2cdb.cc15
-rw-r--r--mail/vmailmgr/files/patch-commands:vpasswd2db.cc15
-rw-r--r--mail/vmailmgr/files/patch-daemon:Makefile.in11
-rw-r--r--mail/vmailmgr/files/patch-lib:courier-authlib:changeuidgid.c10
-rw-r--r--mail/vmailmgr/files/patch-lib:fdbuf:fdbuf.h12
-rw-r--r--mail/vmailmgr/files/patch-lib:misc:exec.cc10
-rw-r--r--mail/vmailmgr/files/patch-lib:misc:keystrlist.cc10
-rw-r--r--mail/vmailmgr/files/patch-lib:misc:server.cc10
-rw-r--r--mail/vmailmgr/files/patch-lib:misc:strlist.cc10
-rw-r--r--mail/vmailmgr/files/patch-lib:mystring:append.cc8
18 files changed, 203 insertions, 0 deletions
diff --git a/mail/vmailmgr/files/patch-authenticate:Makefile.in b/mail/vmailmgr/files/patch-authenticate:Makefile.in
new file mode 100644
index 000000000000..51a9960e58aa
--- /dev/null
+++ b/mail/vmailmgr/files/patch-authenticate:Makefile.in
@@ -0,0 +1,11 @@
+--- authenticate/Makefile.in.orig Mon Feb 2 14:47:40 2004
++++ authenticate/Makefile.in Mon Feb 2 14:49:35 2004
+@@ -93,7 +93,7 @@
+
+ EXTRA_DIST = $(man_MANS) $(noinst_HTMLS) $(noinst_PODS)
+
+-CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
++CXXLINK = $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@
+ INCLUDES = $(CIINCLUDES) -I../lib
+
+ checkvpw_SOURCES = checkvpw.cc authvlib.cc authvlib.h
diff --git a/mail/vmailmgr/files/patch-authenticate:authvmailmgr.cc b/mail/vmailmgr/files/patch-authenticate:authvmailmgr.cc
new file mode 100644
index 000000000000..816f9a77a92c
--- /dev/null
+++ b/mail/vmailmgr/files/patch-authenticate:authvmailmgr.cc
@@ -0,0 +1,10 @@
+--- ./authenticate/authvmailmgr.cc.orig Mon Feb 2 14:45:25 2004
++++ ./authenticate/authvmailmgr.cc Mon Feb 2 14:45:40 2004
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "misc/exec.h"
+ #include "authvlib.h"
+ // Courier-IMAP includes
diff --git a/mail/vmailmgr/files/patch-authenticate:checkvpw.cc b/mail/vmailmgr/files/patch-authenticate:checkvpw.cc
new file mode 100644
index 000000000000..2d2957a155e4
--- /dev/null
+++ b/mail/vmailmgr/files/patch-authenticate:checkvpw.cc
@@ -0,0 +1,10 @@
+--- authenticate/checkvpw.cc.orig Mon Feb 2 14:51:35 2004
++++ authenticate/checkvpw.cc Mon Feb 2 14:51:55 2004
+@@ -16,6 +16,7 @@
+
+ #include <config.h>
+ #include <errno.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
+ #include "config/configrc.h"
diff --git a/mail/vmailmgr/files/patch-authenticate:vauthenticate.cc b/mail/vmailmgr/files/patch-authenticate:vauthenticate.cc
new file mode 100644
index 000000000000..87502f9195e1
--- /dev/null
+++ b/mail/vmailmgr/files/patch-authenticate:vauthenticate.cc
@@ -0,0 +1,10 @@
+--- authenticate/vauthenticate.cc.orig Mon Feb 2 14:53:58 2004
++++ authenticate/vauthenticate.cc Mon Feb 2 14:54:10 2004
+@@ -16,6 +16,7 @@
+
+ #include <config.h>
+ #include <errno.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include "authvlib.h"
+ #include "fdbuf/fdbuf.h"
diff --git a/mail/vmailmgr/files/patch-cgi:Makefile.in b/mail/vmailmgr/files/patch-cgi:Makefile.in
new file mode 100644
index 000000000000..14b06743f1a7
--- /dev/null
+++ b/mail/vmailmgr/files/patch-cgi:Makefile.in
@@ -0,0 +1,11 @@
+--- cgi/Makefile.in.orig Mon Feb 2 15:09:56 2004
++++ cgi/Makefile.in Mon Feb 2 15:10:07 2004
+@@ -86,7 +86,7 @@
+ cgi_PROGRAMS = vpasswd vadduser vdeluser vaddalias vchattr vchforwards listvdomain
+
+
+-CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
++CXXLINK = $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@
+ INCLUDES = -I../lib
+
+ vpasswd_SOURCES = vpasswd.cc
diff --git a/mail/vmailmgr/files/patch-commands:Makefile.in b/mail/vmailmgr/files/patch-commands:Makefile.in
new file mode 100644
index 000000000000..d8eeeec03818
--- /dev/null
+++ b/mail/vmailmgr/files/patch-commands:Makefile.in
@@ -0,0 +1,11 @@
+--- commands/Makefile.in.orig Mon Feb 2 14:57:14 2004
++++ commands/Makefile.in Mon Feb 2 14:57:24 2004
+@@ -99,7 +99,7 @@
+ EXTRA_PROGRAMS = vpasswd2cdb vrehash
+ EXTRA_SCRIPTS = allvpasswd2cdb
+
+-CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
++CXXLINK = $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@
+ INCLUDES = -I../lib -DBINDIR=\"@bindir@\"
+
+ listvdomain_SOURCES = listvdomain.cc vcommand.cc
diff --git a/mail/vmailmgr/files/patch-commands:vcheckquota.cc b/mail/vmailmgr/files/patch-commands:vcheckquota.cc
new file mode 100644
index 000000000000..de8bd01bb6c3
--- /dev/null
+++ b/mail/vmailmgr/files/patch-commands:vcheckquota.cc
@@ -0,0 +1,17 @@
+--- commands/vcheckquota.cc.orig Mon Feb 2 15:00:41 2004
++++ commands/vcheckquota.cc Mon Feb 2 15:01:15 2004
+@@ -31,10 +31,10 @@
+
+ const char* cli_program = "vcheckquota";
+ const char* cli_help_prefix = "vmailmgr quota enforcement program\n";
+-const char* cli_help_suffix = "
+-Warning: the soft-message is linked into the users maildir once for each
+-message that is received while the account is over its soft quota. This may
+-result in multiple warning messages.\n";
++const char* cli_help_suffix = "\n"
++"Warning: the soft-message is linked into the users maildir once for each\n"
++"message that is received while the account is over its soft quota. This may\n"
++"result in multiple warning messages.\n";
+ const char* cli_args_usage = "";
+ const int cli_args_min = 0;
+ const int cli_args_max = 0;
diff --git a/mail/vmailmgr/files/patch-commands:vchforwards.cc b/mail/vmailmgr/files/patch-commands:vchforwards.cc
new file mode 100644
index 000000000000..8e880685fb2c
--- /dev/null
+++ b/mail/vmailmgr/files/patch-commands:vchforwards.cc
@@ -0,0 +1,12 @@
+--- commands/vchforwards.cc.orig Mon Feb 2 14:58:55 2004
++++ commands/vchforwards.cc Mon Feb 2 14:59:29 2004
+@@ -25,8 +25,7 @@
+ const char* cli_help_prefix =
+ "Change virtual user forwarding addresses.\n";
+ const char* cli_help_suffix =
+-"If no forwarding addresses are given, forwarding is disabled.
+-";
++"If no forwarding addresses are given, forwarding is disabled.\n";
+ const char* cli_args_usage = "USERNAME [DESTINATION1 ...]";
+ const int cli_args_min = 1;
+ const int cli_args_max = -1;
diff --git a/mail/vmailmgr/files/patch-commands:vpasswd2cdb.cc b/mail/vmailmgr/files/patch-commands:vpasswd2cdb.cc
new file mode 100644
index 000000000000..b3f82b201f24
--- /dev/null
+++ b/mail/vmailmgr/files/patch-commands:vpasswd2cdb.cc
@@ -0,0 +1,15 @@
+--- commands/vpasswd2cdb.cc.orig Mon Feb 2 14:55:24 2004
++++ commands/vpasswd2cdb.cc Mon Feb 2 14:56:26 2004
+@@ -27,9 +27,9 @@
+ const char* cli_program = "vpasswd2cdb";
+ const char* cli_help_prefix = "Converts text password tables to CDB format\n";
+ const char* cli_help_suffix =
+-"Reads in a standard virtual password table in the current directory,
+-and writes it out to a CDB table. The file names for the text and CDB
+-tables are determined from the configuration file.";
++"Reads in a standard virtual password table in the current directory,\n"
++"and writes it out to a CDB table. The file names for the text and CDB\n"
++"tables are determined from the configuration file.";
+ const char* cli_args_usage = "";
+ const int cli_args_min = 0;
+ const int cli_args_max = 0;
diff --git a/mail/vmailmgr/files/patch-commands:vpasswd2db.cc b/mail/vmailmgr/files/patch-commands:vpasswd2db.cc
new file mode 100644
index 000000000000..7cb14574c724
--- /dev/null
+++ b/mail/vmailmgr/files/patch-commands:vpasswd2db.cc
@@ -0,0 +1,15 @@
+--- commands/vpasswd2db.cc.orig Mon Feb 2 15:02:15 2004
++++ commands/vpasswd2db.cc Mon Feb 2 15:02:33 2004
+@@ -26,9 +26,9 @@
+ const char* cli_program = "vpasswd2db";
+ const char* cli_help_prefix = "Converts text password tables to current vpwtable DB format\n";
+ const char* cli_help_suffix =
+-"Reads in a standard virtual password table in the current directory,
+-and writes it out to a table. The file names for the input and output
+-tables are determined from the configuration file.";
++"Reads in a standard virtual password table in the current directory,\n"
++"and writes it out to a table. The file names for the input and output\n"
++"tables are determined from the configuration file.";
+ const char* cli_args_usage = "";
+ const int cli_args_min = 0;
+ const int cli_args_max = 0;
diff --git a/mail/vmailmgr/files/patch-daemon:Makefile.in b/mail/vmailmgr/files/patch-daemon:Makefile.in
new file mode 100644
index 000000000000..1338a6832d56
--- /dev/null
+++ b/mail/vmailmgr/files/patch-daemon:Makefile.in
@@ -0,0 +1,11 @@
+--- daemon/Makefile.in.orig Mon Feb 2 15:06:13 2004
++++ daemon/Makefile.in Mon Feb 2 15:06:27 2004
+@@ -91,7 +91,7 @@
+
+ EXTRA_DIST = $(man_MANS) $(noinst_HTMLS) $(noinst_PODS)
+
+-CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
++CXXLINK = $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@
+ INCLUDES = -I../lib
+
+ vmailmgrd_SOURCES = daemon.h adduser2.cc autoresponse.cc chattr.cc check.cc command.h command.cc deluser.cc dispatch.cc listdomain.cc log.h log.cc lookup.cc main.cc state.h state.cc
diff --git a/mail/vmailmgr/files/patch-lib:courier-authlib:changeuidgid.c b/mail/vmailmgr/files/patch-lib:courier-authlib:changeuidgid.c
new file mode 100644
index 000000000000..d4ffb7d8061e
--- /dev/null
+++ b/mail/vmailmgr/files/patch-lib:courier-authlib:changeuidgid.c
@@ -0,0 +1,10 @@
+--- ./lib/courier-authlib/changeuidgid.c.orig Mon Feb 2 14:43:32 2004
++++ ./lib/courier-authlib/changeuidgid.c Mon Feb 2 14:43:57 2004
+@@ -12,6 +12,7 @@
+ #endif
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <grp.h>
+ #include <pwd.h>
+ #include <errno.h>
diff --git a/mail/vmailmgr/files/patch-lib:fdbuf:fdbuf.h b/mail/vmailmgr/files/patch-lib:fdbuf:fdbuf.h
new file mode 100644
index 000000000000..59e536d3bf07
--- /dev/null
+++ b/mail/vmailmgr/files/patch-lib:fdbuf:fdbuf.h
@@ -0,0 +1,12 @@
+--- lib/fdbuf/fdbuf.h.orig Mon Feb 2 14:40:11 2004
++++ lib/fdbuf/fdbuf.h Mon Feb 2 14:40:38 2004
+@@ -25,6 +25,9 @@
+ #include <pthread.h>
+ #endif
+
++#include <unistd.h>
++#include <sys/types.h>
++
+ #ifndef FDBUF_SIZE
+ #define FDBUF_SIZE 4096
+ #endif
diff --git a/mail/vmailmgr/files/patch-lib:misc:exec.cc b/mail/vmailmgr/files/patch-lib:misc:exec.cc
new file mode 100644
index 000000000000..204239fbc4a2
--- /dev/null
+++ b/mail/vmailmgr/files/patch-lib:misc:exec.cc
@@ -0,0 +1,10 @@
+--- lib/misc/exec.cc.orig Mon Feb 2 14:31:16 2004
++++ lib/misc/exec.cc Mon Feb 2 14:31:41 2004
+@@ -17,6 +17,7 @@
+ #include <config.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
diff --git a/mail/vmailmgr/files/patch-lib:misc:keystrlist.cc b/mail/vmailmgr/files/patch-lib:misc:keystrlist.cc
new file mode 100644
index 000000000000..26bbb79b5c0e
--- /dev/null
+++ b/mail/vmailmgr/files/patch-lib:misc:keystrlist.cc
@@ -0,0 +1,10 @@
+--- lib/misc/keystrlist.cc.orig Mon Feb 2 14:33:33 2004
++++ lib/misc/keystrlist.cc Mon Feb 2 14:33:55 2004
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "strlist.h"
+
+ void keystrlist::set(const mystring& var, const mystring& val)
diff --git a/mail/vmailmgr/files/patch-lib:misc:server.cc b/mail/vmailmgr/files/patch-lib:misc:server.cc
new file mode 100644
index 000000000000..a0c689d465ff
--- /dev/null
+++ b/mail/vmailmgr/files/patch-lib:misc:server.cc
@@ -0,0 +1,10 @@
+--- lib/misc/server.cc.orig Mon Feb 2 14:37:29 2004
++++ lib/misc/server.cc Mon Feb 2 14:37:47 2004
+@@ -17,6 +17,7 @@
+ #include <config.h>
+ #include "server.h"
+ #include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+ #include "un.h"
+ #include "debug.h"
diff --git a/mail/vmailmgr/files/patch-lib:misc:strlist.cc b/mail/vmailmgr/files/patch-lib:misc:strlist.cc
new file mode 100644
index 000000000000..583b9017b967
--- /dev/null
+++ b/mail/vmailmgr/files/patch-lib:misc:strlist.cc
@@ -0,0 +1,10 @@
+--- lib/misc/strlist.cc.orig Mon Feb 2 14:38:26 2004
++++ lib/misc/strlist.cc Mon Feb 2 14:38:45 2004
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "strlist.h"
+
+ static const char* compare(const char* ptr, const char* end,
diff --git a/mail/vmailmgr/files/patch-lib:mystring:append.cc b/mail/vmailmgr/files/patch-lib:mystring:append.cc
new file mode 100644
index 000000000000..b08c792271c2
--- /dev/null
+++ b/mail/vmailmgr/files/patch-lib:mystring:append.cc
@@ -0,0 +1,8 @@
+--- lib/mystring/append.cc.orig Mon Feb 2 14:41:33 2004
++++ lib/mystring/append.cc Mon Feb 2 14:41:52 2004
+@@ -1,3 +1,5 @@
++#include <string.h>
++
+ #include "mystring.h"
+ #include "trace.h"
+