aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail-devel/Makefile
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-09-21 13:01:40 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-09-21 13:01:40 +0000
commit25d71de54f714c720bd489935f505966c0775673 (patch)
treee14a0d156dd5a4ecbe879bd48527fc5628ddab70 /mail/vpopmail-devel/Makefile
parent7bd115647620e71533b86dc07f00c0bb8d82edd2 (diff)
downloadports-25d71de54f714c720bd489935f505966c0775673.tar.gz
ports-25d71de54f714c720bd489935f505966c0775673.zip
Notes
Diffstat (limited to 'mail/vpopmail-devel/Makefile')
-rw-r--r--mail/vpopmail-devel/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
new file mode 100644
index 000000000000..a7dd9b4c5774
--- /dev/null
+++ b/mail/vpopmail-devel/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: vpopmail
+# Date created: 21 Sep 2000
+# Whom: makeport.pl
+#
+# $FreeBSD$
+#
+
+PORTNAME= vpopmail
+PORTVERSION= 4.9
+CATEGORIES= mail
+MASTER_SITES= http://www.inter7.com/vpopmail/
+
+MAINTAINER= nbm@FreeBSD.org
+
+BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
+ ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
+ ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+CONFIGURE_ARGS= --enable-qmail-dir=${QMAIL_DIR} \
+ --enable-tcprules-bin=${LOCALBASE}/bin/tcprules \
+ --enable-tcpserver-file=~vpopmail/etc/tcp.smtp
+
+#
+# Attempt to set the location of qmail by a simple check. Override this
+# if your qmail lives elsewhere.
+#
+
+.if exists(${LOCALBASE}/qmail/bin/qmail-send)
+QMAIL_DIR?= ${LOCALBASE}/qmail
+.else
+QMAIL_DIR?= /var/qmail
+.endif
+
+#
+# This port doesn't honour PREFIX, it honours vpopmail's home directory.
+# Since we create vpopmail if it doesn't exist, we set it so that it
+# does honour PREFIX. -- nbm
+#
+
+pre-configure:
+ @PKG_PREFIX=${PREFIX}/vpopmail ${PERL5} ${PKGDIR}/INSTALL
+
+.include <bsd.port.mk>