aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail-devel
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
commit01c588a6357d8452a3e0af157e9c1250c067db2f (patch)
treefb26bf418ea8791ab4d308a7931c623124611c3c /mail/vpopmail-devel
parentf484c99df79f169bf954fc4b0ed83e59279a596a (diff)
downloadports-01c588a6357d8452a3e0af157e9c1250c067db2f.tar.gz
ports-01c588a6357d8452a3e0af157e9c1250c067db2f.zip
Notes
Diffstat (limited to 'mail/vpopmail-devel')
-rw-r--r--mail/vpopmail-devel/Makefile26
-rw-r--r--mail/vpopmail-devel/pkg-plist4
2 files changed, 13 insertions, 17 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index e4dab9ec5028..baefa5e5f2c1 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpopmail
PORTVERSION= 5.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,23 +16,22 @@ PKGNAMESUFFIX= -devel
MAINTAINER= ale@FreeBSD.org
COMMENT= Easy virtual domain and authentication package for use with qmail
-BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
- ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
-RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
- ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+BUILD_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+RUN_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+USE_QMAIL= yes
CONFLICTS= vpopmail-5.*
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_REINPLACE= YES
-USE_PERL5_BUILD= YES
+USE_PERL5= YES
VCFGDIR?= ${WRKDIR}/vcfg
VCFGFILES?= inc_deps lib_deps tcp.smtp
CONFIGURE_ENV+= VCFGDIR="${VCFGDIR}"
-CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
+CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_PREFIX} \
--enable-tcprules-prog=${LOCALBASE}/bin/tcprules \
--enable-tcpserver-file=${PREFIX}/vpopmail/etc/tcp.smtp
@@ -74,7 +73,7 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
# WITHOUT_AUTH_LOG - disables authentication logging
# WITH_MYSQL_LOG - enable logging to a MySQL database
# WITH_PGSQL_LOG - enable logging to a PostgreSQL database
-# QMAIL_DIR - location of qmail directory
+# QMAIL_PREFIX - location of qmail directory
# PREFIX - installation area for vpopmail (see comment below)
# VCHKPW_GID - the group ID of the new vchkpw group (89)
# VPOPMAIL_UID - the user ID of the new vpopmail user (89)
@@ -170,12 +169,6 @@ CONFIGURE_ARGS+= --enable-pgsql-logging
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/qmail/bin/qmail-send)
-QMAIL_DIR?= ${LOCALBASE}/qmail
-.else
-QMAIL_DIR?= /var/qmail
-.endif
-
# Uncomment this, or set PREFIX to /home if you have an existing
# vpopmail install with the vpopmail users' home directory set to
# /home/vpopmail - package rules dictate we default to /usr/local/vpopmail
@@ -327,10 +320,11 @@ post-install:
${MKDIR} ${PREFIX}/vpopmail/etc
if [ ! -e "${PREFIX}/vpopmail/etc/tcp.smtp" ]; then \
if [ -e "${VCFGDIR}/tcp.smtp" ]; then \
- ${INSTALL_DATA} ${VCFGDIR}/tcp.smtp ${PREFIX}/vpopmail/etc/; \
+ ${INSTALL_DATA} ${VCFGDIR}/tcp.smtp ${PREFIX}/vpopmail/etc/tcp.smtp-dist; \
else \
- ${TOUCH} ${PREFIX}/vpopmail/etc/tcp.smtp; \
+ ${TOUCH} ${PREFIX}/vpopmail/etc/tcp.smtp-dist; \
fi; \
+ ${CP} -p ${PREFIX}/vpopmail/etc/tcp.smtp-dist ${PREFIX}/vpopmail/etc/tcp.smtp; \
fi
.if defined(DEFAULT_DOMAIN)
${ECHO_CMD} ${DEFAULT_DOMAIN} > ${PREFIX}/vpopmail/etc/defaultdomain
diff --git a/mail/vpopmail-devel/pkg-plist b/mail/vpopmail-devel/pkg-plist
index 2f113a2e8d2d..98ff8626c947 100644
--- a/mail/vpopmail-devel/pkg-plist
+++ b/mail/vpopmail-devel/pkg-plist
@@ -41,7 +41,9 @@ vpopmail/doc/man_html/vsetuserquota.html
@unexec if [ -f %D/vpopmail/etc/defaultdomain ]; then rm -f %D/vpopmail/etc/defaultdomain; fi
vpopmail/etc/inc_deps
vpopmail/etc/lib_deps
-@unexec if [ -f %D/vpopmail/etc/tcp.smtp -a ! -s %D/vpopmail/etc/tcp.smtp ]; then rm -f %D/vpopmail/etc/tcp.smtp; fi
+@unexec if cmp -s %D/vpopmail/etc/tcp.smtp %D/vpopmail/etc/tcp.smtp-dist; then rm -f %D/vpopmail/etc/tcp.smtp; fi
+vpopmail/etc/tcp.smtp-dist
+@exec if [ ! -f %D/vpopmail/etc/tcp.smtp ] ; then cp -p %D/%F %B/tcp.smtp; fi
@unexec if cmp -s %D/vpopmail/etc/vlimits.default %D/vpopmail/etc/vlimits.default-dist; then rm -f %D/vpopmail/etc/vlimits.default; fi
vpopmail/etc/vlimits.default-dist
@unexec if [ -f %D/vpopmail/etc/vpopmail.mysql ]; then rm -f %D/vpopmail/etc/vpopmail.mysql; fi