aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail-devel
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2006-11-29 17:38:45 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2006-11-29 17:38:45 +0000
commit4f5a4b258ff941696f24d6c15dfb1e6e52b54cfa (patch)
treea1901a7c90fb2775a16245b060774f842686fcb6 /mail/vpopmail-devel
parent533b150b09b73fa3c907842d5c7dc53615af3ec2 (diff)
downloadports-4f5a4b258ff941696f24d6c15dfb1e6e52b54cfa.tar.gz
ports-4f5a4b258ff941696f24d6c15dfb1e6e52b54cfa.zip
Notes
Diffstat (limited to 'mail/vpopmail-devel')
-rw-r--r--mail/vpopmail-devel/Makefile2
-rw-r--r--mail/vpopmail-devel/pkg-install4
2 files changed, 3 insertions, 3 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index 89c6d104ede4..fd7da041fc72 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -269,7 +269,7 @@ CONFIGURE_ARGS+= --enable-spamassassin=${LOCALBASE}/bin/spamc \
#
pre-configure:
- @PKG_PREFIX=${PREFIX}/vpopmail ${PERL5} ${PKGINSTALL}
+ @PKG_PREFIX=${PREFIX} ${PERL5} ${PKGINSTALL}
.if defined(WITH_PGSQL)
.if defined(WITH_PGSQL_DB)
${REINPLACE_CMD} -E -e "s/(#define DB.*)vpopmail(.*)/\1${WITH_PGSQL_DB}\2/" ${WRKSRC}/vpgsql.h
diff --git a/mail/vpopmail-devel/pkg-install b/mail/vpopmail-devel/pkg-install
index 101602472771..f435231eea4c 100644
--- a/mail/vpopmail-devel/pkg-install
+++ b/mail/vpopmail-devel/pkg-install
@@ -50,7 +50,7 @@ if (! getpwnam ("alias")) {
do checkrpw; # May exit
$x = "-u $uids{'alias'}";
- $result = system ("/usr/sbin/pw useradd alias -g qnofiles -d \"$ENV{PKG_PREFIX}/alias\" -s /nonexistent $x");
+ $result = system ("/usr/sbin/pw useradd alias -g qnofiles -d \"$ENV{PKG_PREFIX}/vpopmail/alias\" -s /nonexistent $x");
if ($result) {
die "Failed to add user alias as uid $uids{'alias'}\n";
}
@@ -61,7 +61,7 @@ foreach $user (keys %users) {
do checkrpw; # May exit
$x = "-u $uids{$user}";
- $result = system ("/usr/sbin/pw useradd $user -g $users{$user} -d \"$ENV{PKG_PREFIX}\" -s /nonexistent $x");
+ $result = system ("/usr/sbin/pw useradd $user -g $users{$user} -d \"$ENV{PKG_PREFIX}/vpopmail\" -s /nonexistent $x");
if ($result) {
die "Failed to add user $user as uid $uids{$user}\n";
}