aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail-stable
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2001-01-29 15:18:28 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2001-01-29 15:18:28 +0000
commit452f0fa690229f23d52d318301b95a6547810cdd (patch)
treea89a595167e628b35592069065635261d3583d13 /mail/vpopmail-stable
parent9f2c6c945e75d1342b446669e5a0aad814f1d196 (diff)
downloadports-452f0fa690229f23d52d318301b95a6547810cdd.tar.gz
ports-452f0fa690229f23d52d318301b95a6547810cdd.zip
Notes
Diffstat (limited to 'mail/vpopmail-stable')
-rw-r--r--mail/vpopmail-stable/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/mail/vpopmail-stable/Makefile b/mail/vpopmail-stable/Makefile
index aa577fe8fde0..f5f37ed80fca 100644
--- a/mail/vpopmail-stable/Makefile
+++ b/mail/vpopmail-stable/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vpopmail
PORTVERSION= 4.9.8
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.inter7.com/vpopmail/
@@ -30,6 +31,7 @@ CONFIGURE_ARGS= --enable-qmail-dir=${QMAIL_DIR} \
# Define these to change from the default behaviour
#
# WITH_PASSWD - allow authentication off /etc/passwd
+# WITH_MYSQL - allow authentitation via mysql
# WITH_APOP - allow apop authentication
# WITHOUT_ROAMING - disallow roaming users
#
@@ -37,6 +39,7 @@ CONFIGURE_ARGS= --enable-qmail-dir=${QMAIL_DIR} \
#
# HARDQUOTA - size of hard quota, or 'n' for no hard quota
# RELAYCLEAR - time in minutes before clearing relay hole (requires roaming)
+# DEFAULT_DOMAIN - default domain for non-vhost lookups
# LOGLEVEL - n - no logging, y - log all,
# e - log errors, p - log passwords in errors
# APOPFILE - location of apop secrets file
@@ -84,6 +87,17 @@ CONFIGURE_ARGS+= --enable-roaming-users=y \
--enable-relay-clear-minutes=${RELAYCLEAR}
.endif
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+= --with-mysql=y \
+ --with-sqlincdir=${LOCALBASE}/include/mysql \
+ --with-sqllibdir=${LOCALBASE}/lib/mysql
+.endif
+
+.if defined(DEFAULT_DOMAIN)
+CONFIGURE_ARGS+= --enable-default-domain=${DEFAULT_DOMAIN}
+.endif
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it