aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-11-03 13:42:16 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-11-03 13:42:16 +0000
commitd4122741f9c7069dd93b2125988abf6cff1512ee (patch)
tree97ede83206f5f9af9325eb8766624046d5f1cb27 /mail/vpopmail/Makefile
parent2c844b2114ec0135ac757407b2729d101fba73f6 (diff)
downloadports-d4122741f9c7069dd93b2125988abf6cff1512ee.tar.gz
ports-d4122741f9c7069dd93b2125988abf6cff1512ee.zip
Notes
Diffstat (limited to 'mail/vpopmail/Makefile')
-rw-r--r--mail/vpopmail/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 98d51a4f888b..61f06c59cdb4 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vpopmail
-PORTVERSION= 5.3.28
+PORTVERSION= 5.3.29
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -61,6 +61,7 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
#
# HARDQUOTA - size of hard quota, or 'n' for no hard quota
# RELAYCLEAR - time in minutes before clearing relay hole (requires roaming)
+# SPAM_THRESHOLD - minimum score required to delete spam messages (requires spamassassin)
# DEFAULT_DOMAIN - default domain for non-vhost lookups
# WITH_SINGLE_DOMAIN - optimize for a site with many users in a single domain
# LOGLEVEL - n - no logging, y - log all,
@@ -115,6 +116,7 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
HARDQUOTA?= 10000000
RELAYCLEAR?= 30
+SPAM_THRESHOLD?=15
LOGLEVEL?= y
.if defined(WITH_MYSQL)
@@ -243,7 +245,8 @@ CONFIGURE_ARGS+= --enable-domainquotas=y
.if defined(WITH_SPAMASSASSIN)
BUILD_DEPENDS= spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin
-CONFIGURE_ARGS+= --enable-spamassassin=${LOCALBASE}/bin/spamc
+CONFIGURE_ARGS+= --enable-spamassassin=${LOCALBASE}/bin/spamc \
+ --enable-spam-threshold=${SPAM_THRESHOLD}
.endif
# autoconf and automake can remove our patches to the configure scripts.