aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2002-02-26 14:54:19 +0000
committerPeter Pentchev <roam@FreeBSD.org>2002-02-26 14:54:19 +0000
commitdf961b0ee195f5b32de129d3fe049cfcba8386c2 (patch)
tree6f19fe2038e166dd4d7b2029c816037e0448a2d9 /mail/vpopmail/Makefile
parent8879e63cc27a860e822639352207837403176642 (diff)
downloadports-df961b0ee195f5b32de129d3fe049cfcba8386c2.tar.gz
ports-df961b0ee195f5b32de129d3fe049cfcba8386c2.zip
Notes
Diffstat (limited to 'mail/vpopmail/Makefile')
-rw-r--r--mail/vpopmail/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 200c3a3917b9..335be4006418 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vpopmail
-PORTVERSION= 5.0.1
+PORTVERSION= 5.2
CATEGORIES= mail
MASTER_SITES= http://www.inter7.com/vpopmail/
@@ -34,8 +34,10 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
# Define these to change from the default behaviour
#
# WITH_PASSWD - allow authentication off /etc/passwd
+# WITH_MD5_PASSWORDS - store encrypted passwords in MD5 format
# WITH_MYSQL - allow authentitation via mysql
# WITH_MYSQL_LARGE_SITE - enables large site layout
+# WITH_CLEAR_PASSWD - store passwords in plaintext into the MySQL db
# WITH_APOP - allow apop authentication
# WITHOUT_ROAMING - disallow roaming users
# WITH_IP_ALIAS - enables IP aliasing
@@ -90,13 +92,17 @@ QMAIL_DIR?= /var/qmail
# Some suggestions from Gabriel Ambuehl <gabriel_ambuehl@buz.ch>
#
-CONFIGURE_ARGS+= --enable-hardquota=${HARDQUOTA} \
+CONFIGURE_ARGS+= --enable-defaultquota=${HARDQUOTA} \
--enable-logging=${LOGLEVEL}
.if defined(WITH_PASSWD)
CONFIGURE_ARGS+= --enable-passwd=y
.endif
+.if defined(WITH_MD5_PASSWORDS)
+CONFIGURE_ARGS+= --enable-md5-passwords=y
+.endif
+
.if defined(WITH_APOP)
CONFIGURE_ARGS+= --enable-apop=y \
--enable-apop-file=${APOPFILE}
@@ -113,6 +119,10 @@ CONFIGURE_ARGS+= --enable-roaming-users=y \
--enable-relay-clear-minutes=${RELAYCLEAR}
.endif
+.if !defined(WITH_CLEAR_PASSWD)
+CONFIGURE_ARGS+= --enable-clear-passwd=n
+.endif
+
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+= --enable-mysql=y \