aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-05 22:10:00 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-05 22:10:00 +0000
commit7cbdf7fde07ca5a62c2a0a4ffcc2a0edd7978055 (patch)
treede30cccd8e49c7b4509b0f41f182d20cdaf2d626 /mail/vpopmail
parent62ca6cce977f7d4e30ae8a13a53ab67efdd42f03 (diff)
downloadports-7cbdf7fde07ca5a62c2a0a4ffcc2a0edd7978055.tar.gz
ports-7cbdf7fde07ca5a62c2a0a4ffcc2a0edd7978055.zip
Notes
Diffstat (limited to 'mail/vpopmail')
-rw-r--r--mail/vpopmail/Makefile54
-rw-r--r--mail/vpopmail/distinfo3
-rw-r--r--mail/vpopmail/files/patch-config.h.in16
-rw-r--r--mail/vpopmail/files/patch-configure105
4 files changed, 85 insertions, 93 deletions
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 07b6bcd1781a..ddf3921a1206 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vpopmail
-PORTVERSION= 5.3.30
-PORTREVISION= 1
+PORTVERSION= 5.4.0
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -61,7 +60,6 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
#
# Set these to the values you'd prefer
#
-# HARDQUOTA - size of hard quota, or 'n' for no hard quota
# RELAYCLEAR - time in minutes before clearing relay hole (requires roaming)
# SPAM_THRESHOLD - minimum score required to delete spam messages (requires spamassassin)
# DEFAULT_DOMAIN - default domain for non-vhost lookups
@@ -122,24 +120,23 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
# WITH_SYBASE_DB - the name of the Sybase database to connect to (vpopmail)
#
-HARDQUOTA?= 10000000
RELAYCLEAR?= 30
SPAM_THRESHOLD?=15
LOGLEVEL?= y
.if defined(WITH_MYSQL)
USE_MYSQL= yes
-CONFIGURE_ARGS+= --enable-mysql=y \
+CONFIGURE_ARGS+= --enable-auth-module=mysql \
--enable-incdir=${LOCALBASE}/include/mysql \
--enable-libdir=${LOCALBASE}/lib/mysql
.if defined(WITH_MYSQL_REPLICATION)
-CONFIGURE_ARGS+= --enable-mysql-replication=y
+CONFIGURE_ARGS+= --enable-mysql-replication
.endif
.if defined(WITH_MYSQL_LOG)
-CONFIGURE_ARGS+= --enable-mysql-logging=y
+CONFIGURE_ARGS+= --enable-mysql-logging
.endif
.if defined(WITH_MYSQL_LIMITS)
-CONFIGURE_ARGS+= --enable-mysql-limits=y
+CONFIGURE_ARGS+= --enable-mysql-limits
.endif
WITH_MYSQL_SERVER?= localhost
@@ -161,10 +158,10 @@ WITH_PGSQL= yes
.if defined(WITH_PGSQL)
POSTGRESQL_PORT?= databases/postgresql-client
LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
-CONFIGURE_ARGS+= --enable-postgres=y
+CONFIGURE_ARGS+= --enable-auth-module=pgsql
.if defined(WITH_PGSQL_LOG)
-CONFIGURE_ARGS+= --enable-pgsql-logging=y
+CONFIGURE_ARGS+= --enable-pgsql-logging
.endif
.endif
@@ -188,15 +185,14 @@ QMAIL_DIR?= /var/qmail
# Some suggestions from Gabriel Ambuehl <gabriel_ambuehl@buz.ch>
#
-CONFIGURE_ARGS+= --enable-defaultquota=${HARDQUOTA} \
- --enable-logging=${LOGLEVEL}
+CONFIGURE_ARGS+= --enable-logging=${LOGLEVEL}
.if defined(WITH_PASSWD)
-CONFIGURE_ARGS+= --enable-passwd=y
+CONFIGURE_ARGS+= --enable-passwd
.endif
.if defined(WITHOUT_MD5_PASSWORDS)
-CONFIGURE_ARGS+= --enable-md5-passwords=n
+CONFIGURE_ARGS+= --disable-md5-passwords
.endif
.if defined(WITH_APOP)
@@ -204,65 +200,65 @@ BROKEN= "The WITH_APOP option is deprecated; set WITH_CLEAR_PASSWD instead, APO
.endif
.if defined(WITH_VALIAS)
-CONFIGURE_ARGS+= --enable-valias=y
+CONFIGURE_ARGS+= --enable-valias
.endif
.if !defined(WITHOUT_ROAMING)
-CONFIGURE_ARGS+= --enable-roaming-users=y \
+CONFIGURE_ARGS+= --enable-roaming-users \
--enable-relay-clear-minutes=${RELAYCLEAR}
.endif
.if !defined(WITH_CLEAR_PASSWD)
-CONFIGURE_ARGS+= --enable-clear-passwd=n
+CONFIGURE_ARGS+= --disable-clear-passwd
.endif
.if defined(WITH_LEARN_PASSWORDS)
-CONFIGURE_ARGS+= --enable-learn-passwords=y
+CONFIGURE_ARGS+= --enable-learn-passwords
.endif
.if defined(WITH_SYBASE)
-CONFIGURE_ARGS+= --enable-sybase=y
+CONFIGURE_ARGS+= --enable-auth-module=sybase
.endif
.if defined(WITH_ORACLE)
WITH_ORACLE_PROC?= proc
-CONFIGURE_ARGS+= --enable-oracle=y
+CONFIGURE_ARGS+= --enable-auth-module=oracle
.endif
.if defined(WITH_SINGLE_DOMAIN)
-CONFIGURE_ARGS+= --enable-many-domains=n
+CONFIGURE_ARGS+= --disable-many-domains
.endif
.if defined(WITH_IP_ALIAS)
-CONFIGURE_ARGS+= --enable-ip-alias-domains=y
+CONFIGURE_ARGS+= --enable-ip-alias-domains
.endif
.if defined(WITH_QMAIL_EXT)
-CONFIGURE_ARGS+= --enable-qmail-ext=y
+CONFIGURE_ARGS+= --enable-qmail-ext
.endif
.if defined(WITHOUT_FILE_LOCKING)
-CONFIGURE_ARGS+= --enable-file-locking=n
+CONFIGURE_ARGS+= --disable-file-locking
.endif
.if defined(WITH_FILE_SYNC)
-CONFIGURE_ARGS+= --enable-file-sync=y
+CONFIGURE_ARGS+= --enable-file-sync
.endif
.if defined(WITHOUT_AUTH_LOG)
-CONFIGURE_ARGS+= --enable-auth-logging=n
+CONFIGURE_ARGS+= --disable-auth-logging
.endif
.if defined(WITHOUT_USERS_BIG_DIR)
-CONFIGURE_ARGS+= --enable-users-big-dir=n
+CONFIGURE_ARGS+= --disable-users-big-dir
.endif
.if defined(WITHOUT_SEEKABLE)
-CONFIGURE_ARGS+= --enable-make-seekable=n
+CONFIGURE_ARGS+= --disable-make-seekable
.endif
.if defined(WITH_DOMAIN_QUOTAS)
-CONFIGURE_ARGS+= --enable-domainquotas=y
+CONFIGURE_ARGS+= --enable-domainquotas
.endif
.if defined(WITH_SPAMASSASSIN)
diff --git a/mail/vpopmail/distinfo b/mail/vpopmail/distinfo
index f7e8b6e0ead1..091795163a59 100644
--- a/mail/vpopmail/distinfo
+++ b/mail/vpopmail/distinfo
@@ -1 +1,2 @@
-MD5 (vpopmail-5.3.30.tar.gz) = 45a87b772bb158468c1c1039f8765965
+MD5 (vpopmail-5.4.0.tar.gz) = 6de751d3794b091a58464fd85f7bc00c
+SIZE (vpopmail-5.4.0.tar.gz) = 418736
diff --git a/mail/vpopmail/files/patch-config.h.in b/mail/vpopmail/files/patch-config.h.in
index be792244bff0..2fd10f54ddb9 100644
--- a/mail/vpopmail/files/patch-config.h.in
+++ b/mail/vpopmail/files/patch-config.h.in
@@ -1,15 +1,15 @@
---- config.h.in.orig Tue Oct 7 03:25:53 2003
-+++ config.h.in Sat Nov 1 10:59:26 2003
-@@ -89,6 +89,12 @@
- #undef QMAILNEWU
+--- config.h.in.orig Mon Feb 2 06:24:19 2004
++++ config.h.in Mon Feb 2 09:33:51 2004
+@@ -238,6 +238,12 @@
+ #undef QMAILDIR
- /* */
+ /* "" */
+#undef SPAMC
+
-+/* */
++/* "" */
+#undef SPAM_THRESHOLD
+
-+/* */
++/* "" */
#undef QMAILINJECT
- /* */
+ /* "" */
diff --git a/mail/vpopmail/files/patch-configure b/mail/vpopmail/files/patch-configure
index 1045f191c5be..d1d1be7e3408 100644
--- a/mail/vpopmail/files/patch-configure
+++ b/mail/vpopmail/files/patch-configure
@@ -1,34 +1,33 @@
---- configure.orig Fri Oct 17 01:12:22 2003
-+++ configure Sat Nov 1 14:01:27 2003
-@@ -20,6 +20,10 @@
- ac_help="$ac_help
- --enable-qmail-newmrh=path Full path to qmail-newmrh program"
- ac_help="$ac_help
-+ --enable-spamassassin=path Enable SpamAssassin. Full path to spamc program. default /usr/local/bin/spamc"
-+ac_help="$ac_help
+--- configure.orig Mon Feb 2 06:24:19 2004
++++ configure Mon Feb 2 10:10:12 2004
+@@ -846,6 +846,8 @@
+ --enable-qmail-newu=PATH Full path to qmail-newu program.
+ --enable-qmail-inject=PATH Full path to qmail-inject program.
+ --enable-qmail-newmrh=PATH Full path to qmail-newmrh program.
++ --enable-spamassassin=PATH Enable SpamAssassin. Full path to spamc program. default /usr/local/bin/spamc"
+ --enable-spam-threshold=# or n Automatically delete messages that score more than # spam hits"
-+ac_help="$ac_help
- --enable-vpopuser=vpopmail user vchkpw was installed as."
- ac_help="$ac_help
- --enable-vpopgroup=vchkpw group vchkpw was installed as."
-@@ -1317,7 +1321,7 @@
- ;;
- esac
+ --enable-vpopuser=USER User name allocated to vpopmail vpopmail.
+ --enable-vpopgroup=GROUP Group name allocated to vpopmail vchkpw.
+ --enable-roaming-users Enable POP-before-SMTP functionality.
+@@ -5097,7 +5099,7 @@
+
+ #----------------------------------------------------------------------
-if test `$idcommand` != "0"
+if false && test `$idcommand` != "0"
then
- echo "configure: warning: === vpopmail must be configured as root. ===" 1>&2
- echo "configure: warning: === please switch to the root user and ===" 1>&2
-@@ -1446,6 +1450,49 @@
- EOF
-
+ { echo "$as_me:$LINENO: WARNING: === vpopmail must be configured as root. ===" >&5
+ echo "$as_me: WARNING: === vpopmail must be configured as root. ===" >&2;}
+@@ -5227,19 +5229,50 @@
+ ;;
+ esac
+# Check whether --enable-spamassassin or --disable-spamassassin was given.
+if test "${enable_spamassassin+set}" = set; then
+ enableval="$enable_spamassassin"
+ spamc="$enableval"
-+
+
+-#----------------------------------------------------------------------
+ case $spamc in
+ 1*|y*|Y*)
+ spamc="/usr/local/bin/spamc"
@@ -51,9 +50,17 @@
+else
+
+ ENABLE_SPAM_THRESHOLD=0
-+
-+fi
-+
+
+-if test ! -d $vpopmaildir/etc
+-then
+- mkdir $vpopmaildir/etc
+- chown $vpopmailuid "$vpopmaildir"/etc
+- chgrp $vpopmailgid "$vpopmaildir"/etc
+- chmod 755 "$vpopmaildir"/etc
+- { echo "$as_me:$LINENO: WARNING: making a vpopmail etc directory " >&5
+-echo "$as_me: WARNING: making a vpopmail etc directory " >&2;}
+ fi
+
+
+case $ENABLE_SPAM_THRESHOLD in
+0*|n*|N*)
@@ -67,41 +74,29 @@
+esac
+fi
+
++
+ #----------------------------------------------------------------------
- vpopuser="vpopmail"
- # Check whether --enable-vpopuser or --disable-vpopuser was given.
-@@ -1601,15 +1648,6 @@
- EOF
-
-
--if test ! -d $vpopmaildir/etc
--then
-- mkdir $vpopmaildir/etc
-- chown $vpopmailuid "$vpopmaildir"/etc
-- chgrp $vpopmailgid "$vpopmaildir"/etc
-- chmod 755 "$vpopmaildir"/etc
-- echo "configure: warning: making a vpopmail etc directory " 1>&2
--fi
--
- # Check whether --enable-roaming-users or --disable-roaming-users was given.
- if test "${enable_roaming_users+set}" = set; then
- enableval="$enable_roaming_users"
-@@ -1671,17 +1709,7 @@
+ echo "$as_me:$LINENO: checking whether we can locate the qmail directory" >&5
+@@ -5705,20 +5738,7 @@
if test "${enable_tcpserver_file+set}" = set; then
enableval="$enable_tcpserver_file"
tcpserver_file="$enableval"
-else
--
-- if test "$tcpserver_file" = ""
-- then
-- echo "127.:allow,RELAYCLIENT=\"\"" > "$vpopmaildir"/etc/tcp.smtp
-- tcpserver_file="$vpopmaildir"/etc/tcp.smtp
--
-- echo "configure: warning: Unable to find your tcpserver relay file." 1>&2
-- echo "configure: warning: Creating tcp.smtp in "$vpopmaildir"/etc/tcp.smtp." 1>&2
-- fi
--
+-
+- if test "$tcpserver_file" = ""
+- then
+- { echo "$as_me:$LINENO: WARNING: Unable to find your tcpserver relay file." >&5
+-echo "$as_me: WARNING: Unable to find your tcpserver relay file." >&2;}
+- { echo "$as_me:$LINENO: WARNING: Creating tcp.smtp in \"$vpopmaildir\"/etc/tcp.smtp." >&5
+-echo "$as_me: WARNING: Creating tcp.smtp in \"$vpopmaildir\"/etc/tcp.smtp." >&2;}
+-
+- echo "127.:allow,RELAYCLIENT=\"\"" > "$vpopmaildir"/etc/tcp.smtp
+- tcpserver_file="$vpopmaildir"/etc/tcp.smtp
+- fi
+-
+-
+ echo "127.:allow,RELAYCLIENT=\"\"" > ${VCFGDIR}/tcp.smtp
- fi
+ fi;
- cat >> confdefs.h <<EOF
+ if test ! -f "$tcpserver_file"