aboutsummaryrefslogtreecommitdiff
path: root/mail/wmmail/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-03-15 01:16:05 +0000
committerSteve Price <steve@FreeBSD.org>1999-03-15 01:16:05 +0000
commitca2d2573b2c1aa38d4856b3600adc7003b078a8c (patch)
tree43e68110d7ce3fb0c2ec3e8a8911e80f6fefec7d /mail/wmmail/Makefile
parent330922136309b5be390bcfc600c9eaf751a180e8 (diff)
downloadports-ca2d2573b2c1aa38d4856b3600adc7003b078a8c.tar.gz
ports-ca2d2573b2c1aa38d4856b3600adc7003b078a8c.zip
Notes
Diffstat (limited to 'mail/wmmail/Makefile')
-rw-r--r--mail/wmmail/Makefile29
1 files changed, 22 insertions, 7 deletions
diff --git a/mail/wmmail/Makefile b/mail/wmmail/Makefile
index cee9b374d673..70245ddfb524 100644
--- a/mail/wmmail/Makefile
+++ b/mail/wmmail/Makefile
@@ -1,20 +1,35 @@
# New ports collection makefile for: wmmail
-# Version required: 0.59
+# Version required: 0.62
# Date created: 7 Jun 1998
# Whom: rom
#
-# $Id: Makefile,v 1.6 1998/11/23 03:29:10 steve Exp $
+# $Id: Makefile,v 1.7 1999/01/18 06:43:00 asami Exp $
#
-DISTNAME= wmmail-0.59
+DISTNAME= WMMail.app-0.62
+PKGNAME= wmmail-0.62
CATEGORIES= mail windowmaker
-MASTER_SITES= http://earth.gaianet.net/~scorpio/
+MASTER_SITES= http://www.eecg.utoronto.ca/~chanb/
MAINTAINER= jim@phrantic.phear.net
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
+ PropList.1:${PORTSDIR}/devel/libPropList
-USE_IMAKE= yes
-MAN1= wmmail.1
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-PL-libs="-L${LOCALBASE}/lib" \
+ --with-PL-incs="-I${LOCALBASE}/include"
+WRKSRC= ${WRKDIR}/WMMail.app-0.62
+USE_X_PREFIX= yes
+
+post-install:
+ @${ECHO} " "
+ @${ECHO} "---------------------------------------------------------------------"
+ @${ECHO} "===> Installing WMMail.defaults in ${PREFIX}/share/doc/WMMail"
+ @${ECHO} "===> Modify to your config and copy to ~/GNUstep/Defaults/WMMail"
+ @${ECHO} "---------------------------------------------------------------------"
+ @${ECHO} " "
+ @${MKDIR} ${PREFIX}/share/doc/WMMail && chmod a+rx ${PREFIX}/share/doc/WMMail
+ ${INSTALL_DATA} ${WRKSRC}/WMMail.defaults ${PREFIX}/share/doc/WMMail
.include <bsd.port.mk>