aboutsummaryrefslogtreecommitdiff
path: root/mail/xfce4-mailwatch-plugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-28 00:10:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-28 00:10:45 +0000
commit335e212107d1aaecc21d14ff37045225ab4c81f0 (patch)
tree8beb714f040b2555ba8c0823ec63026914a0b217 /mail/xfce4-mailwatch-plugin
parent3acfe00bc7f8c72af2d94a1441d3cd19033562d7 (diff)
downloadports-335e212107d1aaecc21d14ff37045225ab4c81f0.tar.gz
ports-335e212107d1aaecc21d14ff37045225ab4c81f0.zip
Notes
Diffstat (limited to 'mail/xfce4-mailwatch-plugin')
-rw-r--r--mail/xfce4-mailwatch-plugin/Makefile28
-rw-r--r--mail/xfce4-mailwatch-plugin/distinfo3
-rw-r--r--mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-gmail.c21
-rw-r--r--mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-imap.c21
-rw-r--r--mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-pop3.c22
-rw-r--r--mail/xfce4-mailwatch-plugin/pkg-descr16
-rw-r--r--mail/xfce4-mailwatch-plugin/pkg-plist53
7 files changed, 164 insertions, 0 deletions
diff --git a/mail/xfce4-mailwatch-plugin/Makefile b/mail/xfce4-mailwatch-plugin/Makefile
new file mode 100644
index 000000000000..bb1cf88c1ba9
--- /dev/null
+++ b/mail/xfce4-mailwatch-plugin/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: mailwatch plugin for xfce4
+# Date created: 23 Januar 2007
+# Whom: Martin Wilke (miwi@FreeBSD.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-mailwatch-plugin
+PORTVERSION= 1.0.1
+CATEGORIES= mail xfce
+MASTER_SITES= http://spuriousinterrupt.org/files/mailwatch/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A mailwatch plugin for xfce
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+INSTALLS_ICONS= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
+USE_XFCE= configenv libgui libutil panel
+USE_XLIB= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/xfce4-mailwatch-plugin/distinfo b/mail/xfce4-mailwatch-plugin/distinfo
new file mode 100644
index 000000000000..639070f1c569
--- /dev/null
+++ b/mail/xfce4-mailwatch-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (xfce4/xfce4-mailwatch-plugin-1.0.1.tar.bz2) = 6b21d2c98c9ba5a35a847a932c5317e0
+SHA256 (xfce4/xfce4-mailwatch-plugin-1.0.1.tar.bz2) = 71aa6a4d625611fb05324a0a9a1a42f396468211b86d92bfa7b0b2c1bd802ee2
+SIZE (xfce4/xfce4-mailwatch-plugin-1.0.1.tar.bz2) = 646502
diff --git a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-gmail.c b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-gmail.c
new file mode 100644
index 000000000000..5b84c3575192
--- /dev/null
+++ b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-gmail.c
@@ -0,0 +1,21 @@
+--- panel-plugin/mailwatch-mailbox-gmail.c.orig Thu Apr 20 11:24:36 2006
++++ panel-plugin/mailwatch-mailbox-gmail.c Sat Jan 27 11:15:51 2007
+@@ -159,10 +159,16 @@
+ gmail_get_sockaddr(XfceMailwatchGMailMailbox *gmailbox, const gchar *host,
+ const gchar *service, struct sockaddr_in *addr)
+ {
+- struct addrinfo hints = { 0, PF_INET, SOCK_STREAM, IPPROTO_TCP,
+- sizeof(struct sockaddr_in), NULL, NULL, NULL };
++ struct addrinfo hints;
+ GError *error = NULL;
+
++ memset(&hints, 0, sizeof(hints));
++
++ hints.ai_flags = 0;
++ hints.ai_family = PF_INET;
++ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
++
+ TRACE("entering (%s, %s, %p)", host, service, addr);
+
+ g_return_val_if_fail(host && service && addr, FALSE);
diff --git a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-imap.c b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-imap.c
new file mode 100644
index 000000000000..3c5d12d21e9a
--- /dev/null
+++ b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-imap.c
@@ -0,0 +1,21 @@
+--- panel-plugin/mailwatch-mailbox-imap.c.orig Thu Apr 20 11:24:36 2006
++++ panel-plugin/mailwatch-mailbox-imap.c Sat Jan 27 11:15:51 2007
+@@ -208,10 +208,16 @@
+ imap_get_sockaddr(XfceMailwatchIMAPMailbox *imailbox, const gchar *host,
+ const gchar *service, struct sockaddr_in *addr)
+ {
+- struct addrinfo hints = { 0, PF_INET, SOCK_STREAM, IPPROTO_TCP,
+- sizeof(struct sockaddr_in), NULL, NULL, NULL };
++ struct addrinfo hints;
+ GError *error = NULL;
+
++ memset(&hints, 0, sizeof(hints));
++
++ hints.ai_flags = 0;
++ hints.ai_family = PF_INET;
++ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
++
+ TRACE("entering (%s, %s, %p)", host, service, addr);
+
+ g_return_val_if_fail(host && service && addr, FALSE);
diff --git a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-pop3.c b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-pop3.c
new file mode 100644
index 000000000000..86022b777a83
--- /dev/null
+++ b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-pop3.c
@@ -0,0 +1,22 @@
+--- panel-plugin/mailwatch-mailbox-pop3.c.orig Thu Apr 20 11:24:36 2006
++++ panel-plugin/mailwatch-mailbox-pop3.c Sat Jan 27 11:15:51 2007
+@@ -176,10 +176,16 @@
+ pop3_get_sockaddr(XfceMailwatchPOP3Mailbox *pmailbox, const gchar *host,
+ const gchar *service, struct sockaddr_in *addr)
+ {
+- struct addrinfo hints = { 0, PF_INET, SOCK_STREAM, IPPROTO_TCP,
+- sizeof(struct sockaddr_in), NULL, NULL, NULL };
++ struct addrinfo hints;
+ GError *error = NULL;
+-
++
++ memset(&hints, 0, sizeof(hints));
++
++ hints.ai_flags = 0;
++ hints.ai_family = PF_INET;
++ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
++
+ TRACE("entering (%s, %s, %p)", host, service, addr);
+
+ g_return_val_if_fail(host && service && addr, FALSE);
diff --git a/mail/xfce4-mailwatch-plugin/pkg-descr b/mail/xfce4-mailwatch-plugin/pkg-descr
new file mode 100644
index 000000000000..4c267751dd22
--- /dev/null
+++ b/mail/xfce4-mailwatch-plugin/pkg-descr
@@ -0,0 +1,16 @@
+Mailwatch is a plugin for the Xfce 4 panel.
+
+Features
+
+ * IMAP and Secure IMAP support
+ * POP3 and Secure POP3 support
+ * Local Mbox mailbox support
+ * Local Maildir mailbox support
+ * Local MH-Maildir mailbox support
+ * GMail support
+ * Fully multithreaded design: no panel lockups
+ * Informative new-message breakdown in tooltip
+ * Ability to run program on new messages or button click
+ * Informative logger to help track down mail connection problems
+
+WWW: http://spuriousinterrupt.org/projects/mailwatch
diff --git a/mail/xfce4-mailwatch-plugin/pkg-plist b/mail/xfce4-mailwatch-plugin/pkg-plist
new file mode 100644
index 000000000000..9acc82039192
--- /dev/null
+++ b/mail/xfce4-mailwatch-plugin/pkg-plist
@@ -0,0 +1,53 @@
+libexec/xfce4/panel-plugins/xfce4-mailwatch-plugin
+share/icons/hicolor/48x48/apps/xfce-newmail.png
+share/icons/hicolor/48x48/apps/xfce-nomail.png
+share/icons/hicolor/scalable/apps/xfce-newmail.svg
+share/icons/hicolor/scalable/apps/xfce-nomail.svg
+share/locale/ca/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/de/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/el/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/eu/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/fi/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/fr/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/gu/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/ja/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/pt_BR/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/ru/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/vi/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/zh_TW/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/xfce4/doc/C/images/mailwatch-gmail-settings.png
+share/xfce4/doc/C/images/mailwatch-imap-advanced.png
+share/xfce4/doc/C/images/mailwatch-imap-new-folders.png
+share/xfce4/doc/C/images/mailwatch-imap-settings.png
+share/xfce4/doc/C/images/mailwatch-log-window.png
+share/xfce4/doc/C/images/mailwatch-mailbox-type.png
+share/xfce4/doc/C/images/mailwatch-maildir-settings.png
+share/xfce4/doc/C/images/mailwatch-mbox-settings.png
+share/xfce4/doc/C/images/mailwatch-mh-settings.png
+share/xfce4/doc/C/images/mailwatch-panel-indicator.png
+share/xfce4/doc/C/images/mailwatch-pop3-advanced.png
+share/xfce4/doc/C/images/mailwatch-pop3-settings.png
+share/xfce4/doc/C/images/mailwatch-properties.png
+share/xfce4/doc/C/xfce4-mailwatch-plugin.html
+share/xfce4/panel-plugins/mailwatch.desktop
+@dirrm share/xfce4/panel-plugins
+@dirrm share/xfce4/doc/C/images
+@dirrm share/xfce4/doc/C
+@dirrm share/xfce4/doc
+@dirrm share/xfce4
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrm share/icons/hicolor/scalable/apps
+@dirrm share/icons/hicolor/scalable
+@dirrm share/icons/hicolor/48x48/apps
+@dirrm share/icons/hicolor/48x48
+@dirrm share/icons/hicolor
+@dirrm share/icons
+@dirrm libexec/xfce4/panel-plugins
+@dirrm libexec/xfce4