aboutsummaryrefslogtreecommitdiff
path: root/mail/xfce4-mailwatch-plugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-23 09:10:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-23 09:10:33 +0000
commit5401ab283a7d910d2100619348571af39d5c1bf8 (patch)
treeb88c54557ac5c22fe1819f71e78301662cc82445 /mail/xfce4-mailwatch-plugin
parent7f1d77f89014572b35660d5354f1fd592d237eb1 (diff)
Notes
Diffstat (limited to 'mail/xfce4-mailwatch-plugin')
-rw-r--r--mail/xfce4-mailwatch-plugin/Makefile5
-rw-r--r--mail/xfce4-mailwatch-plugin/distinfo6
-rw-r--r--mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-gmail.c21
-rw-r--r--mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-imap.c21
-rw-r--r--mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-pop3.c22
-rw-r--r--mail/xfce4-mailwatch-plugin/pkg-plist35
6 files changed, 28 insertions, 82 deletions
diff --git a/mail/xfce4-mailwatch-plugin/Makefile b/mail/xfce4-mailwatch-plugin/Makefile
index 9a6135aa10fc..f7c1c1ee807b 100644
--- a/mail/xfce4-mailwatch-plugin/Makefile
+++ b/mail/xfce4-mailwatch-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xfce4-mailwatch-plugin
-PORTVERSION= 1.0.1
-PORTREVISION= 5
+PORTVERSION= 1.1.0
CATEGORIES= mail xfce
MASTER_SITES= http://spuriousinterrupt.org/files/mailwatch/ \
http://freebsd.unixfreunde.de/sources/
@@ -16,6 +15,8 @@ DIST_SUBDIR= xfce4
MAINTAINER= miwi@FreeBSD.org
COMMENT= A mailwatch plugin for xfce
+LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
+
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
diff --git a/mail/xfce4-mailwatch-plugin/distinfo b/mail/xfce4-mailwatch-plugin/distinfo
index 639070f1c569..66c942caff94 100644
--- a/mail/xfce4-mailwatch-plugin/distinfo
+++ b/mail/xfce4-mailwatch-plugin/distinfo
@@ -1,3 +1,3 @@
-MD5 (xfce4/xfce4-mailwatch-plugin-1.0.1.tar.bz2) = 6b21d2c98c9ba5a35a847a932c5317e0
-SHA256 (xfce4/xfce4-mailwatch-plugin-1.0.1.tar.bz2) = 71aa6a4d625611fb05324a0a9a1a42f396468211b86d92bfa7b0b2c1bd802ee2
-SIZE (xfce4/xfce4-mailwatch-plugin-1.0.1.tar.bz2) = 646502
+MD5 (xfce4/xfce4-mailwatch-plugin-1.1.0.tar.bz2) = f84dce86be1d7f25f169f262aaacee4e
+SHA256 (xfce4/xfce4-mailwatch-plugin-1.1.0.tar.bz2) = ba6fe9fc8d20f317b968369bbc2802c91c4c7838823faee9304767db9f1a3799
+SIZE (xfce4/xfce4-mailwatch-plugin-1.1.0.tar.bz2) = 662624
diff --git a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-gmail.c b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-gmail.c
deleted file mode 100644
index 5b84c3575192..000000000000
--- a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-gmail.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- panel-plugin/mailwatch-mailbox-gmail.c.orig Thu Apr 20 11:24:36 2006
-+++ panel-plugin/mailwatch-mailbox-gmail.c Sat Jan 27 11:15:51 2007
-@@ -159,10 +159,16 @@
- gmail_get_sockaddr(XfceMailwatchGMailMailbox *gmailbox, const gchar *host,
- const gchar *service, struct sockaddr_in *addr)
- {
-- struct addrinfo hints = { 0, PF_INET, SOCK_STREAM, IPPROTO_TCP,
-- sizeof(struct sockaddr_in), NULL, NULL, NULL };
-+ struct addrinfo hints;
- GError *error = NULL;
-
-+ memset(&hints, 0, sizeof(hints));
-+
-+ hints.ai_flags = 0;
-+ hints.ai_family = PF_INET;
-+ hints.ai_socktype = SOCK_STREAM;
-+ hints.ai_protocol = IPPROTO_TCP;
-+
- TRACE("entering (%s, %s, %p)", host, service, addr);
-
- g_return_val_if_fail(host && service && addr, FALSE);
diff --git a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-imap.c b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-imap.c
deleted file mode 100644
index 3c5d12d21e9a..000000000000
--- a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-imap.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- panel-plugin/mailwatch-mailbox-imap.c.orig Thu Apr 20 11:24:36 2006
-+++ panel-plugin/mailwatch-mailbox-imap.c Sat Jan 27 11:15:51 2007
-@@ -208,10 +208,16 @@
- imap_get_sockaddr(XfceMailwatchIMAPMailbox *imailbox, const gchar *host,
- const gchar *service, struct sockaddr_in *addr)
- {
-- struct addrinfo hints = { 0, PF_INET, SOCK_STREAM, IPPROTO_TCP,
-- sizeof(struct sockaddr_in), NULL, NULL, NULL };
-+ struct addrinfo hints;
- GError *error = NULL;
-
-+ memset(&hints, 0, sizeof(hints));
-+
-+ hints.ai_flags = 0;
-+ hints.ai_family = PF_INET;
-+ hints.ai_socktype = SOCK_STREAM;
-+ hints.ai_protocol = IPPROTO_TCP;
-+
- TRACE("entering (%s, %s, %p)", host, service, addr);
-
- g_return_val_if_fail(host && service && addr, FALSE);
diff --git a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-pop3.c b/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-pop3.c
deleted file mode 100644
index 86022b777a83..000000000000
--- a/mail/xfce4-mailwatch-plugin/files/patch-mailwatch-mailbox-pop3.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- panel-plugin/mailwatch-mailbox-pop3.c.orig Thu Apr 20 11:24:36 2006
-+++ panel-plugin/mailwatch-mailbox-pop3.c Sat Jan 27 11:15:51 2007
-@@ -176,10 +176,16 @@
- pop3_get_sockaddr(XfceMailwatchPOP3Mailbox *pmailbox, const gchar *host,
- const gchar *service, struct sockaddr_in *addr)
- {
-- struct addrinfo hints = { 0, PF_INET, SOCK_STREAM, IPPROTO_TCP,
-- sizeof(struct sockaddr_in), NULL, NULL, NULL };
-+ struct addrinfo hints;
- GError *error = NULL;
--
-+
-+ memset(&hints, 0, sizeof(hints));
-+
-+ hints.ai_flags = 0;
-+ hints.ai_family = PF_INET;
-+ hints.ai_socktype = SOCK_STREAM;
-+ hints.ai_protocol = IPPROTO_TCP;
-+
- TRACE("entering (%s, %s, %p)", host, service, addr);
-
- g_return_val_if_fail(host && service && addr, FALSE);
diff --git a/mail/xfce4-mailwatch-plugin/pkg-plist b/mail/xfce4-mailwatch-plugin/pkg-plist
index a7245ea85f66..52531881b1e0 100644
--- a/mail/xfce4-mailwatch-plugin/pkg-plist
+++ b/mail/xfce4-mailwatch-plugin/pkg-plist
@@ -3,17 +3,30 @@ share/icons/hicolor/48x48/apps/xfce-newmail.png
share/icons/hicolor/48x48/apps/xfce-nomail.png
share/icons/hicolor/scalable/apps/xfce-newmail.svg
share/icons/hicolor/scalable/apps/xfce-nomail.svg
+share/locale/ar/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/ca/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/cs/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/de/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/el/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/en_GB/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/eu/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/fi/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/fr/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/gl/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/gu/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/he/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/hu/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/id/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/it/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/ja/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/nb_NO/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/pt_BR/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/pt_PT/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/ru/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/sq/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/uk/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/vi/LC_MESSAGES/xfce4-mailwatch-plugin.mo
+share/locale/zh_CN/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/locale/zh_TW/LC_MESSAGES/xfce4-mailwatch-plugin.mo
share/xfce4/doc/C/images/mailwatch-gmail-settings.png
share/xfce4/doc/C/images/mailwatch-imap-advanced.png
@@ -30,16 +43,12 @@ share/xfce4/doc/C/images/mailwatch-pop3-settings.png
share/xfce4/doc/C/images/mailwatch-properties.png
share/xfce4/doc/C/xfce4-mailwatch-plugin.html
share/xfce4/panel-plugins/mailwatch.desktop
-@dirrm share/xfce4/panel-plugins
-@dirrm share/xfce4/doc/C/images
-@dirrm share/xfce4/doc/C
-@dirrm share/xfce4/doc
-@dirrm share/xfce4
-@dirrm share/icons/hicolor/scalable/apps
-@dirrm share/icons/hicolor/scalable
-@dirrm share/icons/hicolor/48x48/apps
-@dirrm share/icons/hicolor/48x48
-@dirrm share/icons/hicolor
-@dirrm share/icons
-@dirrm libexec/xfce4/panel-plugins
-@dirrm libexec/xfce4
+@dirrmtry share/xfce4/panel-plugins
+@dirrmtry share/xfce4/doc/C/images
+@dirrmtry share/xfce4/doc/C
+@dirrmtry share/xfce4/doc
+@dirrmtry share/xfce4
+@dirrmtry share/locale/nb_NO/LC_MESSAGES
+@dirrmtry share/locale/nb_NO
+@dirrmtry libexec/xfce4/panel-plugins
+@dirrmtry libexec/xfce4