aboutsummaryrefslogtreecommitdiff
path: root/mail/xfmail
diff options
context:
space:
mode:
authorMike Heffner <mikeh@FreeBSD.org>2001-07-03 01:20:09 +0000
committerMike Heffner <mikeh@FreeBSD.org>2001-07-03 01:20:09 +0000
commitb72c39c55987d12de2fe4500eddd9bef703aebc1 (patch)
tree7ea9b7fd5f035911effeb7a65e8d2f8d3d20b809 /mail/xfmail
parentb219be74cbba54eaae08a76250c628d01f45a5d5 (diff)
downloadports-b72c39c55987d12de2fe4500eddd9bef703aebc1.tar.gz
ports-b72c39c55987d12de2fe4500eddd9bef703aebc1.zip
Notes
Diffstat (limited to 'mail/xfmail')
-rw-r--r--mail/xfmail/Makefile26
-rw-r--r--mail/xfmail/distinfo2
-rw-r--r--mail/xfmail/files/patch-aa41
-rw-r--r--mail/xfmail/files/patch-ab18
-rw-r--r--mail/xfmail/files/patch-ac8
-rw-r--r--mail/xfmail/files/patch-ad53
-rw-r--r--mail/xfmail/files/patch-ae11
-rw-r--r--mail/xfmail/pkg-descr21
-rw-r--r--mail/xfmail/pkg-plist40
9 files changed, 202 insertions, 18 deletions
diff --git a/mail/xfmail/Makefile b/mail/xfmail/Makefile
index 6ed6ccc0b685..aa2131ad3a1f 100644
--- a/mail/xfmail/Makefile
+++ b/mail/xfmail/Makefile
@@ -6,19 +6,31 @@
#
PORTNAME= xfmail
-PORTVERSION= 1.4.0
+PORTVERSION= 1.5.0
CATEGORIES= mail
-MASTER_SITES= ftp://xfmail.ufies.org/pub/xfmail/release/old/1.4.0/
+MASTER_SITES= ftp://xfmail.ufies.org/pub/xfmail/release/%SUBDIR%/ \
+ ftp://cupido.geophys.nat.tu-bs.de/pub/xfmail/release/%SUBDIR%/ \
+ ftp://cfreeze.ufies.org/pub/xfmail/release/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}/source/
-MAINTAINER= gena@NetVision.net.il
+MAINTAINER= mikeh@FreeBSD.org
-LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.0:${PORTSDIR}/x11-toolkits/xforms \
+ gdbm.2:${PORTSDIR}/databases/gdbm
+USE_AUTOMAKE= yes
USE_BZIP2= yes
+USE_GLIB= yes
+USE_GMAKE= yes
USE_X_PREFIX= yes
USE_XPM= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-dead-keys --with-xkb-dead-keys
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --with-dbm-lib=gdbm
MAN1= xfmail.1
-.include <bsd.port.mk>
+pre-configure:
+ @cd ${WRKSRC} && ${SH} autogen.sh
+
+.include <bsd.port.post.mk>
diff --git a/mail/xfmail/distinfo b/mail/xfmail/distinfo
index e7eeb222c3e5..e0e2829a78dc 100644
--- a/mail/xfmail/distinfo
+++ b/mail/xfmail/distinfo
@@ -1 +1 @@
-MD5 (xfmail-1.4.0.tar.bz2) = a22a88ba109689d11d91c14bf3d02d3f
+MD5 (xfmail-1.5.0.tar.bz2) = 37bb5492c8b65a21922074d4e29ab027
diff --git a/mail/xfmail/files/patch-aa b/mail/xfmail/files/patch-aa
new file mode 100644
index 000000000000..9265921efd56
--- /dev/null
+++ b/mail/xfmail/files/patch-aa
@@ -0,0 +1,41 @@
+--- configure.in.orig Sun Jun 3 17:07:35 2001
++++ configure.in Sun Jun 24 22:59:18 2001
+@@ -10,7 +10,6 @@
+
+ dnl Checks for programs.
+ AC_SUBST(CC)
+-AC_SUBST_FILE(debug_frag)
+ AC_PROG_CC
+ AC_PROG_CXX
+ AC_PROG_RANLIB
+@@ -19,9 +18,6 @@
+
+ AM_PROG_LIBTOOL
+
+-ALL_LINGUAS=""
+-AM_GNU_GETTEXT
+-
+ dnl Set which project we are building
+ AC_DEFINE(XFMAIL)
+ AM_CONDITIONAL(BUILD_ARCHIMEDES, test "xfmail" = "archimedes")
+@@ -227,6 +223,9 @@
+ dnl Get/Set Compile Info
+ INFO()
+
++CFLAGS="$CFLAGS -I/usr/local/include"
++CXXFLAGS="$CXXFLAGS -I/usr/local/include"
++
+ AC_OUTPUT(Makefile
+ src/include/version.h
+ src/Makefile
+@@ -236,10 +235,8 @@
+ src/editor/Makefile
+ src/ui/Makefile
+ src/regex/Makefile
+-intl/Makefile
+ data/Makefile
+ man/Makefile
+-po/Makefile
+ contrib/Makefile
+ contrib/misc/build.sh
+ contrib/misc/Rules2Procmail.pl
diff --git a/mail/xfmail/files/patch-ab b/mail/xfmail/files/patch-ab
new file mode 100644
index 000000000000..9c6039557c50
--- /dev/null
+++ b/mail/xfmail/files/patch-ab
@@ -0,0 +1,18 @@
+--- autogen.sh.orig Mon Feb 5 17:40:21 2001
++++ autogen.sh Mon Jun 25 01:02:54 2001
+@@ -42,15 +42,4 @@
+ automake --gnu --add-missing
+ cd "$THEDIR"
+
+-if test -z "$*"; then
+- echo "I am going to run ./configure with no arguments - if you wish "
+- echo "to pass any to it, please specify them on the $0 command line."
+-fi
+-
+-$srcdir/configure "$@"
+ cd $srcdir/src/ui && ./help_gen
+-
+-echo
+-echo "Now type 'make' to compile xfmail."
+-echo "If you have problems, please see the directory docs/"
+-echo "for possible resolutions."
diff --git a/mail/xfmail/files/patch-ac b/mail/xfmail/files/patch-ac
new file mode 100644
index 000000000000..125f032f50e5
--- /dev/null
+++ b/mail/xfmail/files/patch-ac
@@ -0,0 +1,8 @@
+--- Makefile.am.orig Sat Jun 2 22:11:34 2001
++++ Makefile.am Sun Jun 24 22:59:18 2001
+@@ -1,4 +1,4 @@
+-SUBDIRS = src intl data man po
++SUBDIRS = src data man
+
+ DIST_SUBDIRS = $(SUBDIRS) contrib
+
diff --git a/mail/xfmail/files/patch-ad b/mail/xfmail/files/patch-ad
new file mode 100644
index 000000000000..9eae2dcd731f
--- /dev/null
+++ b/mail/xfmail/files/patch-ad
@@ -0,0 +1,53 @@
+--- src/editor/Makefile.am.orig Tue Feb 6 16:31:19 2001
++++ src/editor/Makefile.am Sun Jun 24 22:59:18 2001
+@@ -9,12 +9,14 @@
+ INCLUDES = -I$(top_srcdir)/src/mail
+
+ CFLAGS = \
++ @CFLAGS@ \
+ @DMALLOC_CFLAGS@ \
+ @DEBUG_CFLAGS@ \
+ @GLIB_CFLAGS@
+
+
+ CXXFLAGS = \
++ @CXXFLAGS@ \
+ @DMALLOC_CFLAGS@ \
+ @DEBUG_CFLAGS@ \
+ @GLIB_CFLAGS@
+--- src/mail/Makefile.am.orig Sat Mar 31 01:52:33 2001
++++ src/mail/Makefile.am Sun Jun 24 22:59:18 2001
+@@ -42,6 +42,7 @@
+ util.cpp
+
+ CFLAGS = \
++ @CFLAGS@ \
+ @REGEX_CFLAGS@ \
+ @FACES_CFLAGS@ \
+ @GLIB_CFLAGS@ \
+@@ -50,6 +51,7 @@
+ @DEBUG_CFLAGS@
+
+ CXXFLAGS = \
++ @CXXFLAGS@ \
+ @REGEX_CFLAGS@ \
+ @FACES_CFLAGS@ \
+ @GLIB_CFLAGS@ \
+--- src/ui/Makefile.am.orig Sun Mar 25 19:35:02 2001
++++ src/ui/Makefile.am Sun Jun 24 22:59:18 2001
+@@ -48,6 +48,7 @@
+
+
+ CFLAGS = \
++ @CFLAGS@ \
+ @REGEX_CFLAGS@ \
+ @FACES_CFLAGS@ \
+ @SOUND_CFLAGS@ \
+@@ -57,6 +58,7 @@
+
+
+ CXXFLAGS = \
++ @CXXFLAGS@ \
+ @REGEX_CFLAGS@ \
+ @FACES_CFLAGS@ \
+ @SOUND_CFLAGS@ \
diff --git a/mail/xfmail/files/patch-ae b/mail/xfmail/files/patch-ae
new file mode 100644
index 000000000000..c65c0ebc98c9
--- /dev/null
+++ b/mail/xfmail/files/patch-ae
@@ -0,0 +1,11 @@
+--- macros/debug.m4.orig Thu Feb 22 17:34:16 2001
++++ macros/debug.m4 Sun Jun 24 22:59:18 2001
+@@ -15,7 +15,7 @@
+ ,
+ AC_MSG_RESULT(no)
+ dnl Kovi, don't hate me... :)
+- DEBUG_CFLAGS="-O3 -fomit-frame-pointer -pipe -ffast-math"
++ DEBUG_CFLAGS=""
+ )
+ AC_SUBST(DEBUG_CFLAGS)
+ ])
diff --git a/mail/xfmail/pkg-descr b/mail/xfmail/pkg-descr
index 3b87d4868299..a12d64dd2cb3 100644
--- a/mail/xfmail/pkg-descr
+++ b/mail/xfmail/pkg-descr
@@ -1,14 +1,15 @@
-XF-Mail is X-Windows application for receiving electronic
-mail. It was created using XForms library toolkit by T.C. Zhao
-and Mark Overmars.
+XF-Mail is X-Windows application for receiving electronic mail. It was
+created using XForms library toolkit by T.C. Zhao and Mark Overmars.
-It's partially compatible with MH style mail-
-boxes but it does not require any mh tools to be installed
-on the system. You can read most of your MH folders and messages
-with XF-Mail.
+It's partially compatible with MH style mail boxes but it does not
+require any MH tools to be installed on the system. You can read most
+of your MH folders and messages with XF-Mail.
-XF-Mail has very friendly user interface and it's extremely easy
-in use. It implements most of the mail functionality in one program
-and it does not require any additional tools.
+XF-Mail has very friendly user interface and it's extremely easy in
+use. It implements most of the mail functionality in one program and
+it does not require any additional tools.
WWW: http://xfmail.slappy.org/
+
+- Mike
+mikeh@FreeBSD.org
diff --git a/mail/xfmail/pkg-plist b/mail/xfmail/pkg-plist
index 7aba9cbe434c..091f61a0af64 100644
--- a/mail/xfmail/pkg-plist
+++ b/mail/xfmail/pkg-plist
@@ -1 +1,41 @@
bin/xfmail
+lib/libeditor.a
+lib/libeditor.la
+lib/libeditor.so
+lib/libeditor.so.0
+lib/libmail.a
+lib/libmail.la
+lib/libmail.so
+lib/libmail.so.0
+share/xfmail/abook.xpm
+share/xfmail/abort.xpm
+share/xfmail/attach.xpm
+share/xfmail/delete.xpm
+share/xfmail/delsign.xpm
+share/xfmail/edit.xpm
+share/xfmail/exit.xpm
+share/xfmail/forward.xpm
+share/xfmail/gena.xpm
+share/xfmail/help.xpm
+share/xfmail/icon_mail.xpm
+share/xfmail/icon_nomail.xpm
+share/xfmail/insert.xpm
+share/xfmail/insorig.xpm
+share/xfmail/mail_edit.xpm
+share/xfmail/mailcur.xbm
+share/xfmail/mailcur_mask.xbm
+share/xfmail/move.xpm
+share/xfmail/newmail.xpm
+share/xfmail/next.xpm
+share/xfmail/nextu.xpm
+share/xfmail/prev.xpm
+share/xfmail/prevu.xpm
+share/xfmail/print.xpm
+share/xfmail/reply.xpm
+share/xfmail/retr.xpm
+share/xfmail/save.xpm
+share/xfmail/send.xpm
+share/xfmail/sign.xpm
+share/xfmail/spell.xpm
+share/xfmail/view.xpm
+@dirrm share/xfmail