aboutsummaryrefslogtreecommitdiff
path: root/mail/zmailer
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2007-08-14 16:53:01 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2007-08-14 16:53:01 +0000
commit6022a187989762257db83b1da4a2ca95d9f7258b (patch)
treeeafdb2b77054e4c8cb7fc98444755efa593ede25 /mail/zmailer
parent0d50879922147d772fa5ed1946270f3bed8dadc6 (diff)
downloadports-6022a187989762257db83b1da4a2ca95d9f7258b.tar.gz
ports-6022a187989762257db83b1da4a2ca95d9f7258b.zip
Notes
Diffstat (limited to 'mail/zmailer')
-rw-r--r--mail/zmailer/Makefile64
-rw-r--r--mail/zmailer/distinfo6
-rw-r--r--mail/zmailer/files/patch-EAI_NODATA37
-rw-r--r--mail/zmailer/files/patch-aa34
-rw-r--r--mail/zmailer/files/patch-ab10
-rw-r--r--mail/zmailer/files/patch-include-libz.h10
-rw-r--r--mail/zmailer/files/patch-proto::post-install.sh.in11
-rw-r--r--mail/zmailer/files/patch-smtpserver-smtpetrn.c11
-rw-r--r--mail/zmailer/files/patch-transports-smtp-smtp.h12
-rw-r--r--mail/zmailer/files/zmailer.sh.in61
-rw-r--r--mail/zmailer/files/zmailer.sh.sample23
-rw-r--r--mail/zmailer/pkg-message12
-rw-r--r--mail/zmailer/pkg-plist12
13 files changed, 83 insertions, 220 deletions
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index f64ec22a2542..a9466d15d3ee 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= zmailer
-PORTVERSION= 2.99.56
+PORTVERSION= 2.99.57
CATEGORIES= mail
MASTER_SITES= ftp://ftp.funet.fi/pub/unix/mail/zmailer/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sem@FreeBSD.org
COMMENT= A fully functional fast, robust SMTP server and transport agent
CONFLICTS= courier-0.* postfix-1.* postfix-2.* sendmail-8.* sendmail-*-8.* smail-3.*
@@ -26,10 +26,6 @@ CONFIGURE_ARGS= --without-openssl
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
CONFIGURE_ARGS+=--prefix=${PREFIX}/ \
--with-mailbin=${PREFIX}/sbin \
--with-mailbox=/var/mail \
@@ -56,29 +52,18 @@ MAN8= hold.8zm router.8zm scheduler.8zm sendmail.8zm sm.8zm smtp.8zm \
smtpserver.8zm mprobe.8zm expirer.8zm errormail.8zm mailbox.8zm \
manual-expirer.8zm manual-rerouter.8zm reroute.8zm
-PKGMESSAGE= ${WRKDIR}/MESSAGE
+SUB_FILES= pkg-install
PKGINSTALL= ${WRKDIR}/pkg-install
+USE_RC_SUBR= zmailer.sh
-# local variable
-# this pipe is run before bsd.port.mk is brought in - therefore it is
-# not possible to use ${SED}
-DOMAIN!= /bin/hostname | /usr/bin/sed -e "s:^"`/bin/hostname -s`\.*::g
+# local variable (we can't use ${SED} here)
+DOMAIN!= /bin/hostname | ${SED} -e "s:^"`/bin/hostname -s`"\.*::g"
.if (${DOMAIN} == "")
DOMAIN= "mydomain.com"
.endif
-post-configure:
- ${SED} -e s:@PREFIX@:${PREFIX}:g -e s:@PORTSDIR@:${PORTSDIR}:g \
- ${PKGDIR}/pkg-message > ${PKGMESSAGE}
-
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/zmailer.sh.sample \
- ${PREFIX}/etc/rc.d/zmailer.sh.sample
-
- @${SED} -e 's,%%PREFIX%%,${PREFIX},' ${FILESDIR}/pkg-install.in > \
- ${PKGINSTALL}
@${SETENV} PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
# set up the initial mail.conf with reasonable settings.
@${ECHO_CMD} "# Where am I?" > ${PREFIX}/etc/zmailer/mail.conf.sample
@${ECHO_CMD} "orgdomain="${DOMAIN} >> ${PREFIX}/etc/zmailer/mail.conf.sample
@@ -86,41 +71,6 @@ post-install:
@${ECHO_CMD} "hostname="`/bin/hostname -s`'.$$orgdomain' >> ${PREFIX}/etc/zmailer/mail.conf.sample
@${ECHO_CMD} "# Who do I claim to be?" >> ${PREFIX}/etc/zmailer/mail.conf.sample
@${ECHO_CMD} 'mydomain=$$orgdomain' >> ${PREFIX}/etc/zmailer/mail.conf.sample
-
-# obtained directly from ports/mail/postfix
-# with minor hacks by the originator of this port <veers@disturbed.net>
-replace:
- @${ECHO_MSG} "===> Replacing sendmail"
- @if [ -e /usr/sbin/sendmail ]; then \
- ${MV} -f /usr/sbin/sendmail /usr/sbin/sendmail.OFF; \
- ${CHMOD} 0 /usr/sbin/sendmail.OFF; \
- fi
- @if [ -e ${PREFIX}/sbin/sendmail ]; then \
- ${LN} -s ${PREFIX}/sbin/sendmail /usr/sbin/sendmail; \
- fi
- @${ECHO_MSG} "===> Replacing mailq"
- @if [ -e /usr/bin/mailq ]; then \
- ${MV} -f /usr/bin/mailq /usr/bin/mailq.OFF; \
- ${CHMOD} 0 /usr/bin/mailq.OFF; \
- fi
- @if [ -e ${PREFIX}/sbin/mailq ]; then \
- ${LN} -s ${PREFIX}/sbin/mailq /usr/bin/mailq; \
- fi
- @${ECHO_MSG} "===> Replacing newaliases"
- @if [ -e /usr/bin/newaliases ]; then \
- ${MV} -f /usr/bin/newaliases /usr/bin/newaliases.OFF; \
- ${CHMOD} 0 /usr/bin/newaliases.OFF; \
- fi
- @if [ -e ${PREFIX}/sbin/newaliases ]; then \
- ${LN} -s ${PREFIX}/sbin/newaliases /usr/bin/newaliases; \
- fi
- @${ECHO_MSG} "===> Replacing rmail"
- @if [ -e /bin/rmail ]; then \
- ${MV} -f /bin/rmail /bin/rmail.OFF; \
- ${CHMOD} 0 /bin/rmail.OFF; \
- fi
- @if [ -e ${PREFIX}/sbin/rmail ]; then \
- ${LN} -s ${PREFIX}/sbin/rmail /bin/rmail; \
- fi
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/mail/zmailer/distinfo b/mail/zmailer/distinfo
index b6d752753f03..0c13b3819b05 100644
--- a/mail/zmailer/distinfo
+++ b/mail/zmailer/distinfo
@@ -1,3 +1,3 @@
-MD5 (zmailer-2.99.56.tar.gz) = c94cc0c2e2427a210a046a02ac4c2d50
-SHA256 (zmailer-2.99.56.tar.gz) = 7a5e6c051fc9c9bdf9774fe9ce11871105d20f569e61bdc8da222a1ff587678d
-SIZE (zmailer-2.99.56.tar.gz) = 5926859
+MD5 (zmailer-2.99.57.tar.gz) = abe451575234ac5ce79d9b950b150986
+SHA256 (zmailer-2.99.57.tar.gz) = 74b878138d82c765174c44250a7789b15c70a1d0fc39bddd096cd4147ed5a115
+SIZE (zmailer-2.99.57.tar.gz) = 5521100
diff --git a/mail/zmailer/files/patch-EAI_NODATA b/mail/zmailer/files/patch-EAI_NODATA
deleted file mode 100644
index b42624c6e7fd..000000000000
--- a/mail/zmailer/files/patch-EAI_NODATA
+++ /dev/null
@@ -1,37 +0,0 @@
---- smtpserver/mxverify.c.orig Fri Apr 16 15:45:46 2004
-+++ smtpserver/mxverify.c Fri Apr 16 15:46:38 2004
-@@ -607,7 +607,6 @@
- if (retmode == '+') {
- if (rc == -EX_NOHOST ||
- rc == -EX_UNAVAILABLE ||
-- rc == EAI_NODATA ||
- rc == EAI_NONAME)
- return -2; /* Definitely hard errors */
- if (rc == 2)
---- transports/smtp/smtp.c.orig Fri Apr 16 15:48:44 2004
-+++ transports/smtp/smtp.c Fri Apr 16 15:54:18 2004
-@@ -2912,6 +2912,7 @@
- return EX_DEFERALL;
- }
-
-+#if 0 /* FreeBSD 5.x doesn't have it */
- if ( r == EAI_NODATA ) {
- sprintf(SS->remotemsg,"smtp; 500 (getaddrinfo<%.200s>: No data)",host);
- time(&endtime);
-@@ -2925,6 +2926,7 @@
- return EX_DEFERALL;
- return EX_UNAVAILABLE;
- }
-+#endif
-
- r = EX_UNAVAILABLE; /* This gives instant rejection */
- if (rc == EX_TEMPFAIL) r = rc;
-@@ -2944,7 +2946,7 @@
- if (r != EX_TEMPFAIL)
- r = EX_NOHOST;
- #endif
-- } else if (gai_err == EAI_NONAME || gai_err == EAI_NODATA) {
-+ } else if (gai_err == EAI_NONAME) {
- sprintf(SS->remotemsg,
- "smtp; 500 (nameserver data inconsistency. No MX, no address: '%.200s' (%s))",
- host, gai_err == EAI_NONAME ? "NONAME" : "NODATA");
diff --git a/mail/zmailer/files/patch-aa b/mail/zmailer/files/patch-aa
deleted file mode 100644
index 7a83abb03cf9..000000000000
--- a/mail/zmailer/files/patch-aa
+++ /dev/null
@@ -1,34 +0,0 @@
---- configure.orig Fri Dec 26 10:29:15 2003
-+++ configure Fri Dec 26 10:33:26 2003
-@@ -280,6 +280,7 @@
- # Factoring default headers for most tests.
- ac_includes_default="\
- #include <stdio.h>
-+#include <sys/param.h>
- #if HAVE_SYS_TYPES_H
- # include <sys/types.h>
- #endif
-@@ -20317,7 +20318,7 @@
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-
--#include <sys/types.h>
-+#include <sys/param.h>
- #include <sys/mount.h>
- #include <sys/fs_types.h>
- int
-@@ -20493,6 +20494,7 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-+#include <sys/param.h>
- #include <sys/mount.h>
-
- _ACEOF
-@@ -20539,5 +20541,6 @@
- /* end confdefs.h. */
-
- #include <sys/fs_types.h>
-+#include <sys/param.h>
- #include <sys/mount.h>
- _ACEOF
diff --git a/mail/zmailer/files/patch-ab b/mail/zmailer/files/patch-ab
deleted file mode 100644
index f167d88b90db..000000000000
--- a/mail/zmailer/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- transports/smtp/getmxrr.c.orig Mon Jun 23 12:04:35 2003
-+++ transports/smtp/getmxrr.c Fri Dec 26 11:30:58 2003
-@@ -416,7 +416,6 @@
- break;
- case EAI_NONAME:
- case EAI_FAIL:
-- case EAI_NODATA:
- case EAI_SERVICE:
- default:
- break;
diff --git a/mail/zmailer/files/patch-include-libz.h b/mail/zmailer/files/patch-include-libz.h
new file mode 100644
index 000000000000..e55f8fe9d276
--- /dev/null
+++ b/mail/zmailer/files/patch-include-libz.h
@@ -0,0 +1,10 @@
+--- include/libz.h.orig Tue Aug 14 13:23:53 2007
++++ include/libz.h Tue Aug 14 13:29:34 2007
+@@ -53,6 +53,7 @@
+
+ /* dottedquad.c */
+ #ifdef HAVE_NETINET_IN_H
++# include <sys/socket.h>
+ # include <netinet/in.h>
+ #endif
+ #ifdef IN_CLASSA
diff --git a/mail/zmailer/files/patch-proto::post-install.sh.in b/mail/zmailer/files/patch-proto::post-install.sh.in
deleted file mode 100644
index c352a1a9bbbd..000000000000
--- a/mail/zmailer/files/patch-proto::post-install.sh.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- proto/post-install.sh.in.orig Fri Apr 16 12:45:45 2004
-+++ proto/post-install.sh.in Fri Apr 16 12:46:00 2004
-@@ -373,7 +373,7 @@
- ", $POSTOFFICE);
-
- if (! -d "$POSTOFFICE/.") {
-- mymysystem("$MKDIR -p $POSTOFFICE");
-+ mysystem("$MKDIR -p $POSTOFFICE");
-
- }
- mysystem("chmod 2755 $POSTOFFICE/.");
diff --git a/mail/zmailer/files/patch-smtpserver-smtpetrn.c b/mail/zmailer/files/patch-smtpserver-smtpetrn.c
deleted file mode 100644
index e81d603f331f..000000000000
--- a/mail/zmailer/files/patch-smtpserver-smtpetrn.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- smtpserver/smtpetrn.c.orig Sun Sep 24 14:05:20 2006
-+++ smtpserver/smtpetrn.c Sun Sep 24 14:06:45 2006
-@@ -21,6 +21,8 @@
-
- #ifndef HAVE_OPENSSL
- #include "md5.h"
-+#else
-+#include <openssl/md5.h>
- #endif /* --HAVE_OPENSSL */
-
- static int local_etrn(SS, name, cp, silence)
diff --git a/mail/zmailer/files/patch-transports-smtp-smtp.h b/mail/zmailer/files/patch-transports-smtp-smtp.h
deleted file mode 100644
index 53b9a640e87d..000000000000
--- a/mail/zmailer/files/patch-transports-smtp-smtp.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- transports/smtp/smtp.h.orig Sun Sep 24 14:10:22 2006
-+++ transports/smtp/smtp.h Sun Sep 24 14:10:56 2006
-@@ -69,6 +69,9 @@
- #include <netinet/tcp.h>
- #endif
-
-+#include <sys/types.h>
-+#include <openssl/md5.h>
-+
- #ifndef NFDBITS
- /*
- * This stuff taken from the 4.3bsd /usr/include/sys/types.h, but on the
diff --git a/mail/zmailer/files/zmailer.sh.in b/mail/zmailer/files/zmailer.sh.in
new file mode 100644
index 000000000000..1ea089fc7cf7
--- /dev/null
+++ b/mail/zmailer/files/zmailer.sh.in
@@ -0,0 +1,61 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: mail
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable zmailer:
+#
+#zmailer_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=zmailer
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/zmailer
+required_files=%%PREFIX%%/etc/zmailer/mail.conf
+
+start_precmd=start_precmd
+start_cmd=start_cmd
+stop_cmd=stop_cmd
+
+start_precmd()
+{
+ case $sendmail_enable in
+ [Yy][Ee][Ss]|[Tt][Rr][Uu][Ee]|[Oo][Nn]|1)
+ warn "sendmail_enable should be set to NONE"
+ ;;
+ [Nn][Oo]|[Ff][Aa][Ll][Ss][Ee]|[Oo][Ff][Ff]|0)
+ case $sendmail_submit_enable in
+ [Yy][Ee][Ss]|[Tt][Rr][Uu][Ee]|[Oo][Nn]|1)
+ warn "sendmail_submit_enable should be set to NO"
+ ;;
+ esac
+ ;;
+ [Nn][Oo][Nn][Ee])
+ ;;
+ esac
+}
+
+start_cmd()
+{
+ $command start
+}
+
+stop_cmd()
+{
+ $command stop
+}
+
+# set defaults
+
+zmailer_enable=${zmailer_enable:-"NO"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/mail/zmailer/files/zmailer.sh.sample b/mail/zmailer/files/zmailer.sh.sample
deleted file mode 100644
index 63cc33d27277..000000000000
--- a/mail/zmailer/files/zmailer.sh.sample
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-case "$1" in
-start)
- [ -x ${PREFIX}/sbin/zmailer ] && \
- ${PREFIX}/sbin/zmailer start >/dev/null 2>&1 && \
- echo -n ' zmailer'
- ;;
-stop)
- # just a wild guess
- # ${PREFIX}/sbin/zmailer stop && echo -n ' zmailer'
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
-
-exit 0
diff --git a/mail/zmailer/pkg-message b/mail/zmailer/pkg-message
deleted file mode 100644
index 23574568b7df..000000000000
--- a/mail/zmailer/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-Please note that to automatically replace the existing MTA, use the port
-framework of this package:
-
- cd @PORTSDIR@/mail/zmailer && make replace
-
-This will prepare ZMailer for initial configuration and replace your existing
-transport agent.
-
-Also please note that a "make world" will sever the proper links for
-/usr/sbin/sendmail, /usr/bin/mailq and the likes. If you wish to not build
-sendmail as part of a "make world", add NO_SENDMAIL to the build environment.
-You may do this in /etc/make.conf.
diff --git a/mail/zmailer/pkg-plist b/mail/zmailer/pkg-plist
index 6c68820112df..bbf648010900 100644
--- a/mail/zmailer/pkg-plist
+++ b/mail/zmailer/pkg-plist
@@ -53,7 +53,6 @@ etc/zmailer/forms/proto/loopexceeded.md5
etc/zmailer/forms/proto/nonewsgroup.md5
etc/zmailer/forms/proto/norealname.md5
etc/zmailer/forms/proto/norecipients.md5
-etc/zmailer/forms/proto/nosuchuser.md5
etc/zmailer/forms/proto/unresolvable.md5
etc/zmailer/forms/proto/vms-in-pros.md5
etc/zmailer/forms/proto/wrongname.md5
@@ -71,7 +70,6 @@ etc/zmailer/forms/loopexceeded
etc/zmailer/forms/nonewsgroup
etc/zmailer/forms/norealname
etc/zmailer/forms/norecipients
-etc/zmailer/forms/nosuchuser
etc/zmailer/forms/unresolvable
etc/zmailer/forms/vms-in-pros
etc/zmailer/forms/wrongname
@@ -91,7 +89,6 @@ etc/zmailer/cf/proto/p-uucp.cf.md5
etc/zmailer/cf/proto/p-usenet.cf.md5
etc/zmailer/cf/proto/p-smtp.cf.md5
etc/zmailer/cf/proto/p-routes.cf.md5
-etc/zmailer/cf/proto/p-ldap.cf.md5
etc/zmailer/cf/proto/p-iproutes.cf.md5
etc/zmailer/cf/proto/p-ean.cf.md5
etc/zmailer/cf/proto/p-bitnet.cf.md5
@@ -116,7 +113,6 @@ etc/zmailer/cf/proto/UTGPU.cf.md5
etc/zmailer/cf/proto/UTAI.cf.md5
etc/zmailer/cf/proto/TELE-FI.cf.md5
etc/zmailer/cf/proto/SMTP.cf.md5
-etc/zmailer/cf/proto/tryme.cf.md5
etc/zmailer/cf/SMTP+UUCP.cf
etc/zmailer/cf/trusted.cf
etc/zmailer/cf/standard.cf
@@ -127,7 +123,6 @@ etc/zmailer/cf/p-uucp.cf
etc/zmailer/cf/p-usenet.cf
etc/zmailer/cf/p-smtp.cf
etc/zmailer/cf/p-routes.cf
-etc/zmailer/cf/p-ldap.cf
etc/zmailer/cf/p-iproutes.cf
etc/zmailer/cf/p-ean.cf
etc/zmailer/cf/p-bitnet.cf
@@ -152,7 +147,6 @@ etc/zmailer/cf/UTGPU.cf
etc/zmailer/cf/UTAI.cf
etc/zmailer/cf/TELE-FI.cf
etc/zmailer/cf/SMTP.cf
-etc/zmailer/cf/tryme.cf
etc/zmailer/scheduler.conf
etc/zmailer/sm.conf
etc/zmailer/smtpserver.conf
@@ -184,7 +178,6 @@ etc/zmailer/forms/proto/loopexceeded
etc/zmailer/forms/proto/nonewsgroup
etc/zmailer/forms/proto/norealname
etc/zmailer/forms/proto/norecipients
-etc/zmailer/forms/proto/nosuchuser
etc/zmailer/forms/proto/unresolvable
etc/zmailer/forms/proto/vms-in-pros
etc/zmailer/forms/proto/wrongname
@@ -200,6 +193,7 @@ etc/zmailer/guides/smtpauth-login-pam-support
etc/zmailer/guides/smtp-policy
etc/zmailer/guides/smtp-msa-mode
etc/zmailer/guides/smtp-etrn
+etc/zmailer/guides/smtpserver-spf
etc/zmailer/guides/scheduler-ta-protocol
etc/zmailer/guides/relations
etc/zmailer/guides/procmail
@@ -229,7 +223,6 @@ etc/zmailer/cf/proto/p-uucp.cf
etc/zmailer/cf/proto/p-usenet.cf
etc/zmailer/cf/proto/p-smtp.cf
etc/zmailer/cf/proto/p-routes.cf
-etc/zmailer/cf/proto/p-ldap.cf
etc/zmailer/cf/proto/p-iproutes.cf
etc/zmailer/cf/proto/p-ean.cf
etc/zmailer/cf/proto/p-bitnet.cf
@@ -254,7 +247,6 @@ etc/zmailer/cf/proto/UTGPU.cf
etc/zmailer/cf/proto/UTAI.cf
etc/zmailer/cf/proto/TELE-FI.cf
etc/zmailer/cf/proto/SMTP.cf
-etc/zmailer/cf/proto/tryme.cf
etc/zmailer/vacation.msg
etc/zmailer/mail.conf.sample
@exec mkdir -p %D/etc/zmailer/lists
@@ -276,7 +268,6 @@ etc/zmailer/mail.conf.sample
@dirrm etc/zmailer/bak
@dirrm etc/zmailer
@unexec /bin/rm -f %D/bin/vacation
-etc/rc.d/zmailer.sh.sample
lib/libzmailer.a
sbin/autoanswer.pl
sbin/bitbucket
@@ -308,6 +299,7 @@ sbin/smtpserver-log-parser.pl
sbin/vacation.exe
sbin/vacation.sh
sbin/zmailer
+sbin/zrfilter
sbin/ta/bitbucket
sbin/ta/errormail
sbin/ta/expirer