aboutsummaryrefslogtreecommitdiff
path: root/mail/zmailer
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-02-22 06:30:12 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-02-22 06:30:12 +0000
commit123eedc0315e933910614f316b012eddc235580d (patch)
tree8a94f08114dee190bdd6ccef2ddec7fc3d700f10 /mail/zmailer
parent62eda254b9d11cf23ede53c1757187e5a59eda56 (diff)
downloadports-123eedc0315e933910614f316b012eddc235580d.tar.gz
ports-123eedc0315e933910614f316b012eddc235580d.zip
Notes
Diffstat (limited to 'mail/zmailer')
-rw-r--r--mail/zmailer/Makefile14
-rw-r--r--mail/zmailer/files/patch-ab41
2 files changed, 50 insertions, 5 deletions
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index f771e6f2cd46..9467eb447fe0 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -13,7 +13,17 @@ MASTER_SITES= ftp://ftp.funet.fi/pub/unix/mail/zmailer/src/
MAINTAINER= veers@disturbed.net
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}/ \
+
+.if defined(USE_SSL)
+USE_OPENSSL= RSA
+CONFIGURE_ARGS= --with-openssl
+.else
+CONFIGURE_ARGS= --without-openssl
+.endif
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS+= --prefix=${PREFIX}/ \
--with-bundled-libresolv \
--with-mailbin=${PREFIX}/sbin \
--with-mailbox=/var/mail \
@@ -108,4 +118,4 @@ replace:
${LN} -s ${PREFIX}/sbin/rmail /bin/rmail; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/zmailer/files/patch-ab b/mail/zmailer/files/patch-ab
index 96afbca5c3ab..6f905021ba20 100644
--- a/mail/zmailer/files/patch-ab
+++ b/mail/zmailer/files/patch-ab
@@ -1,6 +1,15 @@
---- configure Mon Jul 19 15:59:43 1999
-+++ configure Mon Jul 19 15:59:57 1999
-@@ -4661,7 +4661,7 @@
+--- configure.orig Mon Jul 19 03:48:10 1999
++++ configure Thu Feb 17 19:10:58 2000
+@@ -94,6 +94,8 @@
+ --with-getpwnam-library=\"-L.. -l..\"
+ Linking options for non-std getpwnam() libraries"
+ ac_help="$ac_help
++ --with-openssl Use openssl"
++ac_help="$ac_help
+ --with-openssl-prefix=/dir/path (defines both include and lib)"
+ ac_help="$ac_help
+ --with-openssl-include=/dir/incl/path"
+@@ -4661,7 +4663,7 @@
done
if test "$ac_cv_header_security_pam_appl_h" = "yes"; then
@@ -9,3 +18,29 @@
else
if test "$ac_cv_header_shadow_h" = "yes"; then
AUTHLIB="-lshadow"
+@@ -7847,6 +7849,9 @@
+
+
+
++# Check whether we are using openssl.
++if test "x$with_openssl" != xno; then
++
+ # Check whether --with-openssl-prefix or --without-openssl-prefix was given.
+ if test "${with_openssl_prefix+set}" = set; then
+ withval="$with_openssl_prefix"
+@@ -7929,12 +7934,13 @@
+ OPENSSLPREFIX="/usr"
+ OPENSSLINCL=""
+ if test -f "$OPENSSLPREFIX/lib/libssl.so" ; then
+- OPENSSLLIB="$OPENSSLPREFIX/lib/libssl.so $OPENSSLPREFIX/lib/libcrypto.so"
++ OPENSSLLIB="$OPENSSLPREFIX/lib/libssl.so $OPENSSLPREFIX/lib/libcrypto.so \$(EXTRA_SSL_LIBS)"
+ else
+- OPENSSLLIB="$OPENSSLPREFIX/lib/libssl.a $OPENSSLPREFIX/lib/libcrypto.a"
++ OPENSSLLIB="$OPENSSLPREFIX/lib/libssl.a $OPENSSLPREFIX/lib/libcrypto.a \$(EXTRA_SSL_LIBS)"
+ fi
+ echo "$ac_t""You have OpenSSL version 0.9.3a (or newer) at system root!" 1>&6
+ fi
++fi
+ fi
+
+