aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2007-06-26 08:08:56 +0000
committerAnders Nordby <anders@FreeBSD.org>2007-06-26 08:08:56 +0000
commit05399447ff6102854158310f4eab91a49c4515b3 (patch)
tree9fcdaf2f3515dbd7c529d95ddccb5b515b4c9601 /mail
parent8b80fc98bf6cf0bd78586a52e1841e6277a725c8 (diff)
downloadports-05399447ff6102854158310f4eab91a49c4515b3.tar.gz
ports-05399447ff6102854158310f4eab91a49c4515b3.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/cclient/Makefile9
-rw-r--r--mail/imap-uw/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index e57f4caf10cd..0deb781608f3 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -20,6 +20,11 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= anders@FreeBSD.org
COMMENT= Mark Crispin's C-client mail access routines
+OPTIONS= SSL "Compile with SSL support" on \
+ SSL_AND_PLAINTEXT "Allow plain text passwords and SSL" off \
+ IPV6 "Support IPv6" on \
+ MBX_DEFAULT "Use MBX as default mailbox format" off
+
USE_LDCONFIG= yes
ALL_TARGET= bsf
.if defined(WITHOUT_SSL)
@@ -53,6 +58,10 @@ post-patch:
@${REINPLACE_CMD} -e "s|^IP=4|IP=6|" ${WRKSRC}/Makefile \
${WRKSRC}/src/osdep/unix/Makefile
.endif
+.if defined(WITH_MBX_DEFAULT)
+ @${REINPLACE_CMD} -e "s|^CREATEPROTO=unixproto|CREATEPROTO=mbxproto|" \
+ ${WRKSRC}/src/osdep/unix/Makefile
+.endif
post-configure:
@${ECHO_MSG} ">> The c-client shared library will be named ${SHLIBNAME}"
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index f0fa403e0cc8..b8f127703b4d 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -22,6 +22,15 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= anders@FreeBSD.org
COMMENT= University of Washington IMAP4rev1/POP2/POP3 mail servers
+# This port must have the same SSL settings as mail/cclient, which it depends on
+# To make MBX format the default mailbox format, change the settings of cclient
+
+OPTIONS= SSL "Compile with SSL support" on \
+ SSL_AND_PLAINTEXT "Allow plain text passwords and SSL" off \
+ DRAC "Dynamically open MTA for relaying" off \
+ NETSCAPE_BRAIN_DAMAGE "See Makefile for documentation" off \
+ ENTOURAGE_BRAIN_DAMAGE "See Makefile for documentation" off
+
LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
.if defined(WITH_DRAC)
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac