aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-04-13 19:06:16 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-04-13 19:06:16 +0000
commit20a8b67cd4fb713267333ca37d5b7c9303d91c0f (patch)
tree4b5e3619f6e3e18bb9f4e3ee95a2c2a7e9e065bb /mail
parent8369d786988cb9f576e9d173df6abd0d677ba6a0 (diff)
downloadports-20a8b67cd4fb713267333ca37d5b7c9303d91c0f.tar.gz
ports-20a8b67cd4fb713267333ca37d5b7c9303d91c0f.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/lmtp2nntp/Makefile12
-rw-r--r--mail/lmtp2nntp/files/patch-configure15
-rw-r--r--mail/lmtp2nntp/files/patch-l2_ut_format.c15
-rw-r--r--mail/lmtp2nntp/files/patch-ts.c14
4 files changed, 54 insertions, 2 deletions
diff --git a/mail/lmtp2nntp/Makefile b/mail/lmtp2nntp/Makefile
index 536713b0e6d1..107ee5a36549 100644
--- a/mail/lmtp2nntp/Makefile
+++ b/mail/lmtp2nntp/Makefile
@@ -7,20 +7,28 @@
PORTNAME= lmtp2nntp
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= mail news
MASTER_SITES= ftp://ftp.ossp.org/pkg/tool/lmtp2nntp/
MAINTAINER= ports@FreeBSD.org
COMMENT= "OSSP mail to news gateway"
+LIB_DEPENDS= str.9:${PORTSDIR}/devel/str \
+ ex.10:${PORTSDIR}/devel/ossp-ex \
+ sa.12:${PORTSDIR}/net/ossp-sa \
+ var.11:${PORTSDIR}/devel/ossp-var
+
MAN8= lmtp2nntp.8
PLIST_FILES= sbin/lmtp2nntp
HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ex="${LOCALBASE}" --with-str="${LOCALBASE}" \
+ --with-sa="${LOCALBASE}" --with-var="${LOCALBASE}"
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" || ${ARCH} == "amd64"
-BROKEN= "Does not compile on alpha and amd64"
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
.endif
.include <bsd.port.post.mk>
diff --git a/mail/lmtp2nntp/files/patch-configure b/mail/lmtp2nntp/files/patch-configure
new file mode 100644
index 000000000000..94dc2ec1cb13
--- /dev/null
+++ b/mail/lmtp2nntp/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig Thu Feb 13 11:01:47 2003
++++ configure Tue Apr 13 20:58:41 2004
+@@ -5845,9 +5845,9 @@
+ SUBDIR_POPT=""
+ else
+ SUBDIR_POPT="lib_popt"
+- CPPFLAGS="$CPPFLAGS -Ilib_popt"
+- CFLAGS="$CFLAGS -Ilib_popt"
+- LDFLAGS="$LDFLAGS -Llib_popt/.libs"
++ CPPFLAGS="-Ilib_popt $CPPFLAGS"
++ CFLAGS="-Ilib_popt $CFLAGS"
++ LDFLAGS="-Llib_popt/.libs $LDFLAGS"
+ LIBS_EXTRA="$LIBS_EXTRA -lpopt"
+ fi
+ echo "$as_me:$LINENO: result: $with_popt" >&5
diff --git a/mail/lmtp2nntp/files/patch-l2_ut_format.c b/mail/lmtp2nntp/files/patch-l2_ut_format.c
new file mode 100644
index 000000000000..99777bbd96ad
--- /dev/null
+++ b/mail/lmtp2nntp/files/patch-l2_ut_format.c
@@ -0,0 +1,15 @@
+--- l2_ut_format.c.orig Tue Apr 13 19:04:15 2004
++++ lib_l2/l2_ut_format.c Tue Apr 13 19:05:59 2004
+@@ -1131,8 +1131,11 @@
+ va_list apbak;
+ char *s;
+ int rv;
+-
++#ifdef __amd64__
++ va_copy(apbak,ap);
++#else
+ apbak = ap;
++#endif
+ if ((rv = l2_util_vsprintf(NULL, -1, fmt, ap)) == -1)
+ return NULL;
+ if ((s = malloc(rv+1)) == NULL)
diff --git a/mail/lmtp2nntp/files/patch-ts.c b/mail/lmtp2nntp/files/patch-ts.c
new file mode 100644
index 000000000000..d7963d364c7e
--- /dev/null
+++ b/mail/lmtp2nntp/files/patch-ts.c
@@ -0,0 +1,14 @@
+--- ts.c.orig Tue Apr 13 19:32:20 2004
++++ lib_tai/ts.c Tue Apr 13 19:32:46 2004
+@@ -206,7 +206,11 @@
+
+ if (format == NULL)
+ return NULL;
++#ifdef __amd64__
++ va_copy(ap2,ap);
++#else
+ ap2 = ap;
++#endif
+ if ((n = ts_suite_mvxprintf(NULL, 0, format, ap)) == -1)
+ return NULL;
+ if ((buffer = (char *)malloc(n+1)) == NULL)