aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-12-31 09:52:05 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-12-31 09:52:05 +0000
commit3f88fb5e9a46ae271fc41ddb2f8f3d6a57b40531 (patch)
treed16ce4d9bbfedfe661a61d19b72d50f1198e9fab /mail
parentaf5da91b83ee04978e8ff08083b1ac7576da8cea (diff)
downloadports-3f88fb5e9a46ae271fc41ddb2f8f3d6a57b40531.tar.gz
ports-3f88fb5e9a46ae271fc41ddb2f8f3d6a57b40531.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/sendmail/Makefile3
-rw-r--r--mail/sendmail/distinfo6
-rw-r--r--mail/sendmail/files/patch-worker.c75
3 files changed, 4 insertions, 80 deletions
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index 7065d22295f2..867791513acb 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sendmail
-PORTVERSION= 8.14.3
-PORTREVISION= 1
+PORTVERSION= 8.14.4
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/mail/sendmail/&,}
diff --git a/mail/sendmail/distinfo b/mail/sendmail/distinfo
index 4b20487b6cb5..c2b0d1e3305a 100644
--- a/mail/sendmail/distinfo
+++ b/mail/sendmail/distinfo
@@ -1,3 +1,3 @@
-MD5 (sendmail.8.14.3.tar.gz) = a5ee5d26e1f546a2da5fb9a513bd6bce
-SHA256 (sendmail.8.14.3.tar.gz) = 5cc69cdc055b587cbedad4efbf17c1dfc52a6ae18ec83a3d2e83e5f5fcdc119b
-SIZE (sendmail.8.14.3.tar.gz) = 2069209
+MD5 (sendmail.8.14.4.tar.gz) = 1b23d5000c8e7bfe82ec1a27f2f5fdc5
+SHA256 (sendmail.8.14.4.tar.gz) = bc0109437c5018b3ea8999edb63506db2f3b31c4c1ab4367cb56236a7df97cb1
+SIZE (sendmail.8.14.4.tar.gz) = 2080472
diff --git a/mail/sendmail/files/patch-worker.c b/mail/sendmail/files/patch-worker.c
deleted file mode 100644
index 9513292c5508..000000000000
--- a/mail/sendmail/files/patch-worker.c
+++ /dev/null
@@ -1,75 +0,0 @@
---- libmilter/worker.c.orig 2007-12-03 23:06:05.000000000 +0100
-+++ libmilter/worker.c 2009-06-15 09:46:29.000000000 +0200
-@@ -328,6 +328,8 @@
- int dim_pfd = 0;
- bool rebuild_set = true;
- int pcnt = 0; /* error count for poll() failures */
-+ time_t lastcheck;
-+ int nfd = 0;
-
- Tskmgr.tm_tid = sthread_get_id();
- if (pthread_detach(Tskmgr.tm_tid) != 0)
-@@ -345,12 +347,12 @@
- }
- dim_pfd = PFD_STEP;
-
-+ lastcheck = time(NULL);
- for (;;)
- {
- SMFICTX_PTR ctx;
-- int nfd, rfd, i;
-+ int rfd, i;
- time_t now;
-- time_t lastcheck;
-
- POOL_LEV_DPRINTF(4, ("Let's %s again...", WAITFN));
-
-@@ -364,20 +366,20 @@
- /* check for timed out sessions? */
- if (lastcheck + DT_CHECK_OLD_SESSIONS < now)
- {
-- SM_TAILQ_FOREACH(ctx, &WRK_CTX_HEAD, ctx_link)
-+ ctx = SM_TAILQ_FIRST(&WRK_CTX_HEAD);
-+ while (ctx != SM_TAILQ_END(&WRK_CTX_HEAD))
- {
-+ SMFICTX_PTR ctx_nxt;
-+
-+ ctx_nxt = SM_TAILQ_NEXT(ctx, ctx_link);
- if (ctx->ctx_wstate == WKST_WAITING)
- {
- if (ctx->ctx_wait == 0)
-- {
- ctx->ctx_wait = now;
-- continue;
-- }
--
-- /* if session timed out, close it */
-- if (ctx->ctx_wait + OLD_SESSION_TIMEOUT
-- < now)
-+ else if (ctx->ctx_wait + OLD_SESSION_TIMEOUT
-+ < now)
- {
-+ /* if session timed out, close it */
- sfsistat (*fi_close) __P((SMFICTX *));
-
- POOL_LEV_DPRINTF(4,
-@@ -389,10 +391,9 @@
- (void) (*fi_close)(ctx);
-
- mi_close_session(ctx);
-- ctx = SM_TAILQ_FIRST(&WRK_CTX_HEAD);
-- continue;
- }
- }
-+ ctx = ctx_nxt;
- }
- lastcheck = now;
- }
-@@ -465,6 +466,7 @@
- }
- }
- }
-+ rebuild_set = false;
- }
-
- TASKMGR_UNLOCK();