aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-03-15 14:08:07 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-03-15 14:08:07 +0000
commit57644bc72928c66c054ff6c90bcc44b8daec5cff (patch)
treeaf636ede699584fc8e5daf2dcd195bed4c070347 /mail
parent2f14e41cfa87b31807370584496e3fa6eeed80e6 (diff)
downloadports-57644bc72928c66c054ff6c90bcc44b8daec5cff.tar.gz
ports-57644bc72928c66c054ff6c90bcc44b8daec5cff.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix-policyd-weight/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/mail/postfix-policyd-weight/Makefile b/mail/postfix-policyd-weight/Makefile
index a342513ab94a..8402058c0358 100644
--- a/mail/postfix-policyd-weight/Makefile
+++ b/mail/postfix-policyd-weight/Makefile
@@ -3,7 +3,7 @@
PORTNAME= policyd-weight
PORTVERSION= 0.1.15.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://www.policyd-weight.org/releases/ \
LOCAL/ohauer
@@ -12,41 +12,39 @@ PKGNAMEPREFIX= postfix-
MAINTAINER= ohauer@FreeBSD.org
COMMENT= Weighted policy daemon for postfix
+LICENSE= GPLv2
+
RUN_DEPENDS= p5-Net-DNS>0:${PORTSDIR}/dns/p5-Net-DNS \
p5-Net-IP>0:${PORTSDIR}/net-mgmt/p5-Net-IP
SUB_FILES= pkg-message
-PLIST_FILES= bin/${PORTNAME} etc/${PORTNAME}.conf.sample
+PLIST_FILES= bin/${PORTNAME} etc/${PORTNAME}.conf.sample \
+ man/man5/policyd-weight.conf.5.gz \
+ man/man8/policyd-weight.8.gz \
USERS= polw
GROUPS= polw
USE_RC_SUBR+= policyd-weight
USES= perl5
+USE_PERL5= run
NO_BUILD= yes
-MAN8+= policyd-weight.8
-MAN5+= policyd-weight.conf.5
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
# really remove dead lists
# SFNET bug ID: 2765629, 3400804
# rfc-ignorant: all entrieys will be marked as deprecated starting on 2012-09-30
+# njabl.org: NJABL is offline
@${REINPLACE_CMD} -e '/DSBL_ORG/d' -e '/IPv6_RBL/d' -e '/rfc-ignorant/d' \
- -e '/IX_MANITU/ s/,$$//' -e '/AHBL/ s/,$$//' \
+ -e '/BL_NJABL/d' -e '/IX_MANITU/ s/,$$//' -e '/AHBL/ s/,$$//' \
${WRKSRC}/policyd-weight ${WRKSRC}/policyd-weight.conf.sample
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${PREFIX}/etc/
-
- ${INSTALL_MAN} ${WRKSRC}/man/man5/${MAN5} ${PREFIX}/man/man5/
- ${INSTALL_MAN} ${WRKSRC}/man/man8/${MAN8} ${PREFIX}/man/man8/
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${STAGEDIR}${PREFIX}/etc/
+ ${INSTALL_MAN} ${WRKSRC}/man/man5/policyd-weight.conf.5 ${STAGEDIR}${MAN5PREFIX}/man/man5/
+ ${INSTALL_MAN} ${WRKSRC}/man/man8/policyd-weight.8 ${STAGEDIR}${MAN8PREFIX}/man/man8/
.include <bsd.port.post.mk>