aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-18 19:53:29 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-18 19:53:29 +0000
commit66ba84b8e457e2dc463bbf8cddbe25994674efdb (patch)
tree73ae98bb0f2f1e8abda370676cb7e868c4e146a8 /mail
parentab01d529d276e79f99a3b5146347f7ae474abe58 (diff)
downloadports-66ba84b8e457e2dc463bbf8cddbe25994674efdb.tar.gz
ports-66ba84b8e457e2dc463bbf8cddbe25994674efdb.zip
Add p5-Mail-Box-POP3 3.004 (copied from p5-Mail-Box)
Maintain a folder which has its messages stored on a remote server. The communication between the client application and the server is implemented using the POP3 protocol. This class uses Mail::Transport::POP3 to hide the transport of information, and focusses solely on the correct handling of messages within a POP3 folder. WWW: https://metacpan.org/release/Mail-Box-POP3
Notes
Notes: svn path=/head/; revision=482363
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Mail-Box-POP3/Makefile26
-rw-r--r--mail/p5-Mail-Box-POP3/distinfo3
-rw-r--r--mail/p5-Mail-Box-POP3/pkg-descr7
-rw-r--r--mail/p5-Mail-Box-POP3/pkg-plist13
5 files changed, 50 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 44ab0981aaa0..2e180320cc66 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -381,6 +381,7 @@
SUBDIR += p5-Mail-Box
SUBDIR += p5-Mail-Box-IMAP4
SUBDIR += p5-Mail-Box-IMAP4-SSL
+ SUBDIR += p5-Mail-Box-POP3
SUBDIR += p5-Mail-Box-Parser-C
SUBDIR += p5-Mail-Bulkmail
SUBDIR += p5-Mail-CheckUser
diff --git a/mail/p5-Mail-Box-POP3/Makefile b/mail/p5-Mail-Box-POP3/Makefile
new file mode 100644
index 000000000000..ff3a09041bbb
--- /dev/null
+++ b/mail/p5-Mail-Box-POP3/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Mail-Box-POP3
+PORTVERSION= 3.004
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Handle POP3 folders as client
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Mail-Box>=3:mail/p5-Mail-Box \
+ p5-Mail-Message>=3:mail/p5-Mail-Message \
+ p5-Mail-Transport>=3:mail/p5-Mail-Transport
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-Box-POP3/distinfo b/mail/p5-Mail-Box-POP3/distinfo
new file mode 100644
index 000000000000..2b71d7807059
--- /dev/null
+++ b/mail/p5-Mail-Box-POP3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539194186
+SHA256 (Mail-Box-POP3-3.004.tar.gz) = da92bbf67f2ba2d319f709fda43980816052b66444061afe92026902c094b568
+SIZE (Mail-Box-POP3-3.004.tar.gz) = 31599
diff --git a/mail/p5-Mail-Box-POP3/pkg-descr b/mail/p5-Mail-Box-POP3/pkg-descr
new file mode 100644
index 000000000000..9c99ce002cb6
--- /dev/null
+++ b/mail/p5-Mail-Box-POP3/pkg-descr
@@ -0,0 +1,7 @@
+Maintain a folder which has its messages stored on a remote server. The
+communication between the client application and the server is implemented using
+the POP3 protocol. This class uses Mail::Transport::POP3 to hide the transport
+of information, and focusses solely on the correct handling of messages within a
+POP3 folder.
+
+WWW: https://metacpan.org/release/Mail-Box-POP3
diff --git a/mail/p5-Mail-Box-POP3/pkg-plist b/mail/p5-Mail-Box-POP3/pkg-plist
new file mode 100644
index 000000000000..6e46289694c0
--- /dev/null
+++ b/mail/p5-Mail-Box-POP3/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Mail/Box/POP3.pm
+%%SITE_PERL%%/Mail/Box/POP3.pod
+%%SITE_PERL%%/Mail/Box/POP3/Message.pm
+%%SITE_PERL%%/Mail/Box/POP3/Message.pod
+%%SITE_PERL%%/Mail/Box/POP3/Test.pm
+%%SITE_PERL%%/Mail/Box/POP3s.pm
+%%SITE_PERL%%/Mail/Box/POP3s.pod
+%%SITE_PERL%%/Mail/Transport/POP3.pm
+%%SITE_PERL%%/Mail/Transport/POP3.pod
+%%PERL5_MAN3%%/Mail::Box::POP3.3.gz
+%%PERL5_MAN3%%/Mail::Box::POP3::Message.3.gz
+%%PERL5_MAN3%%/Mail::Box::POP3s.3.gz
+%%PERL5_MAN3%%/Mail::Transport::POP3.3.gz