aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-10-26 14:40:54 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-10-26 14:40:54 +0000
commit8225837c5ec5b630b863cf530ab2ae7378ad11a0 (patch)
treece0e19793891ec79ccd3d16f4affa42bdadcff7d /mail
parentea0dbea90544f4fe4dc98adffc7094e61ef16506 (diff)
downloadports-8225837c5ec5b630b863cf530ab2ae7378ad11a0.tar.gz
ports-8225837c5ec5b630b863cf530ab2ae7378ad11a0.zip
Fix build with GCC-based architectures. GCC architectures require
CFLAGS+=-fnested-functions. PR: 232646 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> MFH: 2018Q4 (blanket)
Notes
Notes: svn path=/head/; revision=483035
Diffstat (limited to 'mail')
-rw-r--r--mail/milter-callback/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/mail/milter-callback/Makefile b/mail/milter-callback/Makefile
index 6cd57b5e393a..88dbd24b5d94 100644
--- a/mail/milter-callback/Makefile
+++ b/mail/milter-callback/Makefile
@@ -12,10 +12,6 @@ COMMENT= Milter to perform a envelope-from sender verification on target MX
LICENSE= GPLv3
-BROKEN_mips= fails to build: error: nested functions are disabled, use -fnested-functions to re-enable
-BROKEN_mips64= fails to build: error: nested functions are disabled, use -fnested-functions to re-enable
-BROKEN_powerpc64= fails to build: error: nested functions are disabled, use -fnested-functions to re-enable
-
LIB_DEPENDS= libspf2.so:mail/libspf2
USES= tar:xz
@@ -30,6 +26,12 @@ SRC_FILES= cache.c commonprocs.c cpit.c dealwithmxes.c detectlamespf.c \
CFLAGS+= -DFREEBSD -DHAVE_NS_TYPE -DWITH_SPF -I${LOCALBASE}/include \
-I${WRKSRC} -std=gnu99
+CFLAGS_mips= -fnested-functions
+CFLAGS_mips64= -fnested-functions
+CFLAGS_powerpc= -fnested-functions
+CFLAGS_powerpcspe= -fnested-functions
+CFLAGS_powerpc64= -fnested-functions
+CFLAGS_sparc64= -fnested-functions
LDFLAGS+= -lmilter -lthr -L${LOCALBASE}/lib -lspf2
do-build: