aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-02-01 02:42:05 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-02-01 02:42:05 +0000
commitae994c8ea8a59644c1a1406b0b6547826bc12791 (patch)
tree396acb34b10ac8f349be827c6eb833e0fd68cdff /mail
parent2c5b5e25ddd43be1ce0fe90095ab5746c431b5b4 (diff)
downloadports-ae994c8ea8a59644c1a1406b0b6547826bc12791.tar.gz
ports-ae994c8ea8a59644c1a1406b0b6547826bc12791.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/gmime/Makefile1
-rw-r--r--mail/jamlib/Makefile1
-rw-r--r--mail/libnewmail/Makefile2
-rw-r--r--mail/libspf-alt/Makefile1
-rw-r--r--mail/libspf-alt/pkg-plist1
-rw-r--r--mail/libspf2/Makefile1
-rw-r--r--mail/libsrs2/Makefile1
-rw-r--r--mail/libsrs_alt/Makefile1
-rw-r--r--mail/perdition/Makefile1
-rw-r--r--mail/pop3lite/Makefile1
-rw-r--r--mail/whoson/Makefile1
-rw-r--r--mail/xfmail/Makefile1
-rw-r--r--mail/xfmail/pkg-plist2
13 files changed, 14 insertions, 1 deletions
diff --git a/mail/gmime/Makefile b/mail/gmime/Makefile
index 2204eb941af9..fb8585d71fba 100644
--- a/mail/gmime/Makefile
+++ b/mail/gmime/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Library (written in C) for parsing and creating messages using MIME
CONFLICTS= gmime-2.1.*
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= YES
USE_GMAKE= YES
USE_GNOME= glib12
diff --git a/mail/jamlib/Makefile b/mail/jamlib/Makefile
index 99fa3fede3ae..b49f1363a5d1 100644
--- a/mail/jamlib/Makefile
+++ b/mail/jamlib/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= jamlib
MAINTAINER= ports@FreeBSD.org
COMMENT= A JAM subroutine library
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
NO_INSTALL_MANPAGES= yes
diff --git a/mail/libnewmail/Makefile b/mail/libnewmail/Makefile
index fa90f0820bca..8925819c0f35 100644
--- a/mail/libnewmail/Makefile
+++ b/mail/libnewmail/Makefile
@@ -18,7 +18,7 @@ COMMENT= Generic mail checking library
LIB_DEPENDS= gnutls.15:${PORTSDIR}/security/gnutls \
oop.4:${PORTSDIR}/devel/liboop
-USE_AUTOTOOLS= libltdl:15
+USE_AUTOTOOLS= libltdl:15 libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/libspf-alt/Makefile b/mail/libspf-alt/Makefile
index de324b7ba758..915e96cf2250 100644
--- a/mail/libspf-alt/Makefile
+++ b/mail/libspf-alt/Makefile
@@ -17,6 +17,7 @@ COMMENT= Library that allows email systems such as Exim to check SPF records
DEPRECATED= Superceded by mail/libspf2
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_ICONV= yes
USE_GETTEXT= yes
diff --git a/mail/libspf-alt/pkg-plist b/mail/libspf-alt/pkg-plist
index 486594296f25..791f961232e7 100644
--- a/mail/libspf-alt/pkg-plist
+++ b/mail/libspf-alt/pkg-plist
@@ -18,5 +18,6 @@ include/spf_alt/spf_dns_zone.h
include/spf_alt/spf_lib_version.h
@dirrm include/spf_alt
lib/libspf_alt.a
+lib/libspf_alt.la
lib/libspf_alt.so
lib/libspf_alt.so.1
diff --git a/mail/libspf2/Makefile b/mail/libspf2/Makefile
index beb9c10084fd..8e2c5eefe68d 100644
--- a/mail/libspf2/Makefile
+++ b/mail/libspf2/Makefile
@@ -17,6 +17,7 @@ COMMENT= Sender Rewriting Scheme 2 C Implementation
CONFLICTS= ${PORTNAME}-1.0.*
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/mail/libsrs2/Makefile b/mail/libsrs2/Makefile
index 307bd40ff37c..d33e6398f35d 100644
--- a/mail/libsrs2/Makefile
+++ b/mail/libsrs2/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= srs
MAINTAINER= ports@FreeBSD.org
COMMENT= Sender Rewriting Scheme 2 C Implementation
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/mail/libsrs_alt/Makefile b/mail/libsrs_alt/Makefile
index 4fdf361f40d4..2da7d5d795f4 100644
--- a/mail/libsrs_alt/Makefile
+++ b/mail/libsrs_alt/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://srs.mirtol.com/
MAINTAINER= simond@irrelevant.org
COMMENT= Sender Rewriting Scheme C Implementation
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
INSTALLS_SHLIB= yes
SHLIB_MAJOR= 1
diff --git a/mail/perdition/Makefile b/mail/perdition/Makefile
index fb32c512ee9d..14ee9b5c5687 100644
--- a/mail/perdition/Makefile
+++ b/mail/perdition/Makefile
@@ -23,6 +23,7 @@ MAN8= perdition.8
MANCOMPRESSED= no
+USE_AUTOTOOLS= libtool:15
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" BDB_LIB=db3
diff --git a/mail/pop3lite/Makefile b/mail/pop3lite/Makefile
index a98a9736a612..2c2a619e2769 100644
--- a/mail/pop3lite/Makefile
+++ b/mail/pop3lite/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A flexible, modular RFC-compliant POP3 daemon
+USE_AUTOTOOLS= libtool:15
USE_GNOME= glib12
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/mail/whoson/Makefile b/mail/whoson/Makefile
index dc08d4ab9c60..ffc1689828de 100644
--- a/mail/whoson/Makefile
+++ b/mail/whoson/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sem@FreeBSD.org
COMMENT= `WHO iS ONline' protocol implementation
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-config=${PREFIX}/etc/whoson.conf
diff --git a/mail/xfmail/Makefile b/mail/xfmail/Makefile
index a0ed7b5ec612..d2aca9a77dde 100644
--- a/mail/xfmail/Makefile
+++ b/mail/xfmail/Makefile
@@ -20,6 +20,7 @@ COMMENT= An X Window System application for receiving electronic mail
LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms \
gdbm.3:${PORTSDIR}/databases/gdbm
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GNOME= glib12
USE_GMAKE= yes
diff --git a/mail/xfmail/pkg-plist b/mail/xfmail/pkg-plist
index aa4510cc0989..2f79c6286e8c 100644
--- a/mail/xfmail/pkg-plist
+++ b/mail/xfmail/pkg-plist
@@ -1,8 +1,10 @@
bin/xfmail
lib/libxfeditor.a
+lib/libxfeditor.la
lib/libxfeditor.so
lib/libxfeditor.so.0
lib/libmail.a
+lib/libmail.la
lib/libmail.so
lib/libmail.so.0
share/xfmail/abook.xpm