aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2018-10-20 10:19:29 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2018-10-20 10:19:29 +0000
commitd32f47f8288193d64eff89f0a244159860205d5c (patch)
treed05cc6f068180f315893ef5c1e8ea048ff89ca44 /mail
parent0e4506d5fe74ac75244f241f9679431e00f99383 (diff)
downloadports-d32f47f8288193d64eff89f0a244159860205d5c.tar.gz
ports-d32f47f8288193d64eff89f0a244159860205d5c.zip
Fixed problems with OpenSSL 1.1.1 and an error message regarding lua.
PR: 223568 Submitted by: freebsd-ports@dan.me.uk Reported by: pi@FreeBSD.org Reviewed by: mfechner@FreeBSD.org Approved by: mentors (implicit)
Notes
Notes: svn path=/head/; revision=482481
Diffstat (limited to 'mail')
-rw-r--r--mail/opendkim/Makefile12
-rw-r--r--mail/opendkim/files/patch-libopendkim__tests__Makefile.in2
-rw-r--r--mail/opendkim/files/patch-libopendkim_dkim-canon.c4
-rw-r--r--mail/opendkim/files/patch-opendkim__tests__Makefile.in2
4 files changed, 8 insertions, 12 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index cf7afb254941..9abe740f48e0 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opendkim
PORTVERSION= 2.10.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= mail security
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/Previous%20Releases \
@@ -20,12 +20,9 @@ LICENSE_GROUPS_SENDMAIL=FSF OSI
LICENSE_NAME_SENDMAIL= Sendmail Open Source License
LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= checking for library containing SSL_library_init... no
-
GNU_CONFIGURE= yes
NO_OPTIONS_SORT=yes
-USES= libtool perl5 pkgconfig shebangfix ssl
+USES= autoreconf libtool perl5 pkgconfig shebangfix ssl
USE_PERL5= run
SHEBANG_FILES= opendkim/opendkim-genkey* reputation/opendkim-* stats/opendkim-* \
reprrd/opendkim-reprrdimport*
@@ -158,10 +155,9 @@ LDFLAGS+= -lpthread
.endif
pre-configure:
- ${REINPLACE_CMD} -e '/LIBLUA_LIBS/s/lua5\.[0-9]/lua-${LUA_VER}/' \
- -e '/PKG_CONFIG/s/lua5\.[0-9]/lua-${LUA_VER}/' \
+ ${REINPLACE_CMD} -e '/PKG_CHECK_MODULES/s/lua5\.[0-9]/lua-${LUA_VER}/' \
-e '/PKG_CONFIG/s/cyrussasl/libsasl2/' \
- ${WRKSRC}/configure
+ ${WRKSRC}/configure.ac
post-patch-LCOV-on:
${CP} ${FILESDIR}/lcov-helper.sh ${WRKSRC}/libopendkim/tests/
diff --git a/mail/opendkim/files/patch-libopendkim__tests__Makefile.in b/mail/opendkim/files/patch-libopendkim__tests__Makefile.in
index 242cdb388596..57f3b1b80fd1 100644
--- a/mail/opendkim/files/patch-libopendkim__tests__Makefile.in
+++ b/mail/opendkim/files/patch-libopendkim__tests__Makefile.in
@@ -1,6 +1,6 @@
--- libopendkim/tests/Makefile.in.orig 2015-05-12 18:43:48 UTC
+++ libopendkim/tests/Makefile.in
-@@ -1108,8 +1108,10 @@ am__nobase_list = $(am__nobase_strip_set
+@@ -1108,8 +1108,10 @@ am__nobase_list = $(am__nobase_strip_setup); \
{ print $$2, files[$$2]; n[$$2] = 0; files[$$2] = "" } } \
END { for (dir in files) print dir, files[dir] }'
am__base_list = \
diff --git a/mail/opendkim/files/patch-libopendkim_dkim-canon.c b/mail/opendkim/files/patch-libopendkim_dkim-canon.c
index 6f5f5439580a..cda4b276cb22 100644
--- a/mail/opendkim/files/patch-libopendkim_dkim-canon.c
+++ b/mail/opendkim/files/patch-libopendkim_dkim-canon.c
@@ -1,6 +1,6 @@
---- libopendkim/dkim-canon.c.orig 2015-08-26 08:37:01 UTC
+--- libopendkim/dkim-canon.c.orig 2015-05-11 03:56:13 UTC
+++ libopendkim/dkim-canon.c
-@@ -388,7 +388,7 @@ dkim_canon_header_string(struct dkim_dst
+@@ -388,7 +388,7 @@ dkim_canon_header_string(struct dkim_dstring *dstr, dk
}
/* skip all spaces before first word */
diff --git a/mail/opendkim/files/patch-opendkim__tests__Makefile.in b/mail/opendkim/files/patch-opendkim__tests__Makefile.in
index 8134aca9b561..b5318fd1a63b 100644
--- a/mail/opendkim/files/patch-opendkim__tests__Makefile.in
+++ b/mail/opendkim/files/patch-opendkim__tests__Makefile.in
@@ -1,6 +1,6 @@
--- opendkim/tests/Makefile.in.orig 2015-05-12 18:43:49 UTC
+++ opendkim/tests/Makefile.in
-@@ -139,8 +139,10 @@ am__nobase_list = $(am__nobase_strip_set
+@@ -139,8 +139,10 @@ am__nobase_list = $(am__nobase_strip_setup); \
{ print $$2, files[$$2]; n[$$2] = 0; files[$$2] = "" } } \
END { for (dir in files) print dir, files[dir] }'
am__base_list = \